summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2009-03-03 19:34:59 +0000
committerDaniel Black <dragonheart@gentoo.org>2009-03-03 19:34:59 +0000
commit7f459fc772311e2c7b58320d19f6beacc24c7e07 (patch)
treeed11e86a976e802e0ffd38919d7ddcdb20f8a44e /net-misc
parentBump to 2.1.4. Thanks to Alessio Cassibba. (diff)
downloadgentoo-2-7f459fc772311e2c7b58320d19f6beacc24c7e07.tar.gz
gentoo-2-7f459fc772311e2c7b58320d19f6beacc24c7e07.tar.bz2
gentoo-2-7f459fc772311e2c7b58320d19f6beacc24c7e07.zip
gentoo bug #260361 - CVE-2009-0037. thanks security team
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/curl/ChangeLog7
-rw-r--r--net-misc/curl/curl-7.19.4.ebuild109
2 files changed, 115 insertions, 1 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index c9bb5dbfad2e..ff4bb74c355f 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/curl
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.137 2009/02/17 17:12:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.138 2009/03/03 19:34:59 dragonheart Exp $
+
+*curl-7.19.4 (03 Mar 2009)
+
+ 03 Mar 2009; Daniel Black <dragonheart@gentoo.org> +curl-7.19.4.ebuild:
+ gentoo bug #260361 - CVE-2009-0037. thanks security team
17 Feb 2009; Raúl Porcel <armin76@gentoo.org> curl-7.19.3.ebuild:
arm/ia64/s390/sh/sparc stable wrt #258618
diff --git a/net-misc/curl/curl-7.19.4.ebuild b/net-misc/curl/curl-7.19.4.ebuild
new file mode 100644
index 000000000000..08bac46a1fcf
--- /dev/null
+++ b/net-misc/curl/curl-7.19.4.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.19.4.ebuild,v 1.1 2009/03/03 19:34:59 dragonheart Exp $
+
+# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
+
+inherit multilib eutils
+
+#MY_P=${P/_pre/-}
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/ http://curl.planetmirror.com"
+#SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
+#SRC_URI="http://curl.planetmirror.com/download/${P}.tar.bz2"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT X11"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+#IUSE="ssl ipv6 ldap ares gnutls nss idn kerberos test"
+IUSE="ssl ipv6 ldap ares gnutls libssh2 nss idn kerberos test"
+
+# TODO - change to openssl USE flag in the not too distant future
+# https://bugs.gentoo.org/show_bug.cgi?id=207653#c3 (April 2008)
+
+RDEPEND="gnutls? ( net-libs/gnutls app-misc/ca-certificates )
+ nss? ( !gnutls? ( dev-libs/nss app-misc/ca-certificates ) )
+ ssl? ( !gnutls? ( !nss? ( dev-libs/openssl app-misc/ca-certificates ) ) )
+ ldap? ( net-nds/openldap )
+ idn? ( net-dns/libidn )
+ ares? ( >=net-dns/c-ares-1.4.0 )
+ kerberos? ( virtual/krb5 )
+ libssh2? ( >=net-libs/libssh2-0.16 )"
+
+# fbopenssl (not in gentoo) --with-spnego
+# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
+
+DEPEND="${RDEPEND}
+ test? (
+ sys-apps/diffutils
+ dev-lang/perl
+ )"
+# used - but can do without in self test: net-misc/stunnel
+#S="${WORKDIR}"/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/curl-7.17.0-strip-ldflags.patch
+}
+
+src_compile() {
+
+ myconf="$(use_enable ldap)
+ $(use_enable ldap ldaps)
+ $(use_with idn libidn)
+ $(use_with kerberos gssapi /usr)
+ $(use_with libssh2)
+ $(use_enable ipv6)
+ --enable-http
+ --enable-ftp
+ --enable-gopher
+ --enable-file
+ --enable-dict
+ --enable-manual
+ --enable-telnet
+ --enable-nonblocking
+ --enable-largefile
+ --enable-maintainer-mode
+ --disable-sspi
+ --without-krb4
+ --without-spnego"
+
+ if use ipv6 && use ares; then
+ elog "c-ares support disabled because it is incompatible with ipv6."
+ myconf="${myconf} --disable-ares"
+ else
+ myconf="${myconf} $(use_enable ares)"
+ fi
+
+ if use gnutls; then
+ myconf="${myconf} --without-ssl --with-gnutls --without-nss"
+ myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
+ elif use nss; then
+ myconf="${myconf} --without-ssl --without-gnutls --with-nss"
+ myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
+ elif use ssl; then
+ myconf="${myconf} --without-gnutls --without-nss --with-ssl"
+ myconf="${myconf} --without-ca-bundle --with-ca-path=/etc/ssl/certs"
+ else
+ myconf="${myconf} --without-gnutls --without-nss --without-ssl"
+ fi
+
+ econf ${myconf} || die 'configure failed'
+
+ emake || die "install failed for current version"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "installed failed for current version"
+ rm -rf "${D}"/etc/
+
+ # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
+ insinto /usr/share/aclocal
+ doins docs/libcurl/libcurl.m4
+
+ dodoc CHANGES README
+ dodoc docs/FEATURES docs/INTERNALS
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+}