summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-10-21 19:29:02 +0000
committerRoy Marples <uberlord@gentoo.org>2007-10-21 19:29:02 +0000
commit5258d0e025079cdea72847e0a60e04f86c67c7b5 (patch)
tree684821ed867f089c2e399270609153bc9abe0ea3 /net-misc
parentamd64 stable (diff)
downloadgentoo-2-5258d0e025079cdea72847e0a60e04f86c67c7b5.tar.gz
gentoo-2-5258d0e025079cdea72847e0a60e04f86c67c7b5.tar.bz2
gentoo-2-5258d0e025079cdea72847e0a60e04f86c67c7b5.zip
Release new version, should fix #196178 and a few link local issues.
(Portage version: 2.1.3.15)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcpcd/ChangeLog7
-rw-r--r--net-misc/dhcpcd/dhcpcd-3.1.7.ebuild90
-rw-r--r--net-misc/dhcpcd/files/digest-dhcpcd-3.1.73
3 files changed, 99 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index 940f4e15f4c7..ad5d4e491782 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.168 2007/10/17 15:52:13 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.169 2007/10/21 19:29:02 uberlord Exp $
+
+*dhcpcd-3.1.7 (21 Oct 2007)
+
+ 21 Oct 2007; Roy Marples <uberlord@gentoo.org> +dhcpcd-3.1.7.ebuild:
+ Release new version, should fix #196178 and a few link local issues.
17 Oct 2007; Roy Marples <uberlord@gentoo.org>
+files/dhcpcd-3.1.6-zeroconf.patch, dhcpcd-3.1.6-r1.ebuild:
diff --git a/net-misc/dhcpcd/dhcpcd-3.1.7.ebuild b/net-misc/dhcpcd/dhcpcd-3.1.7.ebuild
new file mode 100644
index 000000000000..6c48edf436f4
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-3.1.7.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-3.1.7.ebuild,v 1.1 2007/10/21 19:29:02 uberlord Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A DHCP client"
+HOMEPAGE="http://dhcpcd.berlios.de"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+SLOT="0"
+IUSE="vram zeroconf"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Redefine the location of ntp.drift
+ {
+ echo
+ echo "/* Gentoo stores ntpd drift file here */"
+ echo "#undef NTPDRIFTFILE"
+ echo "#define NTPDRIFTFILE \"/var/lib/ntp/ntp.drift\""
+ } >> config.h
+
+ if use zeroconf; then
+ einfo "ZeroConf support enabled"
+ else
+ einfo "Disabling zeroconf support"
+ {
+ echo
+ echo "/* User indicated no zeroconf support */"
+ echo "#undef ENABLE_IPV4LL"
+ } >> config.h
+ fi
+
+ # Disable DUID support if we have volatile storage.
+ # LiveCD's *should* enable this USE flag
+ if use vram; then
+ einfo "Disabling DUID support"
+ {
+ echo
+ echo "/* User indicated volatile ram storage */"
+ echo "#undef ENABLE_DUID"
+ } >> config.h
+ else
+ einfo "DUID support enabled"
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog
+}
+
+pkg_postinst() {
+ if use zeroconf; then
+ ewarn "You have installed dhcpcd with zeroconf support."
+ einfo "This means that it will always obtain an IP address even if no"
+ einfo "DHCP server can be contacted, which will break any existing"
+ einfo "failover support you may have configured in your net configuration."
+ einfo "This behaviour can be controlled with the -L flag."
+ einfo "See the dhcpcd man page for more details."
+ fi
+
+ if ! use vram; then
+ use zeroconf && echo
+ ewarn "You have installed dhcpcd with DUID support."
+ einfo "This means that we will generate a DUID in /var/lib/dhcpcd/dhcpcd.duid"
+ einfo "This is generated from a MAC address of the card and a timestamp."
+ einfo "It will be used in every subsequent DHCP transaction, along with a IAID"
+ einfo "in the ClientID option. This is required by RFC 4361."
+ echo
+ ewarn "Some DHCP server implementations require a MAC address only in the"
+ ewarn "ClientID field. These DHCP servers should be updated to be RFC"
+ ewarn "conformant. If you cannot do this, you can revert to the old"
+ ewarn "behaviour by using the -I '' option OR building dhcpcd with the"
+ ewarn "vram USE flag enabled."
+ fi
+}
diff --git a/net-misc/dhcpcd/files/digest-dhcpcd-3.1.7 b/net-misc/dhcpcd/files/digest-dhcpcd-3.1.7
new file mode 100644
index 000000000000..aac1f4ae85b2
--- /dev/null
+++ b/net-misc/dhcpcd/files/digest-dhcpcd-3.1.7
@@ -0,0 +1,3 @@
+MD5 6f69c3c9d3b36666078c4aba25e650ab dhcpcd-3.1.7.tar.bz2 43406
+RMD160 07c3a5b2515f5f507f1dd6118ab1954d12e4b39d dhcpcd-3.1.7.tar.bz2 43406
+SHA256 604240633280c827cbfffbf1cb21fca33c3e2a3fc3b5bfee4016373d1ceb6b86 dhcpcd-3.1.7.tar.bz2 43406