summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-04-09 18:14:21 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-04-09 18:14:21 +0000
commit3e15d53b04a36915409876a7450fb23d2fc54556 (patch)
treed2da021d6742c8a341d782261daeebd05e7ec10c /net-misc
parenterror check the cp and only call epatch once, thanks to mr_bones (diff)
downloadgentoo-2-3e15d53b04a36915409876a7450fb23d2fc54556.tar.gz
gentoo-2-3e15d53b04a36915409876a7450fb23d2fc54556.tar.bz2
gentoo-2-3e15d53b04a36915409876a7450fb23d2fc54556.zip
Version bump wrt #216408
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/sitecopy/ChangeLog8
-rw-r--r--net-misc/sitecopy/files/0.16.3_p17-neon-29.patch13
-rw-r--r--net-misc/sitecopy/sitecopy-0.16.3_p17.ebuild80
3 files changed, 100 insertions, 1 deletions
diff --git a/net-misc/sitecopy/ChangeLog b/net-misc/sitecopy/ChangeLog
index 754aafc7839d..81a2a78bf85e 100644
--- a/net-misc/sitecopy/ChangeLog
+++ b/net-misc/sitecopy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/sitecopy
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/sitecopy/ChangeLog,v 1.47 2008/03/25 16:49:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sitecopy/ChangeLog,v 1.48 2008/04/09 18:14:20 armin76 Exp $
+
+*sitecopy-0.16.3_p17 (09 Apr 2008)
+
+ 09 Apr 2008; Raúl Porcel <armin76@gentoo.org>
+ +files/0.16.3_p17-neon-29.patch, +sitecopy-0.16.3_p17.ebuild:
+ Version bump wrt #216408
*sitecopy-0.16.3_p15 (25 Mar 2008)
diff --git a/net-misc/sitecopy/files/0.16.3_p17-neon-29.patch b/net-misc/sitecopy/files/0.16.3_p17-neon-29.patch
new file mode 100644
index 000000000000..4ec36c4ac0f0
--- /dev/null
+++ b/net-misc/sitecopy/files/0.16.3_p17-neon-29.patch
@@ -0,0 +1,13 @@
+--- configure.in
++++ configure.in
+@@ -112,8 +112,8 @@
+ AC_LIBOBJ(lib/fnmatch)
+ fi
+
+-# Support neon 0.24, 0.25, 0.26.
+-NE_REQUIRE_VERSIONS([0], [24 25 26 27 28])
++# Support neon 0.24, 0.25, 0.26, 0.27, 0.28, 0.29.
++NE_REQUIRE_VERSIONS([0], [24 25 26 27 28 29])
+
+ dnl But we don't use zlib or ACL support
+ NEON_WITHOUT_ZLIB
diff --git a/net-misc/sitecopy/sitecopy-0.16.3_p17.ebuild b/net-misc/sitecopy/sitecopy-0.16.3_p17.ebuild
new file mode 100644
index 000000000000..d87b38fb2802
--- /dev/null
+++ b/net-misc/sitecopy/sitecopy-0.16.3_p17.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sitecopy/sitecopy-0.16.3_p17.ebuild,v 1.1 2008/04/09 18:14:20 armin76 Exp $
+
+inherit eutils autotools
+
+IUSE="expat nls rsh ssl webdav xml zlib"
+
+DEB_PL="${P##*_p}"
+MY_P="${P%%_*}"
+MY_P="${MY_P/-/_}"
+DESCRIPTION="sitecopy is for easily maintaining remote web sites"
+SRC_URI="mirror://debian/pool/main/s/${PN}/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/s/${PN}/${MY_P}-${DEB_PL}.diff.gz"
+HOMEPAGE="http://packages.debian.org/unstable/sitecopy http://www.lyra.org/sitecopy/"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+DEPEND="rsh? ( net-misc/netkit-rsh )
+ >=net-misc/neon-0.24.6"
+
+S="${WORKDIR}"/${MY_P/_/-}
+
+pkg_setup() {
+ if use zlib ; then
+ built_with_use net-misc/neon zlib || die "neon needs zlib support"
+ fi
+
+ if use ssl ; then
+ built_with_use net-misc/neon ssl || die "neon needs ssl support"
+ myconf="${myconf} --with-ssl=openssl"
+ fi
+
+ if use expat ; then
+ built_with_use net-misc/neon expat || die "neon needs expat support"
+ fi
+
+ if use xml ; then
+ built_with_use net-misc/neon expat && die "neon needs expat support disabled for
+ libxml2 support to be enabled"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # Debian patches
+ epatch ${MY_P}-${DEB_PL}.diff
+ epatch "${S}"/debian/patches/*.dpatch
+
+ cd "${S}"
+
+ # Make it work with neon .29
+ epatch "${FILESDIR}"/${PV}-neon-29.patch
+
+ sed -i -e \
+ "s:docdir \= .*:docdir \= \$\(prefix\)\/share/doc\/${PF}:" \
+ Makefile.in || die "Documentation directory patching failed"
+
+ eautoconf
+ eautomake
+}
+
+src_compile() {
+ econf ${myconf} \
+ $(use_enable webdav) \
+ $(use_enable nls) \
+ $(use_enable rsh) \
+ $(use_with expat) \
+ $(use_with xml libxml2 ) \
+ --with-neon \
+ || die "econf failed"
+
+ emake || die "eake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}