summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-09-17 20:13:21 +0000
committerChris Reffett <creffett@gentoo.org>2013-09-17 20:13:21 +0000
commit3cf6e554a9037f0e425b4d5841619ad5d0788ae7 (patch)
tree5cf937b88750b96bd3014433ce91c5dbdcf9491d /net-misc
parentForce python-exec:0 since the ebuild does hackery on top of script wrapping. (diff)
downloadgentoo-2-3cf6e554a9037f0e425b4d5841619ad5d0788ae7.tar.gz
gentoo-2-3cf6e554a9037f0e425b4d5841619ad5d0788ae7.tar.bz2
gentoo-2-3cf6e554a9037f0e425b4d5841619ad5d0788ae7.zip
Version bump wrt bug 483696. Remove test patch and restrict tests completely (they were causing compile phase to fail).
(Portage version: 2.2.3/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/csync/ChangeLog8
-rw-r--r--net-misc/csync/csync-0.90.0.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/net-misc/csync/ChangeLog b/net-misc/csync/ChangeLog
index 6db2f2a72917..9e8251a03898 100644
--- a/net-misc/csync/ChangeLog
+++ b/net-misc/csync/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/csync
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/csync/ChangeLog,v 1.17 2013/06/28 23:02:48 dastergon Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/csync/ChangeLog,v 1.18 2013/09/17 20:13:21 creffett Exp $
+
+*csync-0.90.0 (17 Sep 2013)
+
+ 17 Sep 2013; Chris Reffett <creffett@gentoo.org> +csync-0.90.0.ebuild:
+ Version bump wrt bug 483696. Remove test patch and restrict tests completely
+ (they were causing compile phase to fail).
*csync-0.80.0 (28 Jun 2013)
diff --git a/net-misc/csync/csync-0.90.0.ebuild b/net-misc/csync/csync-0.90.0.ebuild
new file mode 100644
index 000000000000..18107fd37ce2
--- /dev/null
+++ b/net-misc/csync/csync-0.90.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/csync/csync-0.90.0.ebuild,v 1.1 2013/09/17 20:13:21 creffett Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A file synchronizer especially designed for you, the normal user"
+HOMEPAGE="http://csync.org/"
+SRC_URI="http://download.owncloud.com/download/o${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc iconv samba +sftp test"
+
+RESTRICT="test"
+
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/iniparser-3.1
+ net-libs/neon[ssl]
+ iconv? ( virtual/libiconv )
+ samba? ( net-fs/samba )
+ sftp? ( net-libs/libssh )
+"
+DEPEND="${DEPEND}
+ app-text/asciidoc
+ doc? ( app-doc/doxygen )
+ test? ( dev-libs/check dev-util/cmocka )
+"
+
+S="${WORKDIR}/o${P}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # proper docdir
+ sed -e "s:/doc/ocsync:/doc/${PF}:" \
+ -i doc/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use test UNIT_TESTING)
+ $(cmake-utils_use_find_package doc Doxygen)
+ $(cmake-utils_use_find_package samba Libsmbclient)
+ $(cmake-utils_use_find_package sftp LibSSH)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ mv "${D}/usr/etc/ocsync" "${D}/etc/"
+ rm -r "${D}/usr/etc/"
+}