summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-10-12 21:13:38 +0000
committerMike Frysinger <vapier@gentoo.org>2013-10-12 21:13:38 +0000
commit1551c3318e4e72d63e4109ae4515045c5a48e483 (patch)
tree0f2fb45b9097320f1018ab3eaeb254448a476324 /net-misc
parentsplit the FIFO fd into two (one ro and one rw) to avoid POSIX undefined behav... (diff)
downloadgentoo-2-1551c3318e4e72d63e4109ae4515045c5a48e483.tar.gz
gentoo-2-1551c3318e4e72d63e4109ae4515045c5a48e483.tar.bz2
gentoo-2-1551c3318e4e72d63e4109ae4515045c5a48e483.zip
Version bump #487682 by Agostino Sarubbo.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dropbear/ChangeLog9
-rw-r--r--net-misc/dropbear/dropbear-2013.59.ebuild107
-rw-r--r--net-misc/dropbear/files/dropbear-2013.59-exec-prefix.patch16
-rw-r--r--net-misc/dropbear/files/dropbear-2013.59-scp-inst.patch62
4 files changed, 193 insertions, 1 deletions
diff --git a/net-misc/dropbear/ChangeLog b/net-misc/dropbear/ChangeLog
index c90786e2b353..11d18daaf1ff 100644
--- a/net-misc/dropbear/ChangeLog
+++ b/net-misc/dropbear/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/dropbear
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dropbear/ChangeLog,v 1.101 2013/09/25 18:14:40 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dropbear/ChangeLog,v 1.102 2013/10/12 21:13:38 vapier Exp $
+
+*dropbear-2013.59 (12 Oct 2013)
+
+ 12 Oct 2013; Mike Frysinger <vapier@gentoo.org> +dropbear-2013.59.ebuild,
+ +files/dropbear-2013.59-exec-prefix.patch,
+ +files/dropbear-2013.59-scp-inst.patch:
+ Version bump #487682 by Agostino Sarubbo.
25 Sep 2013; Anthony G. Basile <blueness@gentoo.org> -dropbear-0.52-r1.ebuild,
-dropbear-0.52.ebuild, -dropbear-0.53.1.ebuild, -dropbear-2011.54.ebuild:
diff --git a/net-misc/dropbear/dropbear-2013.59.ebuild b/net-misc/dropbear/dropbear-2013.59.ebuild
new file mode 100644
index 000000000000..cbc25746dae3
--- /dev/null
+++ b/net-misc/dropbear/dropbear-2013.59.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dropbear/dropbear-2013.59.ebuild,v 1.1 2013/10/12 21:13:38 vapier Exp $
+
+EAPI="4"
+
+inherit eutils savedconfig pam user
+
+DESCRIPTION="small SSH 2 client/server designed for small memory environments"
+HOMEPAGE="http://matt.ucc.asn.au/dropbear/dropbear.html"
+SRC_URI="http://matt.ucc.asn.au/dropbear/releases/${P}.tar.bz2
+ http://matt.ucc.asn.au/dropbear/testing/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="bsdpty minimal multicall pam +shadow static syslog zlib"
+
+LIB_DEPEND="zlib? ( sys-libs/zlib[static-libs(+)] )
+ dev-libs/libtommath[static-libs(+)]"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+RDEPEND+=" pam? ( >=sys-auth/pambase-20080219.1 )"
+
+REQUIRED_USE="pam? ( !static )"
+
+set_options() {
+ progs=(
+ dropbear dbclient dropbearkey
+ $(usex minimal "" "dropbearconvert scp")
+ )
+ makeopts=(
+ MULTI=$(usex multicall 1 0)
+ STATIC=$(usex static 1 0)
+ )
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.46-dbscp.patch
+ epatch "${FILESDIR}"/${P}-exec-prefix.patch
+ epatch "${FILESDIR}"/${P}-scp-inst.patch
+ sed -i '1i#define _GNU_SOURCE' scpmisc.c || die
+ sed -i \
+ -e '/SFTPSERVER_PATH/s:".*":"/usr/lib/misc/sftp-server":' \
+ -e '/XAUTH_COMMAND/s:/X11R6/:/:' \
+ options.h || die
+ sed -i \
+ -e '/pam_start/s:sshd:dropbear:' \
+ svr-authpam.c || die
+ # patch sent upstream to make configure option work.
+ # XXX: Need to add libtomcrypt to the tree and change this to 0.
+ sed -i \
+ -e '/BUNDLED_LIBTOM=1/s:=1:=1:' \
+ configure || die
+ restore_config options.h
+}
+
+src_configure() {
+ econf \
+ --disable-bundled-libtom \
+ $(use_enable zlib) \
+ $(use_enable pam) \
+ $(use_enable !bsdpty openpty) \
+ $(use_enable shadow) \
+ $(use_enable syslog)
+}
+
+src_compile() {
+ set_options
+ emake "${makeopts[@]}" PROGRAMS="${progs[*]}"
+}
+
+src_install() {
+ set_options
+ emake "${makeopts[@]}" PROGRAMS="${progs[*]}" DESTDIR="${D}" install
+ doman *.8
+ newinitd "${FILESDIR}"/dropbear.init.d dropbear
+ newconfd "${FILESDIR}"/dropbear.conf.d dropbear
+ dodoc CHANGES README TODO SMALL MULTI
+
+ # The multi install target does not install the links
+ if use multicall ; then
+ cd "${ED}"/usr/bin
+ local x
+ for x in "${progs[@]}" ; do
+ ln -s dropbearmulti ${x} || die "ln -s dropbearmulti to ${x} failed"
+ done
+ rm -f dropbear
+ dodir /usr/sbin
+ dosym ../bin/dropbearmulti /usr/sbin/dropbear
+ cd "${S}"
+ fi
+ save_config options.h
+
+ if ! use minimal ; then
+ mv "${ED}"/usr/bin/{,db}scp || die
+ fi
+
+ pamd_mimic system-remote-login dropbear auth account password session
+}
+
+pkg_preinst() {
+ enewgroup sshd 22
+ enewuser sshd 22 -1 /var/empty sshd
+}
diff --git a/net-misc/dropbear/files/dropbear-2013.59-exec-prefix.patch b/net-misc/dropbear/files/dropbear-2013.59-exec-prefix.patch
new file mode 100644
index 000000000000..05bc0227d293
--- /dev/null
+++ b/net-misc/dropbear/files/dropbear-2013.59-exec-prefix.patch
@@ -0,0 +1,16 @@
+changeset: 827:4a788a3162a1
+user: Matt Johnston <matt@ucc.asn.au>
+date: Wed Oct 09 21:58:07 2013 +0800
+summary: Add @exec_prefix@ that was missing
+
+diff -r 125012c4d107 -r 4a788a3162a1 Makefile.in
+--- a/Makefile.in Fri Oct 04 22:40:28 2013 +0800
++++ b/Makefile.in Wed Oct 09 21:58:07 2013 +0800
+@@ -66,6 +66,7 @@ VPATH=@srcdir@
+ srcdir=@srcdir@
+
+ prefix=@prefix@
++exec_prefix=@exec_prefix@
+ datarootdir = @datarootdir@
+ bindir=@bindir@
+ sbindir=@sbindir@
diff --git a/net-misc/dropbear/files/dropbear-2013.59-scp-inst.patch b/net-misc/dropbear/files/dropbear-2013.59-scp-inst.patch
new file mode 100644
index 000000000000..ee398a54043a
--- /dev/null
+++ b/net-misc/dropbear/files/dropbear-2013.59-scp-inst.patch
@@ -0,0 +1,62 @@
+changeset: 828:93e04b9ff676
+user: Matt Johnston <matt@ucc.asn.au>
+date: Wed Oct 09 22:24:39 2013 +0800
+summary: - Fix "inst_scp" target since there isn't a manpage
+
+diff -r 4a788a3162a1 -r 93e04b9ff676 MULTI
+--- a/MULTI Wed Oct 09 21:58:07 2013 +0800
++++ b/MULTI Wed Oct 09 22:24:39 2013 +0800
+@@ -20,7 +20,3 @@ etc
+ then execute as normal:
+
+ ./dropbear <options here>
+-
+-"make install" doesn't currently work for multi-binary configuration, though
+-in most situations where it is being used, the target and build systems will
+-differ.
+diff -r 4a788a3162a1 -r 93e04b9ff676 Makefile.in
+--- a/Makefile.in Wed Oct 09 21:58:07 2013 +0800
++++ b/Makefile.in Wed Oct 09 22:24:39 2013 +0800
+@@ -122,34 +122,34 @@ strip: $(TARGETS)
+
+ install: $(addprefix inst_, $(TARGETS))
+
+-installdropbearmulti: insdbmulti $(addprefix insmulti, $(PROGRAMS))
+-
+-insdbmulti: dropbearmulti
+- $(INSTALL) -d $(DESTDIR)$(bindir)
+- $(INSTALL) dropbearmulti$(EXEEXT) $(DESTDIR)$(bindir)
+-
+ insmultidropbear: dropbearmulti
+ $(INSTALL) -d $(DESTDIR)$(sbindir)
+ -rm -f $(DESTDIR)$(sbindir)/dropbear$(EXEEXT)
+ -ln -s $(bindir)/dropbearmulti$(EXEEXT) $(DESTDIR)$(sbindir)/dropbear$(EXEEXT)
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man8
++ $(INSTALL) -m 644 dropbear.8 $(DESTDIR)$(mandir)/man8/dropbear.8
+
+ insmulti%: dropbearmulti
+ $(INSTALL) -d $(DESTDIR)$(bindir)
+ -rm -f $(DESTDIR)$(bindir)/$*$(EXEEXT)
+ -ln -s $(bindir)/dropbearmulti$(EXEEXT) $(DESTDIR)$(bindir)/$*$(EXEEXT)
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man1
++ $(INSTALL) -m 644 $*.1 $(DESTDIR)$(mandir)/man1/$*.1
+
+ # dropbear should go in sbin, so it needs a seperate rule
+ inst_dropbear: dropbear
+ $(INSTALL) -d $(DESTDIR)$(sbindir)
+ $(INSTALL) dropbear$(EXEEXT) $(DESTDIR)$(sbindir)
+ $(INSTALL) -d $(DESTDIR)$(mandir)/man8
+- $(INSTALL) -m 644 dropbear.8 $(DESTDIR)$(mandir)/man8/dropbear.8
++ $(INSTALL) -m 644 dropbear.8 $(DESTDIR)$(mandir)/man8/dropbear.8
+
+ inst_%: $*
+ $(INSTALL) -d $(DESTDIR)$(bindir)
+ $(INSTALL) $*$(EXEEXT) $(DESTDIR)$(bindir)
+ $(INSTALL) -d $(DESTDIR)$(mandir)/man1
+- $(INSTALL) -m 644 $*.1 $(DESTDIR)$(mandir)/man1/$*.1
++ if test -e $*.1; then $(INSTALL) -m 644 $*.1 $(DESTDIR)$(mandir)/man1/$*.1; fi
++
++inst_dropbearmulti: $(addprefix insmulti, $(PROGRAMS))
+
+
+ # for some reason the rule further down doesn't like $($@objs) as a prereq.