summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-07-24 05:57:32 +0000
committerMike Frysinger <vapier@gentoo.org>2010-07-24 05:57:32 +0000
commitf2862b43e5533bfc8028ceb18e3e5d79d3a41a88 (patch)
tree1c3b5590578e12fc91283c725b7cede9d3785aa3 /net-misc/whois
parentold (diff)
downloadgentoo-2-f2862b43e5533bfc8028ceb18e3e5d79d3a41a88.tar.gz
gentoo-2-f2862b43e5533bfc8028ceb18e3e5d79d3a41a88.tar.bz2
gentoo-2-f2862b43e5533bfc8028ceb18e3e5d79d3a41a88.zip
Version bump #329455 by Petr Pisar.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/whois')
-rw-r--r--net-misc/whois/ChangeLog7
-rw-r--r--net-misc/whois/whois-5.0.6.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/net-misc/whois/ChangeLog b/net-misc/whois/ChangeLog
index 1722db4b54ce..e3c3da3e0907 100644
--- a/net-misc/whois/ChangeLog
+++ b/net-misc/whois/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/whois
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.136 2010/06/24 04:35:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.137 2010/07/24 05:57:32 vapier Exp $
+
+*whois-5.0.6 (24 Jul 2010)
+
+ 24 Jul 2010; Mike Frysinger <vapier@gentoo.org> +whois-5.0.6.ebuild:
+ Version bump #329455 by Petr Pisar.
*whois-5.0.5 (24 Jun 2010)
diff --git a/net-misc/whois/whois-5.0.6.ebuild b/net-misc/whois/whois-5.0.6.ebuild
new file mode 100644
index 000000000000..c92c14e48273
--- /dev/null
+++ b/net-misc/whois/whois-5.0.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-5.0.6.ebuild,v 1.1 2010/07/24 05:57:32 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="improved Whois Client"
+HOMEPAGE="http://www.linux.it/~md/software/"
+SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+RESTRICT="test" #59327
+
+RDEPEND="net-dns/libidn"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-4.7.2-config-file.patch
+
+ if use nls ; then
+ sed -i -e 's:#\(.*pos\):\1:' Makefile
+ else
+ sed -i -e '/ENABLE_NLS/s:define:undef:' config.h
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS} ${CPPFLAGS}" HAVE_LIBIDN=1 || die
+}
+
+src_install() {
+ emake BASEDIR="${D}" prefix=/usr install || die
+ insinto /etc
+ doins whois.conf
+ dodoc README debian/changelog
+
+ if [[ ${USERLAND} != "GNU" ]]; then
+ mv "${D}"/usr/share/man/man1/{whois,mdwhois}.1
+ mv "${D}"/usr/bin/{whois,mdwhois}
+ fi
+}