summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-09-26 18:08:00 +0000
committerMike Frysinger <vapier@gentoo.org>2009-09-26 18:08:00 +0000
commit84b694be6f15d5f629a7ee1b7819703002c5acf0 (patch)
tree5f6c73f602ddf0808937811a2ad952477720071a /net-misc/wget
parentCleanup: license changed, no point in autoupdate, TODO does not exist, while ... (diff)
downloadgentoo-2-84b694be6f15d5f629a7ee1b7819703002c5acf0.tar.gz
gentoo-2-84b694be6f15d5f629a7ee1b7819703002c5acf0.tar.bz2
gentoo-2-84b694be6f15d5f629a7ee1b7819703002c5acf0.zip
Automatically skip tests that require USE=debug #286173 by Alexis Ballier.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/ChangeLog6
-rw-r--r--net-misc/wget/files/wget-1.12-debug-tests.patch52
-rw-r--r--net-misc/wget/wget-1.12.ebuild3
3 files changed, 59 insertions, 2 deletions
diff --git a/net-misc/wget/ChangeLog b/net-misc/wget/ChangeLog
index fd3ce99c410d..63af531180fa 100644
--- a/net-misc/wget/ChangeLog
+++ b/net-misc/wget/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/wget
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.112 2009/09/23 19:55:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.113 2009/09/26 18:07:58 vapier Exp $
+
+ 26 Sep 2009; Mike Frysinger <vapier@gentoo.org> wget-1.12.ebuild,
+ +files/wget-1.12-debug-tests.patch:
+ Automatically skip tests that require USE=debug #286173 by Alexis Ballier.
23 Sep 2009; Mike Frysinger <vapier@gentoo.org> wget-1.12.ebuild,
+files/wget-1.12-linking.patch, metadata.xml:
diff --git a/net-misc/wget/files/wget-1.12-debug-tests.patch b/net-misc/wget/files/wget-1.12-debug-tests.patch
new file mode 100644
index 000000000000..7891ed354629
--- /dev/null
+++ b/net-misc/wget/files/wget-1.12-debug-tests.patch
@@ -0,0 +1,52 @@
+Skip tests that require USE=debug when building with USE=-debug
+
+http://bugs.gentoo.org/286173
+
+--- a/tests/Test-E-k-K.px
++++ b/tests/Test-E-k-K.px
+@@ -3,6 +3,7 @@
+ use strict;
+ use warnings;
+
++use WgetFeature qw(debug);
+ use HTTPTest;
+
+
+--- a/tests/Test-cookies-401.px
++++ b/tests/Test-cookies-401.px
+@@ -3,6 +3,7 @@
+ use strict;
+ use warnings;
+
++use WgetFeature qw(debug);
+ use HTTPTest;
+
+
+--- a/tests/Test-ftp-bad-list.px
++++ b/tests/Test-ftp-bad-list.px
+@@ -3,6 +3,7 @@
+ use strict;
+ use warnings;
+
++use WgetFeature qw(debug);
+ use FTPTest;
+
+
+--- a/tests/Test-proxy-auth-basic.px
++++ b/tests/Test-proxy-auth-basic.px
+@@ -3,6 +3,7 @@
+ use strict;
+ use warnings;
+
++use WgetFeature qw(debug);
+ use HTTPTest;
+
+
+--- a/tests/WgetFeature.cfg
++++ b/tests/WgetFeature.cfg
+@@ -1,4 +1,5 @@
+ %skip_messages = (
++ debug => "Not running test: Wget under test doesn't support debug.",
+ https => "Not running test: Wget under test doesn't support HTTPS.",
+ iri => "Not running test: Wget under test doesn't support IDN/IRI.",
+ );
diff --git a/net-misc/wget/wget-1.12.ebuild b/net-misc/wget/wget-1.12.ebuild
index fb3874ca571b..e173c9560f03 100644
--- a/net-misc/wget/wget-1.12.ebuild
+++ b/net-misc/wget/wget-1.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.12.ebuild,v 1.2 2009/09/23 19:55:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.12.ebuild,v 1.3 2009/09/26 18:07:58 vapier Exp $
inherit eutils flag-o-matic
@@ -28,6 +28,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-1.12-linking.patch
+ epatch "${FILESDIR}"/${P}-debug-tests.patch #286173
}
src_compile() {