summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-03-24 15:38:19 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-03-24 15:38:19 +0000
commit383ae0878f617c6bb4b871af5e99e281d26e352b (patch)
treef8fc8438f2946bcc3fdf337f4b27ed9aa05816f0 /net-misc/vnc
parentUpdate SiS driver (diff)
downloadgentoo-2-383ae0878f617c6bb4b871af5e99e281d26e352b.tar.gz
gentoo-2-383ae0878f617c6bb4b871af5e99e281d26e352b.tar.bz2
gentoo-2-383ae0878f617c6bb4b871af5e99e281d26e352b.zip
version bump
Diffstat (limited to 'net-misc/vnc')
-rw-r--r--net-misc/vnc/ChangeLog8
-rw-r--r--net-misc/vnc/files/digest-vnc-3.3.71
-rw-r--r--net-misc/vnc/files/vnc-3.3.7-gentoo.security.patch20
-rw-r--r--net-misc/vnc/vnc-3.3.7.ebuild74
4 files changed, 102 insertions, 1 deletions
diff --git a/net-misc/vnc/ChangeLog b/net-misc/vnc/ChangeLog
index 8f3e2b99e75f..280942368725 100644
--- a/net-misc/vnc/ChangeLog
+++ b/net-misc/vnc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/vnc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/ChangeLog,v 1.17 2003/02/21 18:02:07 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/ChangeLog,v 1.18 2003/03/24 15:38:18 phosphan Exp $
+
+*vnc-3.3.7 (24 Mar 2003)
+
+ 24 Mar 2003; Patrick Kursawe <phosphan@gentoo.org> vnc-3.3.7.ebuild,
+ files/digest-vnc-3.3.7, files/vnc-3.3.7-gentoo.security.patch:
+ Version bump.
*vnc-3.3.6-r1 (21 Feb 2003)
diff --git a/net-misc/vnc/files/digest-vnc-3.3.7 b/net-misc/vnc/files/digest-vnc-3.3.7
new file mode 100644
index 000000000000..c5af65bf0fb4
--- /dev/null
+++ b/net-misc/vnc/files/digest-vnc-3.3.7
@@ -0,0 +1 @@
+MD5 511ffbc8ed8d9df82e7c67852164728c vnc-3.3.7-unixsrc.tar.gz 2160226
diff --git a/net-misc/vnc/files/vnc-3.3.7-gentoo.security.patch b/net-misc/vnc/files/vnc-3.3.7-gentoo.security.patch
new file mode 100644
index 000000000000..7a32a38d7124
--- /dev/null
+++ b/net-misc/vnc/files/vnc-3.3.7-gentoo.security.patch
@@ -0,0 +1,20 @@
+--- /tmp/vncserver 2003-02-21 17:47:11.000000000 +0000
++++ vncserver 2003-02-21 17:47:41.000000000 +0000
+@@ -120,15 +120,8 @@
+ $desktopLog = "$vncUserDir/$host:$displayNumber.log";
+ unlink($desktopLog);
+
+-# Make an X server cookie - use as the seed the sum of the current time, our
+-# PID and part of the encrypted form of the password. Ideally we'd use
+-# /dev/urandom, but that's only available on Linux.
+-
+-srand(time+$$+unpack("L",`cat $vncUserDir/passwd`));
+-$cookie = "";
+-for (1..16) {
+- $cookie .= sprintf("%02x", int(rand(256)) % 256);
+-}
++# Make an X server cookie - use mcookie
++$cookie = `/usr/bin/mcookie`;
+
+ system("xauth -f $xauthorityFile add $host:$displayNumber . $cookie");
+ system("xauth -f $xauthorityFile add $host/unix:$displayNumber . $cookie");
diff --git a/net-misc/vnc/vnc-3.3.7.ebuild b/net-misc/vnc/vnc-3.3.7.ebuild
new file mode 100644
index 000000000000..72ffdac01cf9
--- /dev/null
+++ b/net-misc/vnc/vnc-3.3.7.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/vnc-3.3.7.ebuild,v 1.1 2003/03/24 15:38:19 phosphan Exp $
+
+inherit eutils
+
+IUSE="java tcpd"
+
+MY_P="${P}-unixsrc"
+
+DESCRIPTION="Remote desktop viewer display system"
+HOMEPAGE="http://www.realvnc.com/"
+
+SRC_URI="http://www.realvnc.com/dist/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="java? ( virtual/jre )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-gentoo.security.patch
+}
+
+src_compile() {
+
+ export CXX="g++"
+
+ econf || die "./configure failed"
+
+ make
+
+ cd Xvnc
+ if use tcpd
+ then
+ make \
+ EXTRA_LIBRARIES="-lwrap -lnss_nis" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CFLAGS}" \
+ World || die
+ else
+ make \
+ CDEBUGFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CFLAGS}" \
+ World || die
+ fi
+
+}
+
+src_install () {
+
+ dodir /usr/bin /usr/share/man/man1
+
+ ./vncinstall ${D}/usr/bin ${D}/usr/share/man || die
+
+ if use java
+ then
+ cd ${S}/classes
+ insinto /usr/share/vnc/classes
+ doins *.class *.jar *.vnc
+ fi
+
+ cd ${S}
+ dodoc LICENCE.TXT README
+
+}
+