summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2008-12-10 07:02:37 +0000
committerChristian Faulhammer <fauli@gentoo.org>2008-12-10 07:02:37 +0000
commitc3b4c2f182367eaed50b1b318c4db1004d437dae (patch)
tree25b06c11972a37f530836373a73bf16fee7e5b16 /net-misc/tor
parentSparc stable --- Bug #249871 --- fine for four months. (diff)
downloadgentoo-2-c3b4c2f182367eaed50b1b318c4db1004d437dae.tar.gz
gentoo-2-c3b4c2f182367eaed50b1b318c4db1004d437dae.tar.bz2
gentoo-2-c3b4c2f182367eaed50b1b318c4db1004d437dae.zip
clean up
(Portage version: 2.1.4.5)
Diffstat (limited to 'net-misc/tor')
-rw-r--r--net-misc/tor/ChangeLog6
-rw-r--r--net-misc/tor/files/tor-0.2.0.31-sparc.patch87
-rw-r--r--net-misc/tor/tor-0.2.0.31-r1.ebuild70
3 files changed, 5 insertions, 158 deletions
diff --git a/net-misc/tor/ChangeLog b/net-misc/tor/ChangeLog
index 5b0d64c0ece3..030a67fd2d70 100644
--- a/net-misc/tor/ChangeLog
+++ b/net-misc/tor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/tor
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.147 2008/12/09 19:56:28 bluebird Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.148 2008/12/10 07:02:37 fauli Exp $
+
+ 10 Dec 2008; Christian Faulhammer <fauli@gentoo.org>
+ -files/tor-0.2.0.31-sparc.patch, -tor-0.2.0.31-r1.ebuild:
+ clean up
09 Dec 2008; Friedrich Oslage <bluebird@gentoo.org> tor-0.2.0.32.ebuild:
Stable on sparc, security bug #250018
diff --git a/net-misc/tor/files/tor-0.2.0.31-sparc.patch b/net-misc/tor/files/tor-0.2.0.31-sparc.patch
deleted file mode 100644
index b7634765a1d6..000000000000
--- a/net-misc/tor/files/tor-0.2.0.31-sparc.patch
+++ /dev/null
@@ -1,87 +0,0 @@
---- src/or/buffers.c- 2008-11-13 22:41:16.000000000 +0000
-+++ src/or/buffers.c 2008-11-13 22:46:46.000000000 +0000
-@@ -957,7 +957,8 @@
- return 0;
- peek_from_buf(hdr, sizeof(hdr), buf);
-
-- command = *(uint8_t*)(hdr+2);
-+ /* command = *(uint8_t*)(hdr+2); */
-+ command = get_uint8(hdr+2);
- if (!(CELL_COMMAND_IS_VAR_LENGTH(command)))
- return 0;
-
-@@ -966,7 +967,8 @@
- return 1;
- result = var_cell_new(length);
- result->command = command;
-- result->circ_id = ntohs(*(uint16_t*)hdr);
-+ /* result->circ_id = ntohs(*(uint16_t*)hdr); */
-+ result->circ_id = ntohs(get_uint16(hdr));
-
- buf_remove_from_front(buf, VAR_CELL_HEADER_SIZE);
- peek_from_buf(result->payload, length, buf);
---- src/or/connection_or.c- 2008-06-13 05:12:28.000000000 +0000
-+++ src/or/connection_or.c 2008-11-13 22:48:56.000000000 +0000
-@@ -157,8 +157,12 @@
- void
- var_cell_pack_header(const var_cell_t *cell, char *hdr_out)
- {
-+ /*
- *(uint16_t*)(hdr_out) = htons(cell->circ_id);
- *(uint8_t*)(hdr_out+2) = cell->command;
-+ */
-+ set_uint16(hdr_out, htons(cell->circ_id));
-+ set_uint8(hdr_out+2, cell->command);
- set_uint16(hdr_out+3, htons(cell->payload_len));
- }
-
---- src/common/compat.h- 2008-11-14 00:17:28.000000000 +0000
-+++ src/common/compat.h 2008-11-14 00:18:31.000000000 +0000
-@@ -454,8 +454,10 @@
- /* ===== OS compatibility */
- const char *get_uname(void);
-
-+uint8_t get_uint8(const char *cp) ATTR_PURE ATTR_NONNULL((1));
- uint16_t get_uint16(const char *cp) ATTR_PURE ATTR_NONNULL((1));
- uint32_t get_uint32(const char *cp) ATTR_PURE ATTR_NONNULL((1));
-+void set_uint8(char *cp, uint8_t v) ATTR_NONNULL((1));
- void set_uint16(char *cp, uint16_t v) ATTR_NONNULL((1));
- void set_uint32(char *cp, uint32_t v) ATTR_NONNULL((1));
-
---- src/common/compat.c- 2008-11-14 00:23:11.000000000 +0000
-+++ src/common/compat.c 2008-11-14 00:21:34.000000000 +0000
-@@ -407,6 +407,18 @@
- #endif
-
- /**
-+ * Read a 8-bit value beginning at <b>cp</b>. Equivalent to
-+ * *(uint8_t*)(cp), but will not cause segfaults on platforms that forbid
-+ * unaligned memory access. (fmccor@gentoo.org)
-+ */
-+uint8_t
-+get_uint8(const char *cp)
-+{
-+ uint8_t v;
-+ memcpy(&v,cp,1);
-+ return v;
-+}
-+/**
- * Read a 16-bit value beginning at <b>cp</b>. Equivalent to
- * *(uint16_t*)(cp), but will not cause segfaults on platforms that forbid
- * unaligned memory access.
-@@ -431,6 +443,15 @@
- return v;
- }
- /**
-+ * Set a 8-bit value beginning at <b>cp</b> to <b>v</b>. Equivalent to
-+ * *(uint8_t)(cp) = v, but will not cause segfaults on platforms that forbid
-+ * unaligned memory access. (fmccor@gentoo.org) */
-+void
-+set_uint8(char *cp, uint8_t v)
-+{
-+ memcpy(cp,&v,1);
-+}
-+/**
- * Set a 16-bit value beginning at <b>cp</b> to <b>v</b>. Equivalent to
- * *(uint16_t)(cp) = v, but will not cause segfaults on platforms that forbid
- * unaligned memory access. */
diff --git a/net-misc/tor/tor-0.2.0.31-r1.ebuild b/net-misc/tor/tor-0.2.0.31-r1.ebuild
deleted file mode 100644
index 158b1de4aaca..000000000000
--- a/net-misc/tor/tor-0.2.0.31-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.0.31-r1.ebuild,v 1.3 2008/11/22 17:05:22 opfer Exp $
-
-inherit eutils
-
-DESCRIPTION="Anonymizing overlay network for TCP"
-HOMEPAGE="http://tor.eff.org"
-MY_PV=${PV/_/-}
-SRC_URI="http://tor.eff.org/dist/${PN}-${MY_PV}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="debug logrotate"
-
-DEPEND="dev-libs/openssl
- >=dev-libs/libevent-1.2"
-RDEPEND="${DEPEND}
- net-proxy/tsocks"
-
-pkg_setup() {
- enewgroup tor
- enewuser tor -1 -1 /var/lib/tor tor
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/torrc.sample-0.1.2.6.patch
- epatch "${FILESDIR}"/${PN}-0.2.0.30-logrotate.patch
- epatch "${FILESDIR}"/${PN}-0.2.0.31-sparc.patch
-}
-
-src_compile() {
- econf $(use_enable debug)
- emake || die
-}
-
-src_install() {
- newinitd "${FILESDIR}"/tor.initd-r4 tor
- emake DESTDIR="${D}" install || die
- keepdir /var/{lib,log,run}/tor
-
- dodoc README ChangeLog AUTHORS ReleaseNotes \
- doc/{HACKING,TODO} \
- doc/spec/*.txt
-
- fperms 750 /var/lib/tor /var/log/tor
- fperms 755 /var/run/tor
- fowners tor:tor /var/lib/tor /var/log/tor /var/run/tor
-
- if use logrotate; then
- sed -e "s:/lib::" \
- -e "s:/rc.d::" \
- -e "s:\\*:\\*.:" \
- -e "s:sharedscripts:create 0640 tor tor\n\tsharedscripts:" -i contrib/tor.logrotate || die
- insinto /etc/logrotate.d
- newins contrib/tor.logrotate tor
- fi
-}
-
-pkg_postinst() {
- elog "You must create /etc/tor/torrc, you can use the sample that is in that directory"
- elog "To have privoxy and tor working together you must add:"
- elog "forward-socks4a / localhost:9050 ."
- elog "(notice the . at the end of the line)"
- elog "to /etc/privoxy/config"
-}