summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-06-28 13:35:34 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-06-28 13:35:34 +0000
commitb22fb8f3f89ac1d2baa836fd3f9a942c070403df (patch)
tree39d33d84525a39344b9bb688a8e11876eab35029 /net-misc/tor
parentVersion bump. (diff)
downloadgentoo-2-b22fb8f3f89ac1d2baa836fd3f9a942c070403df.tar.gz
gentoo-2-b22fb8f3f89ac1d2baa836fd3f9a942c070403df.tar.bz2
gentoo-2-b22fb8f3f89ac1d2baa836fd3f9a942c070403df.zip
version bump for security bug 275628, directly stable for x86
(Portage version: 2.1.6.13/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'net-misc/tor')
-rw-r--r--net-misc/tor/ChangeLog7
-rw-r--r--net-misc/tor/tor-0.2.0.35.ebuild88
2 files changed, 94 insertions, 1 deletions
diff --git a/net-misc/tor/ChangeLog b/net-misc/tor/ChangeLog
index 3342b3aaa473..d392611d4628 100644
--- a/net-misc/tor/ChangeLog
+++ b/net-misc/tor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/tor
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.168 2009/06/17 12:23:38 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.169 2009/06/28 13:35:34 fauli Exp $
+
+*tor-0.2.0.35 (28 Jun 2009)
+
+ 28 Jun 2009; Christian Faulhammer <fauli@gentoo.org> +tor-0.2.0.35.ebuild:
+ version bump for security bug 275628, directly stable for x86
17 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
tor-0.2.1.15_rc.ebuild:
diff --git a/net-misc/tor/tor-0.2.0.35.ebuild b/net-misc/tor/tor-0.2.0.35.ebuild
new file mode 100644
index 000000000000..60c91bd4019f
--- /dev/null
+++ b/net-misc/tor/tor-0.2.0.35.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.0.35.ebuild,v 1.1 2009/06/28 13:35:34 fauli Exp $
+
+EAPI=1
+
+inherit eutils
+
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://tor.eff.org"
+MY_PV=${PV/_/-}
+SRC_URI="http://tor.eff.org/dist/${PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="+bundledlibevent debug"
+
+DEPEND="dev-libs/openssl
+ >=dev-libs/libevent-1.2"
+RDEPEND="${DEPEND}
+ net-proxy/tsocks"
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/torrc.sample-0.1.2.6.patch
+ epatch "${FILESDIR}"/${PN}-0.2.0.30-logrotate.patch
+ # Normally tor uses a bundled libevent fragment to provide
+ # asynchronous DNS requests. This is generally a bad idea, but at
+ # the moment the official libevent does not have the 0x20 hack, so
+ # anonymity is higher with the bundled variant. Remove patch as
+ # soon as upstream has installed the autoconf option to use
+ # system's libevent (0.2.1 or later)
+ # See http://bugs.noreply.org/flyspray/index.php?do=details&id=920
+ # for upstream's report
+ use bundledlibevent || epatch "${FILESDIR}"/${PN}-0.2.0.33-no-internal-libevent.patch
+}
+
+src_compile() {
+ econf $(use_enable debug)
+ emake || die
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/tor.initd-r4 tor
+ emake DESTDIR="${D}" install || die
+ keepdir /var/{lib,log,run}/tor
+
+ dodoc README ChangeLog AUTHORS ReleaseNotes \
+ doc/{HACKING,TODO} \
+ doc/spec/*.txt
+
+ fperms 750 /var/lib/tor /var/log/tor
+ fperms 755 /var/run/tor
+ fowners tor:tor /var/lib/tor /var/log/tor /var/run/tor
+
+ sed -e "s:/lib::" \
+ -e "s:/rc.d::" \
+ -e "s:\\*:\\*.:" \
+ -e "s:sharedscripts:create 0640 tor tor\n\tsharedscripts:" -i contrib/tor.logrotate || die
+ insinto /etc/logrotate.d
+ newins contrib/tor.logrotate tor
+
+ # allow the tor user more open files to avoid errors, see bug 251171
+ insinto /etc/security/limits.d/
+ doins "${FILESDIR}"/tor.conf
+}
+
+pkg_postinst() {
+ elog "You must create /etc/tor/torrc, you can use the sample that is in that directory"
+ elog "To have privoxy and tor working together you must add:"
+ elog "forward-socks4a / localhost:9050 ."
+ elog "(notice the . at the end of the line)"
+ elog "to /etc/privoxy/config"
+
+ if ! use bundledlibevent; then
+ elog
+ elog "Please be aware that using the system's libevent library will lower your anonymity"
+ elog "a little bit. If you rely on it, please enable USE=bundledlibevent."
+ fi
+}