summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-02-27 22:59:09 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-02-27 22:59:09 +0000
commit4dc0d54ef476417d434a3a720dc2b9b9da9d63f2 (patch)
treea91269cbde5bd5daf21c83e77df2353fc8c5c0b1 /net-misc/tor
parentFix tests. Bug #356029. Thanks to Diego Elio Pettenò <flameeyes@gentoo.org> (diff)
downloadgentoo-2-4dc0d54ef476417d434a3a720dc2b9b9da9d63f2.tar.gz
gentoo-2-4dc0d54ef476417d434a3a720dc2b9b9da9d63f2.tar.bz2
gentoo-2-4dc0d54ef476417d434a3a720dc2b9b9da9d63f2.zip
Reverted removal of only stable ebuild on most arches.
(Portage version: 2.1.9.25/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'net-misc/tor')
-rw-r--r--net-misc/tor/ChangeLog5
-rw-r--r--net-misc/tor/tor-0.2.1.29.ebuild79
2 files changed, 83 insertions, 1 deletions
diff --git a/net-misc/tor/ChangeLog b/net-misc/tor/ChangeLog
index f485662c5989..2f498ac5d077 100644
--- a/net-misc/tor/ChangeLog
+++ b/net-misc/tor/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/tor
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.238 2011/02/27 17:00:49 chiiph Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.239 2011/02/27 22:59:09 blueness Exp $
+
+ 27 Feb 2011; Anthony G. Basile <blueness@gentoo.org> +tor-0.2.1.29.ebuild:
+ Reverted removal of only stable ebuild on most arches.
*tor-0.2.1.30 (27 Feb 2011)
diff --git a/net-misc/tor/tor-0.2.1.29.ebuild b/net-misc/tor/tor-0.2.1.29.ebuild
new file mode 100644
index 000000000000..0202e52d6289
--- /dev/null
+++ b/net-misc/tor/tor-0.2.1.29.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.1.29.ebuild,v 1.8 2011/02/27 22:59:09 blueness Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+MY_PV=${PV/_/-}
+SRC_URI="http://www.torproject.org/dist/${PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND="dev-libs/openssl
+ >=dev-libs/libevent-1.2"
+# The tordns patch for tsocks avoids some leakage of information thus raising anonymity
+RDEPEND="${DEPEND}
+ net-proxy/tsocks[tordns]"
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/torrc.sample-0.1.2.6.patch
+ epatch "${FILESDIR}"/${PN}-0.2.1.19-logrotate.patch
+ # Normally tor uses a bundled libevent fragment to provide
+ # asynchronous DNS requests. This is generally a bad idea, but at
+ # the moment the official libevent does not have the 0x20 hack, so
+ # anonymity is higher with the bundled variant. Remove patch as
+ # soon as upstream has installed the autoconf option to use
+ # system's libevent. This hasn't happened, so we
+ # have to live with the bundled libevent for this release, as the
+ # current version in tree won't suffice for tor to build
+ # See http://bugs.noreply.org/flyspray/index.php?do=details&id=920
+ # for upstream's report
+ # Let's revisit this when libevent-2* is unmasked
+ # use bundledlibevent || epatch "${FILESDIR}"/${PN}-0.2.1.5-no-internal-libevent.patch
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/tor.initd-r4 tor
+ emake DESTDIR="${D}" install || die
+ keepdir /var/{lib,log,run}/tor
+
+ dodoc README ChangeLog AUTHORS ReleaseNotes \
+ doc/{HACKING,TODO} \
+ doc/spec/*.txt
+
+ fperms 750 /var/lib/tor /var/log/tor
+ fperms 755 /var/run/tor
+ fowners tor:tor /var/lib/tor /var/log/tor /var/run/tor
+
+ insinto /etc/logrotate.d
+ newins contrib/tor.logrotate tor
+
+ # allow the tor user more open files to avoid errors, see bug 251171
+ insinto /etc/security/limits.d/
+ doins "${FILESDIR}"/tor.conf
+}
+
+pkg_postinst() {
+ elog "You must create /etc/tor/torrc, you can use the sample that is in that directory"
+ elog "To have privoxy and tor working together you must add:"
+ elog "forward-socks4a / localhost:9050 ."
+ elog "(notice the . at the end of the line)"
+ elog "to /etc/privoxy/config"
+}