summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-21 16:41:28 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-21 16:41:28 +0000
commitbac77b93aff4b51d2df6f1fdc53c1f98ab87000b (patch)
tree044b39a40d26c2ddc689f81baa74be9a9280a18a /net-misc/tipcutils
parentStable for HPPA (bug #206684). (diff)
downloadgentoo-2-bac77b93aff4b51d2df6f1fdc53c1f98ab87000b.tar.gz
gentoo-2-bac77b93aff4b51d2df6f1fdc53c1f98ab87000b.tar.bz2
gentoo-2-bac77b93aff4b51d2df6f1fdc53c1f98ab87000b.zip
Use linux-info.eclass to figure out KERNEL_DIR for tipc_config.h include wrt #205415.
(Portage version: 2.1.4)
Diffstat (limited to 'net-misc/tipcutils')
-rw-r--r--net-misc/tipcutils/ChangeLog9
-rw-r--r--net-misc/tipcutils/files/tipcutils-1.0.4-cflags.patch19
-rw-r--r--net-misc/tipcutils/tipcutils-1.0.4.ebuild20
3 files changed, 43 insertions, 5 deletions
diff --git a/net-misc/tipcutils/ChangeLog b/net-misc/tipcutils/ChangeLog
index 6d4a4a3afb2b..f97c014793e0 100644
--- a/net-misc/tipcutils/ChangeLog
+++ b/net-misc/tipcutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/tipcutils
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tipcutils/ChangeLog,v 1.2 2007/08/29 17:25:28 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tipcutils/ChangeLog,v 1.3 2008/01/21 16:41:27 drac Exp $
+
+ 21 Jan 2008; Samuli Suominen <drac@gentoo.org>
+ +files/tipcutils-1.0.4-cflags.patch, tipcutils-1.0.4.ebuild:
+ Use linux-info.eclass to figure out KERNEL_DIR for tipc_config.h include wrt
+ #205415.
29 Aug 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing gustavoz from metadata due to his retirement (see #36010 for
diff --git a/net-misc/tipcutils/files/tipcutils-1.0.4-cflags.patch b/net-misc/tipcutils/files/tipcutils-1.0.4-cflags.patch
new file mode 100644
index 000000000000..4080aa70f7f3
--- /dev/null
+++ b/net-misc/tipcutils/files/tipcutils-1.0.4-cflags.patch
@@ -0,0 +1,19 @@
+diff -ur tipcutils-1.0.4.orig/Makefile tipcutils-1.0.4/Makefile
+--- tipcutils-1.0.4.orig/Makefile 2006-10-12 17:46:49.000000000 +0300
++++ tipcutils-1.0.4/Makefile 2008-01-21 18:38:02.000000000 +0200
+@@ -2,12 +2,12 @@
+ # Makefile for tipcutils
+ #
+
+-ifndef KERNELDIR
+- KERNELDIR = /usr/src/linux
++ifndef KERNEL_DIR
++ KERNEL_DIR = /usr/src/linux
+ endif
+
+ VERSION = 1.0.4
+-CFLAGS = -Wall -O2 -I${KERNELDIR}/include -D VERSION=\"${VERSION}\"
++CFLAGS += -Wall -I${KERNEL_DIR}/include -D VERSION=\"${VERSION}\"
+
+ all: tipc-config
+
diff --git a/net-misc/tipcutils/tipcutils-1.0.4.ebuild b/net-misc/tipcutils/tipcutils-1.0.4.ebuild
index df24de8b0d97..afa4d9a6e773 100644
--- a/net-misc/tipcutils/tipcutils-1.0.4.ebuild
+++ b/net-misc/tipcutils/tipcutils-1.0.4.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tipcutils/tipcutils-1.0.4.ebuild,v 1.1 2007/01/26 19:07:09 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tipcutils/tipcutils-1.0.4.ebuild,v 1.2 2008/01/21 16:41:27 drac Exp $
+
+inherit eutils linux-info toolchain-funcs
DESCRIPTION="Utilities for TIPC (Transparent Inter-Process Communication)"
-HOMEPAGE="http://tipc.sourceforge.net/"
+HOMEPAGE="http://tipc.sourceforge.net"
SRC_URI="mirror://sourceforge/tipc/${P}.tar.gz"
LICENSE="as-is"
@@ -14,6 +16,18 @@ IUSE=""
DEPEND=""
RDEPEND=""
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-cflags.patch
+}
+
+src_compile() {
+ tc-export CC
+ export KERNEL_DIR
+ emake || die "emake failed."
+}
+
src_install () {
dosbin tipc-config
}