summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-04-23 02:40:54 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-04-23 02:40:54 +0000
commitd4e79d1e58c7b0dbc3eb28970a2402d0fd2a0740 (patch)
tree5215991462619dd2994534c88430de7e52a3e973 /net-misc/tinc
parentversion bump and some minor improvements (diff)
downloadgentoo-2-d4e79d1e58c7b0dbc3eb28970a2402d0fd2a0740.tar.gz
gentoo-2-d4e79d1e58c7b0dbc3eb28970a2402d0fd2a0740.tar.bz2
gentoo-2-d4e79d1e58c7b0dbc3eb28970a2402d0fd2a0740.zip
Version bump
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc/tinc')
-rw-r--r--net-misc/tinc/ChangeLog7
-rw-r--r--net-misc/tinc/tinc-1.0.21.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/net-misc/tinc/ChangeLog b/net-misc/tinc/ChangeLog
index 87f243c3dbfc..34278ea39081 100644
--- a/net-misc/tinc/ChangeLog
+++ b/net-misc/tinc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/tinc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/ChangeLog,v 1.39 2013/03/05 02:41:34 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/ChangeLog,v 1.40 2013/04/23 02:40:54 blueness Exp $
+
+*tinc-1.0.21 (23 Apr 2013)
+
+ 23 Apr 2013; Anthony G. Basile <blueness@gentoo.org> +tinc-1.0.21.ebuild:
+ Version bump
05 Mar 2013; Anthony G. Basile <blueness@gentoo.org>
-files/fix-ac-arg-enable.patch, -tinc-1.0.18.ebuild:
diff --git a/net-misc/tinc/tinc-1.0.21.ebuild b/net-misc/tinc/tinc-1.0.21.ebuild
new file mode 100644
index 000000000000..058f79923353
--- /dev/null
+++ b/net-misc/tinc/tinc-1.0.21.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/tinc-1.0.21.ebuild,v 1.1 2013/04/23 02:40:54 blueness Exp $
+
+EAPI="5"
+
+DESCRIPTION="tinc is an easy to configure VPN implementation"
+HOMEPAGE="http://www.tinc-vpn.org/"
+SRC_URI="http://www.tinc-vpn.org/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+lzo uml vde +zlib"
+
+DEPEND=">=dev-libs/openssl-0.9.7
+ lzo? ( dev-libs/lzo:2 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )"
+RDEPEND="${DEPEND}
+ vde? ( net-misc/vde )"
+
+src_configure() {
+ econf \
+ --enable-jumbograms \
+ --disable-tunemu \
+ $(use_enable lzo) \
+ $(use_enable uml) \
+ $(use_enable vde) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodir /etc/tinc
+ dodoc AUTHORS NEWS README THANKS
+ newinitd "${FILESDIR}"/tincd.1 tincd
+ newinitd "${FILESDIR}"/tincd.lo.1 tincd.lo
+ doconfd "${FILESDIR}"/tinc.networks
+ newconfd "${FILESDIR}"/tincd.conf.1 tincd
+}
+
+pkg_postinst() {
+ elog "This package requires the tun/tap kernel device."
+ elog "Look at http://www.tinc-vpn.org/ for how to configure tinc"
+}