summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-06-26 13:52:39 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-06-26 13:52:39 +0000
commit99685c14d819fb1345bde7ab0a048584e14bcd86 (patch)
tree272dffd33f0a6affb881c9059f40db46348fe069 /net-misc/tinc
parentEnable ipv6 on all hardened profiles (diff)
downloadgentoo-2-99685c14d819fb1345bde7ab0a048584e14bcd86.tar.gz
gentoo-2-99685c14d819fb1345bde7ab0a048584e14bcd86.tar.bz2
gentoo-2-99685c14d819fb1345bde7ab0a048584e14bcd86.zip
Version bump
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/tinc')
-rw-r--r--net-misc/tinc/ChangeLog7
-rw-r--r--net-misc/tinc/tinc-1.0.19.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/net-misc/tinc/ChangeLog b/net-misc/tinc/ChangeLog
index 55d24d7c040d..3278bd2bbdea 100644
--- a/net-misc/tinc/ChangeLog
+++ b/net-misc/tinc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/tinc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/ChangeLog,v 1.35 2012/05/12 05:28:45 heroxbd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/ChangeLog,v 1.36 2012/06/26 13:52:39 blueness Exp $
+
+*tinc-1.0.19 (26 Jun 2012)
+
+ 26 Jun 2012; Anthony G. Basile <blueness@gentoo.org> +tinc-1.0.19.ebuild:
+ Version bump
12 May 2012; Benda Xu <heroxbd@gentoo.org> tinc-1.0.18.ebuild:
keyword ~amd64-linux
diff --git a/net-misc/tinc/tinc-1.0.19.ebuild b/net-misc/tinc/tinc-1.0.19.ebuild
new file mode 100644
index 000000000000..f1b3507d530b
--- /dev/null
+++ b/net-misc/tinc/tinc-1.0.19.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/tinc-1.0.19.ebuild,v 1.1 2012/06/26 13:52:39 blueness Exp $
+
+EAPI="4"
+
+DESCRIPTION="tinc is an easy to configure VPN implementation"
+HOMEPAGE="http://www.tinc-vpn.org/"
+SRC_URI="http://www.tinc-vpn.org/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+lzo uml vde +zlib"
+
+DEPEND=">=dev-libs/openssl-0.9.7
+ lzo? ( dev-libs/lzo:2 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )"
+RDEPEND="${DEPEND}
+ vde? ( net-misc/vde )"
+
+src_configure() {
+ econf \
+ --enable-jumbograms \
+ --disable-tunemu \
+ $(use_enable lzo) \
+ $(use_enable uml) \
+ $(use_enable vde) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodir /etc/tinc
+ dodoc AUTHORS NEWS README THANKS
+ newinitd "${FILESDIR}"/tincd.1 tincd
+ newinitd "${FILESDIR}"/tincd.lo.1 tincd.lo
+ doconfd "${FILESDIR}"/tinc.networks
+ newconfd "${FILESDIR}"/tincd.conf.1 tincd
+}
+
+pkg_postinst() {
+ elog "This package requires the tun/tap kernel device."
+ elog "Look at http://www.tinc-vpn.org/ for how to configure tinc"
+}