summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2006-10-08 16:09:41 +0000
committerMarkus Ullmann <jokey@gentoo.org>2006-10-08 16:09:41 +0000
commit022f7428a40a729c3d108062ec8db8d47671f8d5 (patch)
tree335c2a5574ebc209181b38648103b96b8f8c290b /net-misc/tcpsound/tcpsound-0.3.1.ebuild
parentDropped ~ppc-macos, see you in prefix. (diff)
downloadgentoo-2-022f7428a40a729c3d108062ec8db8d47671f8d5.tar.gz
gentoo-2-022f7428a40a729c3d108062ec8db8d47671f8d5.tar.bz2
gentoo-2-022f7428a40a729c3d108062ec8db8d47671f8d5.zip
Initial commit, thanks to Daniel Willmann in bug #63554 for providing an ebuild
(Portage version: 2.1.2_pre2-r6)
Diffstat (limited to 'net-misc/tcpsound/tcpsound-0.3.1.ebuild')
-rw-r--r--net-misc/tcpsound/tcpsound-0.3.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/tcpsound/tcpsound-0.3.1.ebuild b/net-misc/tcpsound/tcpsound-0.3.1.ebuild
new file mode 100644
index 000000000000..009a87af4563
--- /dev/null
+++ b/net-misc/tcpsound/tcpsound-0.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tcpsound/tcpsound-0.3.1.ebuild,v 1.1 2006/10/08 16:09:41 jokey Exp $
+
+inherit eutils
+
+DESCRIPTION="Play sounds in response to network traffic"
+HOMEPAGE="http://www.ioplex.com/~miallen/tcpsound/"
+SRC_URI="http://www.ioplex.com/~miallen/tcpsound/dl/${P}.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+DEPEND="net-analyzer/tcpdump
+ media-libs/libsdl
+ dev-libs/libmba"
+
+src_compile() {
+ sed -i -e "s;/usr/share/sounds:/usr/local/share/sounds;/usr/share/tcpsound;g"\
+ ${S}/src/tcpsound.c ${S}/elaborate.conf
+
+ sed -i -e "s;/share/sounds;/share/tcpsound;g"\
+ ${S}/Makefile
+ emake || die "emake failed"
+}
+
+src_install() {
+ # Makefile expects /usr/bin to be there...
+ dodir /usr/bin
+ # einstall is required here
+ einstall || die
+
+ dodoc README.txt elaborate.conf
+}