summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2007-02-02 16:47:06 +0000
committerAron Griffis <agriffis@gentoo.org>2007-02-02 16:47:06 +0000
commit2ebef87cd462b975b3a31f167b0cd593538ebc92 (patch)
treec459aec38ca27b665a0796a03df33e65ca89dc45 /net-misc/stunnel
parentUpdated to (hopefully) properly support the Diamond DVD and the Platinum CD a... (diff)
downloadgentoo-2-2ebef87cd462b975b3a31f167b0cd593538ebc92.tar.gz
gentoo-2-2ebef87cd462b975b3a31f167b0cd593538ebc92.tar.bz2
gentoo-2-2ebef87cd462b975b3a31f167b0cd593538ebc92.zip
Bump to 4.20 (from 4.16)
(Portage version: 2.1.2_pre3-r1)
Diffstat (limited to 'net-misc/stunnel')
-rw-r--r--net-misc/stunnel/ChangeLog9
-rw-r--r--net-misc/stunnel/files/digest-stunnel-4.203
-rw-r--r--net-misc/stunnel/stunnel-4.20.ebuild82
3 files changed, 92 insertions, 2 deletions
diff --git a/net-misc/stunnel/ChangeLog b/net-misc/stunnel/ChangeLog
index 319693af4ca9..c124d1c9e708 100644
--- a/net-misc/stunnel/ChangeLog
+++ b/net-misc/stunnel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/stunnel
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/ChangeLog,v 1.60 2006/11/04 17:25:51 dertobi123 Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/ChangeLog,v 1.61 2007/02/02 16:47:06 agriffis Exp $
+
+*stunnel-4.20 (02 Feb 2007)
+
+ 02 Feb 2007; Aron Griffis <agriffis@gentoo.org> +stunnel-4.20.ebuild:
+ Bump to 4.20 (from 4.16)
04 Nov 2006; Tobias Scherbaum <dertobi123@gentoo.org>
stunnel-4.09-r1.ebuild, stunnel-4.16.ebuild:
diff --git a/net-misc/stunnel/files/digest-stunnel-4.20 b/net-misc/stunnel/files/digest-stunnel-4.20
new file mode 100644
index 000000000000..3e4d1f773a90
--- /dev/null
+++ b/net-misc/stunnel/files/digest-stunnel-4.20
@@ -0,0 +1,3 @@
+MD5 cf9940395d3503018f721c962528d2ec stunnel-4.20.tar.gz 513394
+RMD160 6a5dfbabe17804e87ed8c7c75898dba4b4257827 stunnel-4.20.tar.gz 513394
+SHA256 2926b8eda6d90872056145da8a260bd2eab41621c143f8a014ffa7a92e81fd10 stunnel-4.20.tar.gz 513394
diff --git a/net-misc/stunnel/stunnel-4.20.ebuild b/net-misc/stunnel/stunnel-4.20.ebuild
new file mode 100644
index 000000000000..7867b4bbe272
--- /dev/null
+++ b/net-misc/stunnel/stunnel-4.20.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-4.20.ebuild,v 1.1 2007/02/02 16:47:06 agriffis Exp $
+
+inherit ssl-cert eutils flag-o-matic
+
+DESCRIPTION="TLS/SSL - Port Wrapper"
+HOMEPAGE="http://stunnel.mirt.net/"
+SRC_URI="http://www.stunnel.org/download/stunnel/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="ipv6 selinux tcpd"
+
+DEPEND="virtual/libc
+ >=dev-libs/openssl-0.9.6j"
+RDEPEND=">=dev-libs/openssl-0.9.6j
+ selinux? ( sec-policy/selinux-stunnel )"
+
+src_unpack() {
+ unpack ${A}
+ # Hack away generation of certificate
+ sed -i s/^install-data-local:/do-not-run-this:/ "${S}"/tools/Makefile.in
+}
+
+src_compile() {
+ local myconf=""
+ # Don't shoot me for doing this! The stunnel configure script is broke and
+ # doesn't honor --disable-foo
+ if use ipv6 ; then
+ myconf="${myconf} --enable-ipv6"
+ fi
+ if ! use tcpd ; then
+ myconf="${myconf} --disable-libwrap"
+ fi
+ econf ${myconf} || die "econf died"
+ emake || die "emake died"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ rm -rf ${D}/usr/share/doc/${PN}
+ rm -f ${D}/{etc/stunnel/stunnel.conf-sample,usr/sbin/stunnel3}
+ rm -f ${D}/usr/share/man/man8/{stunnel.fr.8,stunnel.pl.8}
+
+ dodoc AUTHORS BUGS CREDITS INSTALL NEWS PORTS README TODO ChangeLog \
+ doc/en/transproxy.txt
+ dohtml doc/stunnel.html doc/en/VNC_StunnelHOWTO.html tools/ca.html \
+ tools/importCA.html
+
+ insinto /etc/stunnel
+ donewins ${FILESDIR}/stunnel.conf stunnel.conf
+ newinitd ${FILESDIR}/stunnel.rc6 stunnel
+ # Check if there's currently an cert already there
+ if [ ! -f /etc/stunnel/stunnel.key ]; then
+ docert stunnel
+ fi
+
+ keepdir /var/run/stunnel
+}
+
+pkg_postinst() {
+ enewgroup stunnel
+ enewuser stunnel -1 -1 -1 stunnel
+
+ chown stunnel:stunnel ${ROOT}/var/run/stunnel
+ chown stunnel:stunnel ${ROOT}/etc/stunnel/stunnel.{conf,crt,csr,key,pem}
+ chmod 0640 ${ROOT}/etc/stunnel/stunnel.{conf,crt,csr,key,pem}
+
+ if [ ! -z "$(egrep '/etc/stunnel/stunnel.pid' \
+ ${ROOT}/etc/stunnel/stunnel.conf )" ] ; then
+
+ ewarn "As of stunnel-4.09, the pid file will be located in /var/run/stunnel."
+ ewarn "Please stop stunnel, etc-update, and start stunnel back up to ensure"
+ ewarn "the update takes place"
+ ewarn ""
+ ewarn "The new location will be /var/run/stunnel/stunnel.pid"
+ ebeep 3
+ epause 3
+ fi
+}