summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2009-10-10 23:48:18 +0000
committerCédric Krier <cedk@gentoo.org>2009-10-10 23:48:18 +0000
commit926e8d89fc6ba85be86b7f50d12b5cb9f44cbc43 (patch)
treedffd908cfe96ac2d162b3511719def313ed58893 /net-misc/openvpn
parentBug 284946 again, prefix needs gcc-apple too. (diff)
downloadgentoo-2-926e8d89fc6ba85be86b7f50d12b5cb9f44cbc43.tar.gz
gentoo-2-926e8d89fc6ba85be86b7f50d12b5cb9f44cbc43.tar.bz2
gentoo-2-926e8d89fc6ba85be86b7f50d12b5cb9f44cbc43.zip
Add eurephia patch for bug #272079
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-misc/openvpn')
-rw-r--r--net-misc/openvpn/ChangeLog6
-rw-r--r--net-misc/openvpn/metadata.xml5
-rw-r--r--net-misc/openvpn/openvpn-2.1_rc20.ebuild15
3 files changed, 21 insertions, 5 deletions
diff --git a/net-misc/openvpn/ChangeLog b/net-misc/openvpn/ChangeLog
index c12c0c0016bb..2be6efa14824 100644
--- a/net-misc/openvpn/ChangeLog
+++ b/net-misc/openvpn/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/openvpn
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/ChangeLog,v 1.166 2009/10/10 23:30:15 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/ChangeLog,v 1.167 2009/10/10 23:48:18 cedk Exp $
+
+ 10 Oct 2009; Cédric Krier <cedk@gentoo.org> openvpn-2.1_rc20.ebuild,
+ metadata.xml:
+ Add eurephia patch for bug #272079
*openvpn-2.1_rc20 (10 Oct 2009)
diff --git a/net-misc/openvpn/metadata.xml b/net-misc/openvpn/metadata.xml
index 4c00b128c56b..046745ad5824 100644
--- a/net-misc/openvpn/metadata.xml
+++ b/net-misc/openvpn/metadata.xml
@@ -6,10 +6,11 @@
<email>cedk@gentoo.org</email>
<name>Cédric Krier</name>
</maintainer>
- <longdescription>OpenVPN is an easy-to-use, robust and highly
-configurable VPN daemon which can be used to securely link two or more
+ <longdescription>OpenVPN is an easy-to-use, robust and highly
+configurable VPN daemon which can be used to securely link two or more
networks using an encrypted tunnel.</longdescription>
<use>
+ <flag name="eurephia">Apply eurephia patch</flag>
<flag name="iproute2">Enabled iproute2 support instead of net-tools</flag>
<flag name="passwordsave">Enables openvpn to save passwords</flag>
<flag name="pkcs11">Enable PKCS#11 smartcard support</flag>
diff --git a/net-misc/openvpn/openvpn-2.1_rc20.ebuild b/net-misc/openvpn/openvpn-2.1_rc20.ebuild
index 272a51147712..62919d428253 100644
--- a/net-misc/openvpn/openvpn-2.1_rc20.ebuild
+++ b/net-misc/openvpn/openvpn-2.1_rc20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.1_rc20.ebuild,v 1.1 2009/10/10 23:30:15 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.1_rc20.ebuild,v 1.2 2009/10/10 23:48:18 cedk Exp $
inherit eutils multilib toolchain-funcs autotools
@@ -8,13 +8,16 @@ DESCRIPTION="OpenVPN is a robust and highly flexible tunneling application compa
SRC_URI="http://openvpn.net/release/${P}.tar.gz
ipv6? (
http://cloud.github.com/downloads/jjo/openvpn-ipv6/openvpn-2.1_rc20-ipv6-0.4.9.patch.gz
+ )
+ eurephia? (
+ mirror://sourceforge/eurephia/${P}_eurephia.patch
)"
HOMEPAGE="http://openvpn.net/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="examples iproute2 ipv6 minimal pam passwordsave selinux ssl static pkcs11 threads userland_BSD"
+IUSE="eurephia examples iproute2 ipv6 minimal pam passwordsave selinux ssl static pkcs11 threads userland_BSD"
DEPEND=">=dev-libs/lzo-1.07
kernel_linux? (
@@ -43,6 +46,7 @@ src_unpack() {
epatch "${FILESDIR}/${PN}-2.1_rc13-peercred.patch"
epatch "${FILESDIR}"/openvpn-2.1_rc20-pkcs11.patch
use ipv6 && epatch "${WORKDIR}"/openvpn-2.1_rc20-ipv6-0.4.9.patch
+ use eurephia && epatch "${DISTDIR}/${P}_eurephia.patch"
sed -i \
-e "s/gcc \${CC_FLAGS}/\${CC} \${CFLAGS} -Wall/" \
-e "s/-shared/-shared \${LDFLAGS}/" \
@@ -171,4 +175,11 @@ pkg_postinst() {
einfo "For more information please visit:"
einfo "http://github.com/jjo/openvpn-ipv6"
fi
+
+ if use eurephia ; then
+ einfo ""
+ einfo "This build contains eurephia patch."
+ einfo "For more information please visit:"
+ einfo "http://www.eurephia.net/"
+ fi
}