summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-20 05:48:24 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-20 05:48:24 +0000
commit9d516738a653d1fa74df247d2107a6eca9a7e205 (patch)
tree109467595c51c7c1587190b3dd4d43c92f9ebb8e /net-misc/openssh
parentVersion bump for testing. (diff)
downloadgentoo-2-9d516738a653d1fa74df247d2107a6eca9a7e205.tar.gz
gentoo-2-9d516738a653d1fa74df247d2107a6eca9a7e205.tar.bz2
gentoo-2-9d516738a653d1fa74df247d2107a6eca9a7e205.zip
Fix openssl version check to accept dev/beta/release versions.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'net-misc/openssh')
-rw-r--r--net-misc/openssh/ChangeLog6
-rw-r--r--net-misc/openssh/files/openssh-6.6_p1-openssl-ignore-status.patch15
-rw-r--r--net-misc/openssh/openssh-6.6_p1.ebuild3
3 files changed, 22 insertions, 2 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index ee5859a1ee8f..fe3291f38aa3 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/openssh
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.504 2014/03/19 23:40:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.505 2014/03/20 05:48:23 vapier Exp $
+
+ 20 Mar 2014; Mike Frysinger <vapier@gentoo.org>
+ +files/openssh-6.6_p1-openssl-ignore-status.patch, openssh-6.6_p1.ebuild:
+ Fix openssl version check to accept dev/beta/release versions.
*openssh-6.6_p1 (19 Mar 2014)
diff --git a/net-misc/openssh/files/openssh-6.6_p1-openssl-ignore-status.patch b/net-misc/openssh/files/openssh-6.6_p1-openssl-ignore-status.patch
new file mode 100644
index 000000000000..2f614104de4e
--- /dev/null
+++ b/net-misc/openssh/files/openssh-6.6_p1-openssl-ignore-status.patch
@@ -0,0 +1,15 @@
+the last nibble of the openssl version represents the status. that is,
+whether it is a beta or release. when it comes to version checks in
+openssh, this component does not matter, so ignore it.
+
+--- a/entropy.c
++++ b/entropy.c
+@@ -216,7 +216,7 @@ seed_rng(void)
+ * allow 1.0.1 to work with 1.0.0). Going backwards is only allowed
+ * within a patch series.
+ */
+- u_long version_mask = SSLeay() >= 0x1000000f ? ~0xffff0L : ~0xff0L;
++ u_long version_mask = SSLeay() >= 0x1000000f ? ~0xfffffL : ~0xff0L;
+ if (((SSLeay() ^ OPENSSL_VERSION_NUMBER) & version_mask) ||
+ (SSLeay() >> 12) < (OPENSSL_VERSION_NUMBER >> 12))
+ fatal("OpenSSL version mismatch. Built against %lx, you "
diff --git a/net-misc/openssh/openssh-6.6_p1.ebuild b/net-misc/openssh/openssh-6.6_p1.ebuild
index 4d433ec3699a..8578a4dcd396 100644
--- a/net-misc/openssh/openssh-6.6_p1.ebuild
+++ b/net-misc/openssh/openssh-6.6_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-6.6_p1.ebuild,v 1.1 2014/03/19 23:40:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-6.6_p1.ebuild,v 1.2 2014/03/20 05:48:23 vapier Exp $
EAPI="4"
inherit eutils user flag-o-matic multilib autotools pam systemd versionator
@@ -117,6 +117,7 @@ src_prepare() {
use ldap && ewarn "Sorry, X509 and LDAP conflict internally, disabling LDAP"
fi
epatch "${FILESDIR}"/${PN}-4.7_p1-GSSAPI-dns.patch #165444 integrated into gsskex
+ epatch "${FILESDIR}"/${PN}-6.6_p1-openssl-ignore-status.patch
if [[ -n ${HPN_PATCH} ]] && use hpn; then
epatch "${WORKDIR}"/${HPN_PATCH%.*}
epatch "${FILESDIR}"/${PN}-6.5_p1-hpn-cipher-align.patch #498632