summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-04-24 19:41:58 +0000
committerVlastimil Babka <caster@gentoo.org>2010-04-24 19:41:58 +0000
commit9502e950dccd4e3116076e486f49fccf7c59d158 (patch)
tree7197f6d26908d0068bbc1ed9d52ecabc0da47907 /net-misc/omniORB
parentalpha/arm/ia64/sh/sparc stable wrt #314597 (diff)
downloadgentoo-2-9502e950dccd4e3116076e486f49fccf7c59d158.tar.gz
gentoo-2-9502e950dccd4e3116076e486f49fccf7c59d158.tar.bz2
gentoo-2-9502e950dccd4e3116076e486f49fccf7c59d158.zip
Revbump with python improvements, thanks to Arfrefer, bug #315835. Add patch to respect LDFLAGS, bug #284191.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/omniORB')
-rw-r--r--net-misc/omniORB/ChangeLog9
-rw-r--r--net-misc/omniORB/files/ldflags.patch11
-rw-r--r--net-misc/omniORB/omniORB-4.1.4-r1.ebuild97
3 files changed, 116 insertions, 1 deletions
diff --git a/net-misc/omniORB/ChangeLog b/net-misc/omniORB/ChangeLog
index f1d6ded4f857..b40170734fbc 100644
--- a/net-misc/omniORB/ChangeLog
+++ b/net-misc/omniORB/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/omniORB
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/ChangeLog,v 1.61 2010/04/23 20:04:01 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/ChangeLog,v 1.62 2010/04/24 19:41:57 caster Exp $
+
+*omniORB-4.1.4-r1 (24 Apr 2010)
+
+ 24 Apr 2010; Vlastimil Babka <caster@gentoo.org> +omniORB-4.1.4-r1.ebuild,
+ +files/ldflags.patch:
+ Revbump with python improvements, thanks to Arfrefer, bug #315835. Add
+ patch to respect LDFLAGS, bug #284191.
23 Apr 2010; Vlastimil Babka <caster@gentoo.org> -files/omniORB-4.0.0,
-omniORB-4.0.5.ebuild, -omniORB-4.1.2.ebuild, -omniORB-4.1.3.ebuild,
diff --git a/net-misc/omniORB/files/ldflags.patch b/net-misc/omniORB/files/ldflags.patch
new file mode 100644
index 000000000000..471df27ae7f4
--- /dev/null
+++ b/net-misc/omniORB/files/ldflags.patch
@@ -0,0 +1,11 @@
+--- mk/beforeauto.mk.in.orig 2010-04-24 21:13:17.000000000 +0200
++++ mk/beforeauto.mk.in 2010-04-24 21:14:24.000000000 +0200
+@@ -541,7 +541,7 @@
+ SharedLibraryLibNameTemplate = lib$$1$$2.$(SHAREDLIB_SUFFIX)
+ SharedLibraryImplibNameTemplate = lib$$1$$2.a
+
+-SharedLibraryPlatformLinkFlagsTemplate = -shared -Wl,-soname,$$soname
++SharedLibraryPlatformLinkFlagsTemplate = -shared -Wl,-soname,$$soname @LDFLAGS@
+
+ define SharedLibraryFullName
+ fn() { \
diff --git a/net-misc/omniORB/omniORB-4.1.4-r1.ebuild b/net-misc/omniORB/omniORB-4.1.4-r1.ebuild
new file mode 100644
index 000000000000..380cea19ba82
--- /dev/null
+++ b/net-misc/omniORB/omniORB-4.1.4-r1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/omniORB-4.1.4-r1.ebuild,v 1.1 2010/04/24 19:41:57 caster Exp $
+
+EAPI="3"
+
+# 2.5 is problematic due to bug #261330
+PYTHON_DEPEND="2:2.6"
+
+inherit python eutils
+
+DESCRIPTION="A robust, high-performance CORBA 2 ORB"
+SRC_URI="mirror://sourceforge/omniorb/${P}.tar.gz"
+HOMEPAGE="http://omniorb.sourceforge.net/"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc ssl"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # respect ldflags, bug #284191
+ epatch "${FILESDIR}/ldflags.patch"
+
+ sed -i -e 's/^CXXDEBUGFLAGS.*/CXXDEBUGFLAGS = $(OPTCXXFLAGS)/' \
+ -e 's/^CDEBUGFLAGS.*/CDEBUGFLAGS = $(OPTCFLAGS)/' \
+ mk/beforeauto.mk.in \
+ mk/platforms/i586_linux_2.0*.mk || die "sed failed"
+}
+
+src_configure() {
+ mkdir build && cd build || die
+
+ local MY_CONF="--prefix=/usr --with-omniORB-config=/etc/omniorb/omniORB.cfg \
+ --with-omniNames-logdir=/var/log/omniORB --libdir=/usr/$(get_libdir)"
+
+ use ssl && MY_CONF="${MY_CONF} --with-openssl=/usr"
+
+ PYTHON="$(PYTHON -a)" ECONF_SOURCE=".." econf ${MY_CONF}
+}
+
+src_compile() {
+ cd build
+ emake OPTCFLAGS="${CFLAGS}" OPTCXXFLAGS="${CXXFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ cd build
+ emake DESTDIR="${D}" install || die "emake install failed"
+ # this looks redundant
+ rm "${D}/usr/bin/omniidlrun.py" || die
+
+ cd "${S}"
+ dodoc COPYING* CREDITS README* ReleaseNotes* || die
+
+ if use doc; then
+ dohtml doc/*.html || die
+ dohtml -r doc/omniORB || die
+ docinto print
+ dodoc doc/*.pdf || die
+ fi
+
+ dodir /etc/env.d/
+ cat <<- EOF > "${T}/90omniORB"
+ PATH="/usr/share/omniORB/bin/scripts"
+ OMNIORB_CONFIG="/etc/omniorb/omniORB.cfg"
+ EOF
+ doenvd "${T}/90omniORB" || die
+ doinitd "${FILESDIR}"/omniNames || die
+
+ cp "sample.cfg" "${T}/omniORB.cfg" || die
+ cat <<- EOF >> "${T}/omniORB.cfg"
+ # resolve the omniNames running on localhost
+ InitRef = NameService=corbaname::localhost
+ EOF
+ dodir /etc/omniorb
+ insinto /etc/omniorb
+ doins "${T}/omniORB.cfg" || die
+
+ keepdir /var/log/omniORB
+}
+
+pkg_postinst() {
+ elog "Since 4.1.2, the omniORB init script has been renamed to omniNames for clarity."
+ python_mod_optimize omniidl omniidl_be
+}
+
+pkg_postrm() {
+ python_mod_cleanup omniidl omniidl_be
+}