summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2003-07-30 00:08:35 +0000
committerJason Wever <weeve@gentoo.org>2003-07-30 00:08:35 +0000
commitafd295fdbe7a749c48548b9ea3c51094efd225cb (patch)
treec7d6633cb1bdd87440add74c0096bde4784d5db8 /net-misc/jigdo/jigdo-0.7.0.ebuild
parentInitial import. Resolves bug #21829. (diff)
downloadgentoo-2-afd295fdbe7a749c48548b9ea3c51094efd225cb.tar.gz
gentoo-2-afd295fdbe7a749c48548b9ea3c51094efd225cb.tar.bz2
gentoo-2-afd295fdbe7a749c48548b9ea3c51094efd225cb.zip
Initial import. Resolves bug #21829.
Diffstat (limited to 'net-misc/jigdo/jigdo-0.7.0.ebuild')
-rw-r--r--net-misc/jigdo/jigdo-0.7.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/jigdo/jigdo-0.7.0.ebuild b/net-misc/jigdo/jigdo-0.7.0.ebuild
new file mode 100644
index 000000000000..ea3754938b8b
--- /dev/null
+++ b/net-misc/jigdo/jigdo-0.7.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/jigdo-0.7.0.ebuild,v 1.1 2003/07/30 00:08:25 weeve Exp $
+
+inherit eutils
+
+DESCRIPTION="Jigsaw Download, or short jigdo, is a tool designed to ease the distribution of very large files over the internet, for example CD or DVD images."
+HOMEPAGE="http://home.in.tum.de/~atterer/jigdo/"
+SRC_URI="http://home.in.tum.de/~atterer/jigdo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+
+IUSE="gtk nls"
+
+DEPEND="gtk? ( >=gtk+-2.0.6 )
+ nls? ( sys-devel/gettext )
+ >=libwww-5.3.2"
+
+src_compile() {
+local myconf
+
+ use nls || myconf="--disable-nls"
+ use gtk || myconf="--without-libdb --without-gui"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man $myconf \
+ --datadir=/usr/share || die "./configure failed"
+
+ # Patch the Makefile so that when jidgo is installed, jigdo-lite has
+ # the correct path to the debian mirrors file.
+ epatch ${FILESDIR}/makefile.patch
+
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc COPYING README THANKS VERSION changelog
+ dodoc doc/*.txt
+ dohtml doc/*.html
+}