summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2013-05-10 08:33:58 +0000
committerPeter Volkov <pva@gentoo.org>2013-05-10 08:33:58 +0000
commit1f9ee00e82d891f37d78fd3fa0dd49a50b58f053 (patch)
tree71dae7230d9f772456d989119e5840129199d79f /net-misc/ipv6calc
parentFix inherit (diff)
downloadgentoo-2-1f9ee00e82d891f37d78fd3fa0dd49a50b58f053.tar.gz
gentoo-2-1f9ee00e82d891f37d78fd3fa0dd49a50b58f053.tar.bz2
gentoo-2-1f9ee00e82d891f37d78fd3fa0dd49a50b58f053.zip
Version bump.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key F1989B07)
Diffstat (limited to 'net-misc/ipv6calc')
-rw-r--r--net-misc/ipv6calc/ChangeLog8
-rw-r--r--net-misc/ipv6calc/ipv6calc-0.94.0.ebuild57
-rw-r--r--net-misc/ipv6calc/metadata.xml4
3 files changed, 68 insertions, 1 deletions
diff --git a/net-misc/ipv6calc/ChangeLog b/net-misc/ipv6calc/ChangeLog
index 4057a1dc19d9..01139c37a0dd 100644
--- a/net-misc/ipv6calc/ChangeLog
+++ b/net-misc/ipv6calc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/ipv6calc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ChangeLog,v 1.62 2013/03/17 15:08:18 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ChangeLog,v 1.63 2013/05/10 08:33:58 pva Exp $
+
+*ipv6calc-0.94.0 (09 May 2013)
+
+ 09 May 2013; Peter Volkov <pva@gentoo.org> +ipv6calc-0.94.0.ebuild,
+ metadata.xml:
+ Version bump.
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/net-misc/ipv6calc/ipv6calc-0.94.0.ebuild b/net-misc/ipv6calc/ipv6calc-0.94.0.ebuild
new file mode 100644
index 000000000000..5654b3bbb945
--- /dev/null
+++ b/net-misc/ipv6calc/ipv6calc-0.94.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ipv6calc-0.94.0.ebuild,v 1.1 2013/05/10 08:33:58 pva Exp $
+
+EAPI="4"
+inherit fixheadtails
+
+DESCRIPTION="IPv6 address calculator"
+HOMEPAGE="http://www.deepspace6.net/projects/ipv6calc.html"
+SRC_URI="ftp://ftp.bieringer.de/pub/linux/IPv6/ipv6calc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="geoip"
+
+DEPEND="
+ dev-perl/URI
+ geoip? ( >=dev-libs/geoip-1.4.7 )
+"
+
+src_prepare() {
+ # Disable broken test for now
+ sed '/fe80--218-8bff-fe17-a226s4.ipv6-literal.net/d' \
+ -i ipv6calc/test_ipv6calc.sh || die
+ sed -e '/^2001-db8-0-0-0-0-0-1.ipv6-literal.net/d' \
+ -e '/^2001-db8--1.ipv6-literal.net/d' \
+ -i ipv6calc/test_scenarios.sh || die
+ ht_fix_file configure
+}
+
+src_configure() {
+ if use geoip; then
+ myconf=$(use_enable geoip)
+ myconf+=" --with-geoip-ipv4-default-file=/usr/share/GeoIP/GeoIP.dat"
+ myconf+=" --with-geoip-ipv6-default-file=/usr/share/GeoIP/GeoIPv6.dat"
+ fi
+ econf ${myconf}
+}
+
+src_compile() {
+ # Disable default CFLAGS (-O2 and -g)
+ emake DEFAULT_CFLAGS=""
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]]; then
+ # Disable tests that fail as root
+ echo true > ipv6logstats/test_ipv6logstats.sh
+ fi
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog CREDITS README TODO USAGE
+}
diff --git a/net-misc/ipv6calc/metadata.xml b/net-misc/ipv6calc/metadata.xml
index 035515b5b9b9..2f853e4b8b28 100644
--- a/net-misc/ipv6calc/metadata.xml
+++ b/net-misc/ipv6calc/metadata.xml
@@ -3,6 +3,10 @@
<pkgmetadata>
<herd>proxy-maintainers</herd>
<maintainer>
+ <email>pva@gentoo.org</email>
+ <name>Peter Volkov</name>
+ </maintainer>
+ <maintainer>
<email>bmangentoo@gmail.com</email>
<name>Aaron Bauman</name>
</maintainer>