summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-03-22 19:34:13 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-03-22 19:34:13 +0000
commit66d32deee721a874ad7c16a259c8d698415204e1 (patch)
treec77b512eb1f8d6c53a2612f27d5e7e4c85ae7696 /net-misc/htun
parentImport patch from debian to fix compilation with gcc4.8 (diff)
downloadgentoo-2-66d32deee721a874ad7c16a259c8d698415204e1.tar.gz
gentoo-2-66d32deee721a874ad7c16a259c8d698415204e1.tar.bz2
gentoo-2-66d32deee721a874ad7c16a259c8d698415204e1.zip
Remove old.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'net-misc/htun')
-rw-r--r--net-misc/htun/ChangeLog9
-rw-r--r--net-misc/htun/files/htun-0.9.5-glibc.patch40
-rw-r--r--net-misc/htun/htun-0.9.5.ebuild53
3 files changed, 6 insertions, 96 deletions
diff --git a/net-misc/htun/ChangeLog b/net-misc/htun/ChangeLog
index e21e570104b9..151789634ddd 100644
--- a/net-misc/htun/ChangeLog
+++ b/net-misc/htun/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/htun
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/htun/ChangeLog,v 1.9 2013/03/12 04:35:43 pinkbyte Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/htun/ChangeLog,v 1.10 2014/03/22 19:34:13 kensington Exp $
+
+ 22 Mar 2014; Michael Palimaka <kensington@gentoo.org>
+ -files/htun-0.9.5-glibc.patch, -htun-0.9.5.ebuild:
+ Remove old.
*htun-0.9.6 (12 Mar 2013)
@@ -38,4 +42,3 @@
30 Dec 2003; Chuck Short <zul@gentoo.org> htun-0.9.5.ebuild:
Initial version by Chris Verges <squirrel at headnut.org>
modified by me. Closes #35113.
-
diff --git a/net-misc/htun/files/htun-0.9.5-glibc.patch b/net-misc/htun/files/htun-0.9.5-glibc.patch
deleted file mode 100644
index e568e443586c..000000000000
--- a/net-misc/htun/files/htun-0.9.5-glibc.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-get things building with glibc-2.8
-
-http://bugs.gentoo.org/248100
-
---- include/common.h
-+++ include/common.h
-@@ -23,6 +23,7 @@
- #ifndef __COMMON_H
- #define __COMMON_H
-
-+#include <limits.h>
- #include <netinet/in.h>
- #include <time.h>
- #include "queue.h"
---- src/queue.c
-+++ src/queue.c
-@@ -34,8 +34,8 @@
- #define q_lock(q, cnt) do { int _old; \
- pthread_setcanceltype(PTHREAD_CANCEL_DEFERRED,&_old); \
- pthread_cleanup_push(q_sempost,q); \
-- pthread_cleanup_push(q_release,q) \
-- pthread_cleanup_push(q_decrement, cnt) \
-+ pthread_cleanup_push(q_release,q); \
-+ pthread_cleanup_push(q_decrement, cnt); \
- pthread_mutex_lock(&((q)->mutex)); \
- (*(cnt))++; \
- pthread_testcancel()
-@@ -43,9 +43,9 @@
- /* q_unlock() is called when intentionally exiting critical section */
- #define q_unlock(cond) \
- pthread_testcancel(); \
-- pthread_cleanup_pop(1) \
-- pthread_cleanup_pop(1) \
-- pthread_cleanup_pop(1) \
-+ pthread_cleanup_pop(1); \
-+ pthread_cleanup_pop(1); \
-+ pthread_cleanup_pop(1); \
- if(cond) pthread_cond_broadcast(cond); \
- pthread_setcanceltype(_old,NULL); } while(0)
-
diff --git a/net-misc/htun/htun-0.9.5.ebuild b/net-misc/htun/htun-0.9.5.ebuild
deleted file mode 100644
index 161a37e86ade..000000000000
--- a/net-misc/htun/htun-0.9.5.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/htun/htun-0.9.5.ebuild,v 1.8 2009/01/14 03:47:53 vapier Exp $
-
-inherit eutils
-
-DESCRIPTION="Project to tunnel IP traffic over HTTP"
-HOMEPAGE="http://htun.runslinux.net/"
-SRC_URI="http://htun.runslinux.net/dist/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-DEPEND="dev-util/yacc"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-glibc.patch #248100
- sed -i \
- -e '/^CFLAGS/s:=\(.*\)-O :+=\1 $(CPPFLAGS) :' \
- -e '/LDFLAGS/s:=:+=:' \
- src/Makefile || die
-}
-
-src_compile() {
- cd src
- emake all || die
-}
-
-src_install() {
- dosbin src/htund || die
- insinto /etc
- doins doc/htund.conf
- dodoc doc/* README
-}
-
-pkg_postinst() {
- einfo "NOTE: HTun requires the Universal TUN/TAP module"
- einfo "available in the Linux kernel. Make sure you have"
- einfo "compiled the tun.o driver as a module!"
- einfo
- einfo "It can be found in the kernel configuration under"
- einfo "Network Device Support --> Universal TUN/TAP"
- einfo
- einfo "To configure HTun, run the following commands as root:"
- einfo " # mknod /dev/net/tun c 10 200"
- einfo " # echo \"alias char-major-10-200 tun\" >> /etc/modules.conf"
- einfo " # depmod -e"
-}