summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-27 08:29:44 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-27 08:29:44 +0000
commit70ffa74aa58ecca33039f6731be0cfce65a9dc70 (patch)
tree19b594332d30b23bf2222077aa292ce01d29477b /net-misc/hotot
parentDropping stable keywords since failover is broken (diff)
downloadgentoo-2-70ffa74aa58ecca33039f6731be0cfce65a9dc70.tar.gz
gentoo-2-70ffa74aa58ecca33039f6731be0cfce65a9dc70.tar.bz2
gentoo-2-70ffa74aa58ecca33039f6731be0cfce65a9dc70.zip
Fix dependencies #427294 #432818
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/hotot')
-rw-r--r--net-misc/hotot/ChangeLog9
-rw-r--r--net-misc/hotot/hotot-0.9.8.7-r1.ebuild63
-rw-r--r--net-misc/hotot/hotot-0.9.8.7.ebuild5
3 files changed, 73 insertions, 4 deletions
diff --git a/net-misc/hotot/ChangeLog b/net-misc/hotot/ChangeLog
index 94f9e881a58f..7c1851f26c71 100644
--- a/net-misc/hotot/ChangeLog
+++ b/net-misc/hotot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/hotot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/ChangeLog,v 1.18 2012/07/09 11:55:16 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/ChangeLog,v 1.19 2012/08/27 08:29:44 patrick Exp $
+
+*hotot-0.9.8.7-r1 (27 Aug 2012)
+
+ 27 Aug 2012; Patrick Lauer <patrick@gentoo.org> +hotot-0.9.8.7-r1.ebuild,
+ hotot-0.9.8.7.ebuild:
+ Fix dependencies #427294 #432818
09 Jul 2012; Agostino Sarubbo <ago@gentoo.org> hotot-0.9.8.7.ebuild:
Stable for amd64, wrt bug #425226
@@ -88,4 +94,3 @@
+hotot-9999.ebuild, +metadata.xml:
Initial import, thanks to Paweł Pogorzelski <pawelpogorzelski@gmail.com> on
bug #346297.
-
diff --git a/net-misc/hotot/hotot-0.9.8.7-r1.ebuild b/net-misc/hotot/hotot-0.9.8.7-r1.ebuild
new file mode 100644
index 000000000000..96d803ec8df2
--- /dev/null
+++ b/net-misc/hotot/hotot-0.9.8.7-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/hotot-0.9.8.7-r1.ebuild,v 1.1 2012/08/27 08:29:44 patrick Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="gtk? 2"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit cmake-utils python vcs-snapshot
+
+DESCRIPTION="lightweight & open source microblogging client"
+HOMEPAGE="http://hotot.org"
+SRC_URI="https://github.com/shellex/Hotot/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="chrome gtk kde qt4"
+
+RDEPEND="dev-python/PyQt4[sql]
+ dev-python/dbus-python
+ gtk? ( dev-python/pywebkitgtk )
+ qt4? ( x11-libs/qt-webkit:4
+ kde? ( kde-base/kdelibs ) )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+REQUIRED_USE="|| ( chrome gtk qt4 )"
+
+pkg_setup() {
+ if ! use gtk ; then
+ if ! use qt4 ; then
+ ewarn "neither gtk not qt4 binaries will be build"
+ fi
+ fi
+ python_pkg_setup
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs} \
+ $(cmake-utils_use_with chrome CHROME) \
+ $(cmake-utils_use_with gtk GTK) \
+ $(cmake-utils_use_with kde KDE) \
+ $(cmake-utils_use_with qt4 QT) \
+ -DPYTHON_EXECUTABLE=$(PYTHON -2 -a)"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ find "${D}" -name "*.pyc" -delete
+}
+
+pkg_postinst() {
+ if use chrome; then
+ elog "TO install hotot for chrome, open chromium/google-chrome,"
+ elog "vist chrome://chrome/extensions/ and load /usr/share/hotot"
+ elog "as unpacked extension."
+ fi
+}
diff --git a/net-misc/hotot/hotot-0.9.8.7.ebuild b/net-misc/hotot/hotot-0.9.8.7.ebuild
index 213fae6bfcbb..203896fec8f3 100644
--- a/net-misc/hotot/hotot-0.9.8.7.ebuild
+++ b/net-misc/hotot/hotot-0.9.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/hotot-0.9.8.7.ebuild,v 1.5 2012/07/09 11:55:16 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/hotot-0.9.8.7.ebuild,v 1.6 2012/08/27 08:29:44 patrick Exp $
EAPI=4
@@ -18,7 +18,8 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="chrome gtk kde qt4"
-RDEPEND="
+RDEPEND="dev-python/PyQt4[sql]
+ dev-python/dbus-python
gtk? ( dev-python/pywebkitgtk )
qt4? ( x11-libs/qt-webkit:4
kde? ( kde-base/kdelibs ) )"