summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-01-26 17:04:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-01-26 17:04:49 +0000
commit8121b145d9da6fce82203aaff71b2a05a343fe00 (patch)
tree706f9883178790c818bd298042b2d4f3a32a34c9 /net-misc/dhcpcd
parentx86 stable (diff)
downloadgentoo-2-8121b145d9da6fce82203aaff71b2a05a343fe00.tar.gz
gentoo-2-8121b145d9da6fce82203aaff71b2a05a343fe00.tar.bz2
gentoo-2-8121b145d9da6fce82203aaff71b2a05a343fe00.zip
Upgrade the duid file to the new format if needed. Proxying for Roy.
(Portage version: 2.1.4)
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/ChangeLog5
-rw-r--r--net-misc/dhcpcd/dhcpcd-3.2.0.ebuild8
2 files changed, 11 insertions, 2 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index 9154d0184a2b..0d095e890a59 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.175 2008/01/25 11:06:27 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.176 2008/01/26 17:04:49 flameeyes Exp $
+
+ 26 Jan 2008; Diego Pettenò <flameeyes@gentoo.org> dhcpcd-3.2.0.ebuild:
+ Upgrade the duid file to the new format if needed. Proxying for Roy.
*dhcpcd-3.2.0 (25 Jan 2008)
diff --git a/net-misc/dhcpcd/dhcpcd-3.2.0.ebuild b/net-misc/dhcpcd/dhcpcd-3.2.0.ebuild
index 98518dd8b514..f2af5eb52a95 100644
--- a/net-misc/dhcpcd/dhcpcd-3.2.0.ebuild
+++ b/net-misc/dhcpcd/dhcpcd-3.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-3.2.0.ebuild,v 1.1 2008/01/25 11:06:27 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-3.2.0.ebuild,v 1.2 2008/01/26 17:04:49 flameeyes Exp $
inherit toolchain-funcs
@@ -55,6 +55,12 @@ src_install() {
}
pkg_postinst() {
+ # Upgrade the duid file to the new format if needed
+ local duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
+ if [ -e "${duid}" ] && ! grep -q '..:..:..:..:..:..' "${duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${duid}"
+ fi
+
if use zeroconf; then
elog "You have installed dhcpcd with zeroconf support."
elog "This means that it will always obtain an IP address even if no"