summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2007-06-25 12:19:40 +0000
committerDaniel Black <dragonheart@gentoo.org>2007-06-25 12:19:40 +0000
commite7421b5837f692542e4a9b13dd8fc136714afd97 (patch)
treed57f27a5cbba02f33c0857843cc4180239a97b50 /net-misc/curl
parentBetter handling of the icon files (diff)
downloadgentoo-2-e7421b5837f692542e4a9b13dd8fc136714afd97.tar.gz
gentoo-2-e7421b5837f692542e4a9b13dd8fc136714afd97.tar.bz2
gentoo-2-e7421b5837f692542e4a9b13dd8fc136714afd97.zip
version bump
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/ChangeLog8
-rw-r--r--net-misc/curl/curl-7.16.3.ebuild (renamed from net-misc/curl/curl-7.16.3_pre20070610.ebuild)16
-rw-r--r--net-misc/curl/curl-7.16.3_pre20070418.ebuild100
-rw-r--r--net-misc/curl/files/digest-curl-7.16.33
-rw-r--r--net-misc/curl/files/digest-curl-7.16.3_pre200704183
-rw-r--r--net-misc/curl/files/digest-curl-7.16.3_pre200706103
6 files changed, 19 insertions, 114 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index 6201a870cd65..93c4b8662f61 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/curl
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.83 2007/06/11 01:21:54 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.84 2007/06/25 12:19:40 dragonheart Exp $
+
+*curl-7.16.3 (25 Jun 2007)
+
+ 25 Jun 2007; Daniel Black <dragonheart@gentoo.org> +curl-7.16.3.ebuild,
+ -curl-7.16.3_pre20070418.ebuild, -curl-7.16.3_pre20070610.ebuild:
+ release thanks to upstream.
*curl-7.16.3_pre20070610 (11 Jun 2007)
diff --git a/net-misc/curl/curl-7.16.3_pre20070610.ebuild b/net-misc/curl/curl-7.16.3.ebuild
index abd382f24725..b1312b720efd 100644
--- a/net-misc/curl/curl-7.16.3_pre20070610.ebuild
+++ b/net-misc/curl/curl-7.16.3.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.16.3_pre20070610.ebuild,v 1.1 2007/06/11 01:21:54 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.16.3.ebuild,v 1.1 2007/06/25 12:19:40 dragonheart Exp $
# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
inherit libtool eutils
-MY_P=${P/_pre/-}
+#MY_P=${P/_pre/-}
DESCRIPTION="A Client that groks URLs"
HOMEPAGE="http://curl.haxx.se/ http://curl.planetmirror.com"
-SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
-#SRC_URI="http://curl.planetmirror.com/download/${P}.tar.bz2"
+#SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
LICENSE="MIT X11"
SLOT="0"
@@ -23,7 +23,8 @@ RDEPEND="gnutls? ( net-libs/gnutls )
ldap? ( net-nds/openldap )
idn? ( net-dns/libidn )
ares? ( >=net-dns/c-ares-1.4.0 )
- kerberos? ( virtual/krb5 )"
+ kerberos? ( virtual/krb5 )
+ app-misc/ca-certificates"
# net-libs/libssh2 (masked) --with-libssh2
# fbopenssl (not in gentoo) --with-spnego
@@ -36,7 +37,7 @@ DEPEND="${RDEPEND}
dev-lang/perl
)"
# used - but can do without in self test: net-misc/stunnel
-S="${WORKDIR}"/${MY_P}
+#S="${WORKDIR}"/${MY_P}
src_unpack() {
unpack ${A}
@@ -63,7 +64,7 @@ src_compile() {
--enable-largefile
--enable-maintainer-mode
--disable-sspi
- --without-ca-bundle
+ --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
--without-krb4
--without-libssh2
--without-spnego"
@@ -91,6 +92,7 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "installed failed for current version"
+ rm -rf "${D}"/etc/
# https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
insinto /usr/share/aclocal
diff --git a/net-misc/curl/curl-7.16.3_pre20070418.ebuild b/net-misc/curl/curl-7.16.3_pre20070418.ebuild
deleted file mode 100644
index b45e6266c4ae..000000000000
--- a/net-misc/curl/curl-7.16.3_pre20070418.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.16.3_pre20070418.ebuild,v 1.1 2007/04/18 11:04:51 dragonheart Exp $
-
-# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
-
-inherit libtool eutils
-
-MY_P=${P/_pre/-}
-DESCRIPTION="A Client that groks URLs"
-HOMEPAGE="http://curl.haxx.se/ http://curl.planetmirror.com"
-SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
-#SRC_URI="http://curl.planetmirror.com/download/${P}.tar.bz2"
-
-LICENSE="MIT X11"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="ssl ipv6 ldap ares gnutls idn kerberos test"
-
-RDEPEND="gnutls? ( net-libs/gnutls )
- ssl? ( !gnutls? ( dev-libs/openssl ) )
- ldap? ( net-nds/openldap )
- idn? ( net-dns/libidn )
- ares? ( net-dns/c-ares )
- kerberos? ( virtual/krb5 )"
-
-DEPEND="${RDEPEND}
- test? (
- sys-apps/diffutils
- dev-lang/perl
- )"
-# used - but can do without in self test: net-misc/stunnel
-S="${WORKDIR}"/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-# epatch "${FILESDIR}"/${P}-strip-ldflags.patch
- epatch "${FILESDIR}"/curl-7.16.2-strip-ldflags.patch
- elibtoolize
-}
-
-src_compile() {
-
- myconf="$(use_enable ldap)
- $(use_with idn libidn)
- $(use_enable kerberos gssapi)
- $(use_enable ipv6)
- --enable-http
- --enable-ftp
- --enable-gopher
- --enable-file
- --enable-dict
- --enable-manual
- --enable-telnet
- --enable-nonblocking
- --enable-largefile
- --enable-maintainer-mode"
-
- if use ipv6 && use ares; then
- ewarn "c-ares support disabled because it is incompatible with ipv6."
- myconf="${myconf} --disable-ares"
- else
- myconf="${myconf} $(use_enable ares)"
- fi
-
- if use gnutls; then
- myconf="${myconf} --without-ssl --with-gnutls=/usr"
- elif use ssl; then
- myconf="${myconf} --without-gnutls --with-ssl=/usr"
- else
- myconf="${myconf} --without-gnutls --without-ssl"
- fi
-
- if use kerberos; then
- myconf="${myconf} --with-gssapi=/usr"
- fi
-
- econf ${myconf} || die 'configure failed'
- emake || die "install failed for current version"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "installed failed for current version"
-
- insinto /usr/share/aclocal
- doins docs/libcurl/libcurl.m4
-
- dodoc CHANGES README
- dodoc docs/FEATURES docs/INTERNALS
- dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
-}
-
-pkg_postinst() {
- if [[ -e "${ROOT}"/usr/$(get_libdir)/libcurl.so.3 ]] ; then
- ewarn "You must re-compile all packages that are linked against"
- ewarn "curl-7.15.* by using revdep-rebuild from gentoolkit:"
- ewarn "# revdep-rebuild --library libcurl.so.3"
- fi
-}
diff --git a/net-misc/curl/files/digest-curl-7.16.3 b/net-misc/curl/files/digest-curl-7.16.3
new file mode 100644
index 000000000000..91f2f22d082a
--- /dev/null
+++ b/net-misc/curl/files/digest-curl-7.16.3
@@ -0,0 +1,3 @@
+MD5 ed55dfa8946ad53f245fae5db3a9d0ca curl-7.16.3.tar.bz2 1667847
+RMD160 49475fd0118e4ba9bd00244852d915bc56a2a2dd curl-7.16.3.tar.bz2 1667847
+SHA256 7dc1ff9b06686650669befd8884f3dab599de6795f24148c56d67b285211e494 curl-7.16.3.tar.bz2 1667847
diff --git a/net-misc/curl/files/digest-curl-7.16.3_pre20070418 b/net-misc/curl/files/digest-curl-7.16.3_pre20070418
deleted file mode 100644
index ce47406bde47..000000000000
--- a/net-misc/curl/files/digest-curl-7.16.3_pre20070418
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 cc759ca0b631fb2f4b55cb20ab78dc56 curl-7.16.3-20070418.tar.bz2 1710368
-RMD160 323553de20da5abb66f146dde10fb7f5e0933607 curl-7.16.3-20070418.tar.bz2 1710368
-SHA256 6e1a99e906c8560ffd9150ba8d23cee480a67f254c178846100f27a09fbcf85b curl-7.16.3-20070418.tar.bz2 1710368
diff --git a/net-misc/curl/files/digest-curl-7.16.3_pre20070610 b/net-misc/curl/files/digest-curl-7.16.3_pre20070610
deleted file mode 100644
index 8cde3f7ff599..000000000000
--- a/net-misc/curl/files/digest-curl-7.16.3_pre20070610
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 63b4b36bf46b20f165b0718021e088b6 curl-7.16.3-20070610.tar.bz2 1713832
-RMD160 5111cf10b095ff5195f3ec505b28613d864ae8c6 curl-7.16.3-20070610.tar.bz2 1713832
-SHA256 075862b2811671bafaaa13f55f24432da8a905468c9e7ac13c389702e24e3da4 curl-7.16.3-20070610.tar.bz2 1713832