summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Piasek <dagger@gentoo.org>2010-08-20 08:07:57 +0000
committerRobert Piasek <dagger@gentoo.org>2010-08-20 08:07:57 +0000
commitf2f51ec3f5bc4e45da4c15fd2954fb5bb9184e4e (patch)
tree198c383f9094b82fbee3f875f5110aa1a62d0502 /net-misc/connman
parentstable x86, bug 333087 (diff)
downloadgentoo-2-f2f51ec3f5bc4e45da4c15fd2954fb5bb9184e4e.tar.gz
gentoo-2-f2f51ec3f5bc4e45da4c15fd2954fb5bb9184e4e.tar.bz2
gentoo-2-f2f51ec3f5bc4e45da4c15fd2954fb5bb9184e4e.zip
Added patch to fix compilation with iptables 1.4.9
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/connman')
-rw-r--r--net-misc/connman/ChangeLog8
-rw-r--r--net-misc/connman/connman-0.57-r1.ebuild (renamed from net-misc/connman/connman-0.57.ebuild)6
-rw-r--r--net-misc/connman/files/connman-0.57-fix-iptables-test.patch36
3 files changed, 48 insertions, 2 deletions
diff --git a/net-misc/connman/ChangeLog b/net-misc/connman/ChangeLog
index ba7b2fec6ec0..f9e01f0d57ba 100644
--- a/net-misc/connman/ChangeLog
+++ b/net-misc/connman/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/connman
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.16 2010/08/16 12:42:55 dagger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.17 2010/08/20 08:07:53 dagger Exp $
+
+*connman-0.57-r1 (20 Aug 2010)
+
+ 20 Aug 2010; Robert Piasek <dagger@gentoo.org> -connman-0.57.ebuild,
+ +connman-0.57-r1.ebuild, +files/connman-0.57-fix-iptables-test.patch:
+ This patch fixes test/iptables to compile with iptables 1.4.9 and newer
*connman-0.57 (16 Aug 2010)
diff --git a/net-misc/connman/connman-0.57.ebuild b/net-misc/connman/connman-0.57-r1.ebuild
index 4f86d951ba36..5b2cd9db42f7 100644
--- a/net-misc/connman/connman-0.57.ebuild
+++ b/net-misc/connman/connman-0.57-r1.ebuild
@@ -4,7 +4,7 @@
EAPI="2"
-inherit multilib
+inherit multilib eutils
DESCRIPTION="Provides a daemon for managing internet connections"
HOMEPAGE="http://connman.net"
@@ -31,6 +31,10 @@ RDEPEND=">=dev-libs/glib-2.16
DEPEND="${RDEPEND}
doc? ( dev-util/gtk-doc )"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix-iptables-test.patch"
+}
+
src_configure() {
econf \
--localstatedir=/var \
diff --git a/net-misc/connman/files/connman-0.57-fix-iptables-test.patch b/net-misc/connman/files/connman-0.57-fix-iptables-test.patch
new file mode 100644
index 000000000000..b3dd5d32f389
--- /dev/null
+++ b/net-misc/connman/files/connman-0.57-fix-iptables-test.patch
@@ -0,0 +1,36 @@
+From f9745d978e6797c4576b52f602325db02dc48403 Mon Sep 17 00:00:00 2001
+From: Robert Piasek <dagger@gentoo.org>
+Date: Thu, 19 Aug 2010 16:33:59 +0100
+Subject: [PATCH] fix iptables-test to work with iptables 1.4.9
+
+Starting with version 1.4.9 iptables dropped xtables_set_revision
+function. This patch removes any use of it.
+---
+ tools/iptables-test.c | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tools/iptables-test.c b/tools/iptables-test.c
+index 1f3235c..b97c520 100644
+--- a/tools/iptables-test.c
++++ b/tools/iptables-test.c
+@@ -110,7 +110,7 @@ static struct ipt_entry *build_quota_drop_entry(void)
+ return NULL;
+ m->m->u.match_size = match_size;
+ strcpy(m->m->u.user.name, m->name);
+- xtables_set_revision(m->m->u.user.name, m->revision);
++ m->m->u.user.revision = m->revision;
+ if (m->init != NULL)
+ m->init(m->m);
+
+@@ -125,7 +125,7 @@ static struct ipt_entry *build_quota_drop_entry(void)
+ t->t = xtables_calloc(1, target_size);
+ t->t->u.target_size = target_size;
+ strcpy(t->t->u.user.name, "DROP");
+- xtables_set_revision(t->t->u.user.name, t->revision);
++ t->t->u.user.revision = t->revision;
+ if (t->init != NULL)
+ t->init(t->t);
+
+--
+1.7.2
+