summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2014-02-15 08:51:09 +0000
committerWolfram Schlich <wschlich@gentoo.org>2014-02-15 08:51:09 +0000
commit76b69d2fd890175ba4c6b84498a1c12c649f4dd6 (patch)
tree9bedc61c4d45c671dc7232b7d363ad32305f93a2 /net-misc/connect
parentamd64 stable, bug #498186 (diff)
downloadgentoo-2-76b69d2fd890175ba4c6b84498a1c12c649f4dd6.tar.gz
gentoo-2-76b69d2fd890175ba4c6b84498a1c12c649f4dd6.tar.bz2
gentoo-2-76b69d2fd890175ba4c6b84498a1c12c649f4dd6.zip
version bump, re-added version 100 as 1.100 according to upstream versioning schema
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-misc/connect')
-rw-r--r--net-misc/connect/ChangeLog13
-rw-r--r--net-misc/connect/connect-1.100.ebuild34
-rw-r--r--net-misc/connect/connect-1.103.ebuild35
3 files changed, 79 insertions, 3 deletions
diff --git a/net-misc/connect/ChangeLog b/net-misc/connect/ChangeLog
index 1dc1a619e216..2e5b9f72b760 100644
--- a/net-misc/connect/ChangeLog
+++ b/net-misc/connect/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/connect
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/connect/ChangeLog,v 1.10 2012/10/08 11:08:10 nativemad Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connect/ChangeLog,v 1.11 2014/02/15 08:51:09 wschlich Exp $
+
+*connect-1.100 (15 Feb 2014)
+*connect-1.103 (15 Feb 2014)
+
+ 15 Feb 2014; Wolfram Schlich <wschlich@gentoo.org> +connect-1.100.ebuild,
+ +connect-1.103.ebuild:
+ version bump, re-added version 100 as 1.100 according to upstream versioning
+ schema
08 Oct 2012; Andreas Schuerch <nativemad@gentoo.org> connect-100.ebuild:
x86 stable, see bug 384471
@@ -39,4 +47,3 @@
19 Sep 2005; Wolfram Schlich <wschlich@gentoo.org> +metadata.xml,
+connect-1.95.ebuild:
initial import
-
diff --git a/net-misc/connect/connect-1.100.ebuild b/net-misc/connect/connect-1.100.ebuild
new file mode 100644
index 000000000000..0134e626131d
--- /dev/null
+++ b/net-misc/connect/connect-1.100.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connect/connect-1.100.ebuild,v 1.1 2014/02/15 08:51:09 wschlich Exp $
+
+inherit toolchain-funcs
+
+IUSE=""
+DESCRIPTION="network connection relaying command"
+HOMEPAGE="http://www.meadowy.org/~gotoh/projects/connect/"
+SRC_URI="http://www.meadowy.org/~gotoh/ssh/${PN}-r${PV#1.}.c"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND=""
+RDEPEND=""
+S=${WORKDIR}
+
+src_unpack() {
+ cp "${DISTDIR}/${A}" "${S}/"
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${PN}-r${PV#1.}.c || die "compiler failed"
+}
+
+src_install() {
+ dobin ${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "There is no manpage, please see ${HOMEPAGE} for details"
+ einfo
+}
diff --git a/net-misc/connect/connect-1.103.ebuild b/net-misc/connect/connect-1.103.ebuild
new file mode 100644
index 000000000000..917a91ba964c
--- /dev/null
+++ b/net-misc/connect/connect-1.103.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connect/connect-1.103.ebuild,v 1.1 2014/02/15 08:51:09 wschlich Exp $
+
+EAPI=3
+
+inherit toolchain-funcs
+
+IUSE=""
+DESCRIPTION="network connection relaying command (proxy)"
+HOMEPAGE="https://bitbucket.org/gotoh/connect"
+HG_COMMIT_ID="ee1fbc21da4b" # bitbucket commit id
+#SRC_URI="mirror://bitbucket/gotoh/connect/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI="http://bitbucket.org/gotoh/connect/get/${HG_COMMIT_ID}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND=""
+RDEPEND=""
+S="${WORKDIR}/gotoh-connect-${HG_COMMIT_ID}"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c || die "compilation failed"
+}
+
+src_install() {
+ dobin ${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "There is no manpage."
+ einfo "Please see https://bitbucket.org/gotoh/connect/wiki/Home for details."
+ einfo
+}