summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-06-23 16:15:27 +0000
committerMichael Weber <xmw@gentoo.org>2013-06-23 16:15:27 +0000
commit2315bb13429998e52df0757c4329a4f91122bab9 (patch)
tree46b06d9ff01c8e68f78e2a2db3b758b702bf5fb5 /net-misc/clipgrab/clipgrab-3.2.1.0.ebuild
parentUse virtualx for the test suite. (diff)
downloadgentoo-2-2315bb13429998e52df0757c4329a4f91122bab9.tar.gz
gentoo-2-2315bb13429998e52df0757c4329a4f91122bab9.tar.bz2
gentoo-2-2315bb13429998e52df0757c4329a4f91122bab9.zip
Version bump, revert to media-libs/ffmpeg (bug 474368 by Nikoli), drop old.
(Portage version: 2.2.0_alpha183/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'net-misc/clipgrab/clipgrab-3.2.1.0.ebuild')
-rw-r--r--net-misc/clipgrab/clipgrab-3.2.1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/clipgrab/clipgrab-3.2.1.0.ebuild b/net-misc/clipgrab/clipgrab-3.2.1.0.ebuild
new file mode 100644
index 000000000000..db926be20c00
--- /dev/null
+++ b/net-misc/clipgrab/clipgrab-3.2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/clipgrab/clipgrab-3.2.1.0.ebuild,v 1.1 2013/06/23 16:15:27 xmw Exp $
+
+EAPI=5
+
+inherit qt4-r2 eutils
+
+DESCRIPTION="Download from various internet video services like Youtube etc."
+HOMEPAGE="http://clipgrab.de/en"
+SRC_URI="http://${PN}.de/download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtwebkit:4"
+# does not work with libav #474368
+RDEPEND="${DEPEND}
+ media-video/ffmpeg"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.2.1.0-obey.patch"
+)
+
+src_install() {
+ dobin ${PN}
+
+ newicon icon.png ${PN}.png
+ make_desktop_entry clipgrab Clipgrab "" "Qt;Video;AudioVideo;"
+}