summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-03-26 13:21:04 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-03-26 13:21:04 +0000
commit5ded034544a5086c9006a9b93844ccb25be578cf (patch)
tree26e8d43e904c81c63ca089af13f7ec6414525907 /net-misc/asterisk-app_rtxfax
parent1.0 final. (diff)
downloadgentoo-2-5ded034544a5086c9006a9b93844ccb25be578cf.tar.gz
gentoo-2-5ded034544a5086c9006a9b93844ccb25be578cf.tar.bz2
gentoo-2-5ded034544a5086c9006a9b93844ccb25be578cf.zip
Initial import
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-misc/asterisk-app_rtxfax')
-rw-r--r--net-misc/asterisk-app_rtxfax/ChangeLog11
-rw-r--r--net-misc/asterisk-app_rtxfax/asterisk-app_rtxfax-0.0.2_pre10.ebuild40
-rw-r--r--net-misc/asterisk-app_rtxfax/files/app_rtxfax-0.0.2_pre10-astcfg.diff35
-rw-r--r--net-misc/asterisk-app_rtxfax/files/digest-asterisk-app_rtxfax-0.0.2_pre101
-rw-r--r--net-misc/asterisk-app_rtxfax/metadata.xml8
5 files changed, 95 insertions, 0 deletions
diff --git a/net-misc/asterisk-app_rtxfax/ChangeLog b/net-misc/asterisk-app_rtxfax/ChangeLog
new file mode 100644
index 000000000000..fea371a6b6cb
--- /dev/null
+++ b/net-misc/asterisk-app_rtxfax/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/asterisk-app_rtxfax
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-app_rtxfax/ChangeLog,v 1.1 2005/03/26 13:21:04 stkn Exp $
+
+*asterisk-app_rtxfax-0.0.2_pre10 (26 Mar 2005)
+
+ 26 Mar 2005; Stefan Knoblich <stkn@gentoo.org> +metadata.xml,
+ +files/app_rtxfax-0.0.2_pre10-astcfg.diff,
+ +asterisk-app_rtxfax-0.0.2_pre10.ebuild:
+ Initial import.
+
diff --git a/net-misc/asterisk-app_rtxfax/asterisk-app_rtxfax-0.0.2_pre10.ebuild b/net-misc/asterisk-app_rtxfax/asterisk-app_rtxfax-0.0.2_pre10.ebuild
new file mode 100644
index 000000000000..d32d5026fa6c
--- /dev/null
+++ b/net-misc/asterisk-app_rtxfax/asterisk-app_rtxfax-0.0.2_pre10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-app_rtxfax/asterisk-app_rtxfax-0.0.2_pre10.ebuild,v 1.1 2005/03/26 13:21:04 stkn Exp $
+
+IUSE=""
+
+inherit eutils
+
+MY_PN="app_rtxfax"
+
+DESCRIPTION="Asterisk applications for sending and receiving faxes"
+HOMEPAGE="http://www.opencall.org/"
+SRC_URI="mirror://gentoo/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=media-libs/spandsp-0.0.2_pre10
+ >=net-misc/asterisk-1.0.5-r1"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # use asterisk-config...
+ epatch ${FILESDIR}/${MY_PN}-${PV}-astcfg.diff
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc README
+}
diff --git a/net-misc/asterisk-app_rtxfax/files/app_rtxfax-0.0.2_pre10-astcfg.diff b/net-misc/asterisk-app_rtxfax/files/app_rtxfax-0.0.2_pre10-astcfg.diff
new file mode 100644
index 000000000000..afd378158f3b
--- /dev/null
+++ b/net-misc/asterisk-app_rtxfax/files/app_rtxfax-0.0.2_pre10-astcfg.diff
@@ -0,0 +1,35 @@
+--- Makefile.orig 1970-01-01 00:00:00.000000000 +0000
++++ Makefile 2005-01-26 20:30:27.009331696 +0000
+@@ -0,0 +1,32 @@
++
++CC=gcc
++CFLAGS=$(shell /usr/bin/asterisk-config --cflags)
++CFLAGS+=-fPIC -I/usr/include/spandsp
++SOLINK=$(shell /usr/bin/asterisk-config --solink)
++LIBS=-lspandsp -ltiff
++
++ASTMODDIR=$(shell /usr/bin/asterisk-config --modulesdir)
++ASTETCDIR=$(shell /usr/bin/asterisk-config --sysconfdir)
++
++all: .depend app_rxfax.so app_txfax.so
++
++.depend:
++ @if [ ! -x /usr/bin/asterisk-config ]; then \
++ echo "/usr/bin/asterisk-config not found!"; \
++ exit 255; \
++ fi
++
++.c.o:
++ $(CC) -c $(CFLAGS) -o $@ $<
++
++app_rxfax.so: app_rxfax.o
++ $(CC) $(SOLINK) -o $@ $< $(LIBS)
++
++app_txfax.so: app_txfax.o
++ $(CC) $(SOLINK) -o $@ $< $(LIBS)
++
++install:
++ if [ ! -d $(DESTDIR)$(ASTMODDIR) ]; then mkdir -p $(DESTDIR)$(ASTMODDIR); fi
++ install -m755 app_rxfax.so $(DESTDIR)$(ASTMODDIR)
++ install -m755 app_txfax.so $(DESTDIR)$(ASTMODDIR)
++
diff --git a/net-misc/asterisk-app_rtxfax/files/digest-asterisk-app_rtxfax-0.0.2_pre10 b/net-misc/asterisk-app_rtxfax/files/digest-asterisk-app_rtxfax-0.0.2_pre10
new file mode 100644
index 000000000000..90c676e2d7ce
--- /dev/null
+++ b/net-misc/asterisk-app_rtxfax/files/digest-asterisk-app_rtxfax-0.0.2_pre10
@@ -0,0 +1 @@
+MD5 4db327686738aaae48b39b46ff732599 app_rtxfax-0.0.2_pre10.tar.bz2 5034
diff --git a/net-misc/asterisk-app_rtxfax/metadata.xml b/net-misc/asterisk-app_rtxfax/metadata.xml
new file mode 100644
index 000000000000..a3cddc42f9cc
--- /dev/null
+++ b/net-misc/asterisk-app_rtxfax/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>voip</herd>
+<maintainer>
+ <email>stkn@gentoo.org</email>
+</maintainer>
+</pkgmetadata>