summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-05-31 08:31:54 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-05-31 08:31:54 +0000
commit2a384e2408e713cb6e4c14e801eeccb2aa2c1c21 (patch)
tree3151b4d5413f89e849b0b35e5d8ab946a35402ff /net-misc/aria2
parentVersion bump (bug #224201, #212955). Punted old versions (mips stable keyword... (diff)
downloadgentoo-2-2a384e2408e713cb6e4c14e801eeccb2aa2c1c21.tar.gz
gentoo-2-2a384e2408e713cb6e4c14e801eeccb2aa2c1c21.tar.bz2
gentoo-2-2a384e2408e713cb6e4c14e801eeccb2aa2c1c21.zip
Version bump.
(Portage version: 2.1.5_rc7)
Diffstat (limited to 'net-misc/aria2')
-rw-r--r--net-misc/aria2/ChangeLog8
-rw-r--r--net-misc/aria2/aria2-0.13.2_p1.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/net-misc/aria2/ChangeLog b/net-misc/aria2/ChangeLog
index 267b522225dc..8911dfdef03e 100644
--- a/net-misc/aria2/ChangeLog
+++ b/net-misc/aria2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/aria2
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/ChangeLog,v 1.24 2008/05/19 11:35:25 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/ChangeLog,v 1.25 2008/05/31 08:31:54 dev-zero Exp $
+
+*aria2-0.13.2_p1 (31 May 2008)
+
+ 31 May 2008; Tiziano Müller <dev-zero@gentoo.org>
+ +aria2-0.13.2_p1.ebuild:
+ Version bump.
*aria2-0.13.1_p2 (19 May 2008)
diff --git a/net-misc/aria2/aria2-0.13.2_p1.ebuild b/net-misc/aria2/aria2-0.13.2_p1.ebuild
new file mode 100644
index 000000000000..208bceed8aa5
--- /dev/null
+++ b/net-misc/aria2/aria2-0.13.2_p1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/aria2-0.13.2_p1.ebuild,v 1.1 2008/05/31 08:31:54 dev-zero Exp $
+
+MY_P="aria2c-${PV/_p/+}"
+
+DESCRIPTION="A download utility with resuming and segmented downloading with HTTP/HTTPS/FTP/BitTorrent support."
+HOMEPAGE="http://aria2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="ares bittorrent expat gnutls metalink nls ssl test"
+
+# Broken (once more)
+RESTRICT="test"
+
+CDEPEND="ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl ) )
+ ares? ( >=net-dns/c-ares-1.3.1 )
+ bittorrent? ( gnutls? ( dev-libs/libgcrypt ) )
+ metalink? (
+ !expat? ( >=dev-libs/libxml2-2.6.26 )
+ expat? ( dev-libs/expat )
+ )"
+DEPEND="${CDEPEND}
+ nls? ( sys-devel/gettext )
+ test? ( >=dev-util/cppunit-1.12.0 )"
+RDEPEND="${CDEPEND}
+ nls? ( virtual/libiconv virtual/libintl )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ use ssl && \
+ myconf="${myconf} $(use_with gnutls) $(use_with !gnutls openssl)"
+
+ # Note:
+ # - we don't have ares, only libcares
+ # - depends on libgcrypt only when using openssl
+ # - links only against libxml2 and libexpat when metalink is enabled
+ econf \
+ $(use_enable nls) \
+ $(use_enable metalink) \
+ $(use_with expat libexpat) \
+ $(use_with !expat libxml2) \
+ $(use_enable bittorrent) \
+ --without-ares \
+ $(use_with ares libcares) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README AUTHORS TODO NEWS
+}