summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2010-05-30 06:49:46 +0000
committerBenedikt Boehm <hollow@gentoo.org>2010-05-30 06:49:46 +0000
commitcd96614bac3b9978a7bde2c21b7273380bff7075 (patch)
tree3c59a0de5b781013f3582db251a098d6507c401b /net-mail
parentfix #320749 (diff)
downloadgentoo-2-cd96614bac3b9978a7bde2c21b7273380bff7075.tar.gz
gentoo-2-cd96614bac3b9978a7bde2c21b7273380bff7075.tar.bz2
gentoo-2-cd96614bac3b9978a7bde2c21b7273380bff7075.zip
5.4.30-r1 stable on amd64 wrt #285213; add support for spamassassin wrt #315643
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/vpopmail/ChangeLog11
-rw-r--r--net-mail/vpopmail/metadata.xml2
-rw-r--r--net-mail/vpopmail/vpopmail-5.4.19.ebuild218
-rw-r--r--net-mail/vpopmail/vpopmail-5.4.20.ebuild218
-rw-r--r--net-mail/vpopmail/vpopmail-5.4.25.ebuild218
-rw-r--r--net-mail/vpopmail/vpopmail-5.4.26.ebuild219
-rw-r--r--net-mail/vpopmail/vpopmail-5.4.30-r1.ebuild4
-rw-r--r--net-mail/vpopmail/vpopmail-5.4.30-r2.ebuild (renamed from net-mail/vpopmail/vpopmail-5.4.30.ebuild)36
8 files changed, 40 insertions, 886 deletions
diff --git a/net-mail/vpopmail/ChangeLog b/net-mail/vpopmail/ChangeLog
index a40a9c830572..85ad5b30b6a7 100644
--- a/net-mail/vpopmail/ChangeLog
+++ b/net-mail/vpopmail/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-mail/vpopmail
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/ChangeLog,v 1.94 2010/04/05 17:40:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/ChangeLog,v 1.95 2010/05/30 06:49:46 hollow Exp $
+
+*vpopmail-5.4.30-r2 (30 May 2010)
+
+ 30 May 2010; Benedikt Böhm <hollow@gentoo.org> -vpopmail-5.4.19.ebuild,
+ -vpopmail-5.4.20.ebuild, -vpopmail-5.4.25.ebuild, -vpopmail-5.4.26.ebuild,
+ -vpopmail-5.4.30.ebuild, vpopmail-5.4.30-r1.ebuild,
+ +vpopmail-5.4.30-r2.ebuild, metadata.xml:
+ 5.4.30-r1 stable on amd64 wrt #285213; add support for spamassassin wrt
+ #315643
05 Apr 2010; Raúl Porcel <armin76@gentoo.org> vpopmail-5.4.30-r1.ebuild:
arm/s390/sh/sparc stable wrt #285213
diff --git a/net-mail/vpopmail/metadata.xml b/net-mail/vpopmail/metadata.xml
index c9fbea4197d1..cec9a2f1418c 100644
--- a/net-mail/vpopmail/metadata.xml
+++ b/net-mail/vpopmail/metadata.xml
@@ -12,5 +12,7 @@
<flag name='ipalias'>Enables enable-ip-alias-domains</flag>
<flag name='maildrop'>Enables <pkg>mail-filter/maildrop</pkg> support
in vdelivermail</flag>
+ <flag name='spamassassin'>Enables <pkg>mail-filter/spamassassin</pkg>
+ support</flag>
</use>
</pkgmetadata>
diff --git a/net-mail/vpopmail/vpopmail-5.4.19.ebuild b/net-mail/vpopmail/vpopmail-5.4.19.ebuild
deleted file mode 100644
index 70dab6bdcb16..000000000000
--- a/net-mail/vpopmail/vpopmail-5.4.19.ebuild
+++ /dev/null
@@ -1,218 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.19.ebuild,v 1.2 2007/09/16 08:16:28 hollow Exp $
-
-inherit eutils fixheadtails autotools
-
-HOMEPAGE="http://www.inter7.com/index.php?page=vpopmail"
-DESCRIPTION="A collection of programs to manage virtual email domains and accounts on your Qmail mail servers."
-SRC_URI="mirror://sourceforge/${PN}/${P}a.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sh ~sparc ~x86"
-IUSE="clearpasswd ipalias maildrop mysql"
-
-DEPEND="virtual/qmail
- maildrop? ( mail-filter/maildrop )
- mysql? ( virtual/mysql )
-"
-
-# This makes sure the variable is set, and that it isn't null.
-VPOP_DEFAULT_HOME="/var/vpopmail"
-
-# qmail home directory
-QMAIL_HOME="/var/qmail"
-
-vpopmail_set_homedir() {
- VPOP_HOME=$(getent passwd vpopmail | cut -d: -f6)
- if [[ -z "${VPOP_HOME}" ]]; then
- ebeep
- eerror "vpopmail's home directory is null in passwd data!"
- eerror "You probably want to check that out."
- eerror "Continuing with default."
- VPOP_HOME="${VPOP_DEFAULT_HOME}"
- else
- einfo "Setting VPOP_HOME to: $VPOP_HOME"
- fi
-}
-
-pkg_setup() {
- enewgroup vpopmail 89
- enewuser vpopmail 89 -1 ${VPOP_DEFAULT_HOME} vpopmail
- upgradewarning
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-5.4.9-access.violation.patch
- epatch "${FILESDIR}"/${PN}-lazy.patch
-
- # fix maildir paths
- sed -i -e 's|Maildir|.maildir|g' \
- vchkpw.c vconvert.c vdelivermail.c \
- vpopbull.c vpopmail.c vqmaillocal.c \
- vuserinfo.c maildirquota.c || die
-
- # remove vpopmail advertisement
- sed -i -e '/printf.*vpopmail/s:vpopmail (:(:' \
- vdelivermail.c vpopbull.c vqmaillocal.c || die
-
- eautoreconf
- ht_fix_file "${S}"/cdb/Makefile || die "failed to fix file"
-}
-
-src_compile() {
- vpopmail_set_homedir
-
- if use mysql; then
- authopts=" \
- --enable-auth-module=mysql \
- --enable-libs=/usr/include/mysql \
- --enable-libdir=/usr/lib/mysql \
- --enable-sql-logging \
- --enable-valias \
- --disable-mysql-replication \
- --enable-mysql-limits"
- else
- authopts="--enable-auth-module=cdb"
- fi
-
- econf ${authopts} \
- --sysconfdir=${VPOP_HOME}/etc \
- --enable-non-root-build \
- --enable-qmaildir=${QMAIL_HOME} \
- --enable-qmail-newu=${QMAIL_HOME}/bin/qmail-newu \
- --enable-qmail-inject=${QMAIL_HOME}/bin/qmail-inject \
- --enable-qmail-newmrh=${QMAIL_HOME}/bin/qmail-newmrh \
- --enable-vpopuser=vpopmail \
- --enable-vpopgroup=vpopmail \
- --enable-many-domains \
- --enable-file-locking \
- --enable-file-sync \
- --enable-md5-passwords \
- --enable-logging \
- --enable-auth-logging \
- --enable-log-name=vpopmail \
- --enable-qmail-ext \
- --disable-tcp-rules-prog \
- --disable-tcpserver-file \
- --disable-roaming-users \
- $(use_enable ipalias ip-alias-domains) \
- $(use_enable clearpasswd clear-passwd) \
- $(use_enable maildrop) \
- || die "configure failed"
-
- emake || die "make failed"
-}
-
-src_install() {
- vpopmail_set_homedir
-
- make DESTDIR="${D}" install || die "make install failed"
- keepdir "${VPOP_HOME}"/domains
-
- # install helper script for maildir conversion
- into /var/vpopmail
- dobin "${FILESDIR}"/vpopmail-Maildir-dotmaildir-fix.sh
- into /usr
-
- # install documentation
- dodoc AUTHORS ChangeLog FAQ INSTALL README*
- dohtml doc/doc_html/* doc/man_html/*
- rm -rf "${D}"/"${VPOP_HOME}"/doc
- dosym /usr/share/doc/${PF}/ "${VPOP_HOME}"/doc
-
- # create /etc/vpopmail.conf
- if use mysql; then
- einfo "Installing vpopmail mysql configuration file"
- dodir /etc
- # config file position
- mv "${D}"/var/vpopmail/etc/vpopmail.mysql "${D}"/etc/vpopmail.conf
- dosym /etc/vpopmail.conf /var/vpopmail/etc/vpopmail.mysql
- sed -e '12d' -i "${D}"/etc/vpopmail.conf
- echo '# Read-only DB' >> "${D}"/etc/vpopmail.conf
- echo 'localhost|0|vpopmail|secret|vpopmail' >> "${D}"/etc/vpopmail.conf
- echo '# Write DB' >>${D}/etc/vpopmail.conf
- echo 'localhost|0|vpopmail|secret|vpopmail' >> "${D}"/etc/vpopmail.conf
- # lock down perms
- fperms 640 /etc/vpopmail.conf
- fowners root:vpopmail /etc/vpopmail.conf
- fi
-
- einfo "Installing env.d entry"
- dodir /etc/env.d
- doenvd "${FILESDIR}"/99vpopmail
-
- einfo "Locking down vpopmail permissions"
- fowners root:0 -R "${VPOP_HOME}"/{bin,etc,include}
- fowners root:vpopmail "${VPOP_HOME}"/bin/vchkpw
- fperms 4711 "${VPOP_HOME}"/bin/vchkpw
-}
-
-pkg_postinst() {
- einfo "Performing post-installation routines for ${P}"
-
- if use mysql ; then
- elog
- elog "You have 'mysql' turned on in your USE"
- elog "Vpopmail needs a VALID MySQL USER. Let's call it 'vpopmail'"
- elog "You MUST add it and then specify its passwd in the /etc/vpopmail.conf file"
- elog
- elog "First log into mysql as your mysql root user and pass. Then:"
- elog "> create database vpopmail;"
- elog "> use mysql;"
- elog "> grant select, insert, update, delete, create, drop on vpopmail.* to"
- elog " vpopmail@localhost identified by 'your password';"
- elog "> flush privileges;"
- elog
- elog "If you have problems with vpopmail not accepting mail properly,"
- elog "please ensure that /etc/vpopmail.conf is chmod 640 and"
- elog "owned by root:vpopmail"
- fi
-
- # do this for good measure
- if [ -e /etc/vpopmail.conf ] ; then
- chmod 640 /etc/vpopmail.conf
- chown root:vpopmail /etc/vpopmail.conf
- fi
-
- upgradewarning
-}
-
-pkg_postrm() {
- vpopmail_set_homedir
-
- elog "The vpopmail DATA will NOT be removed automatically."
- elog "You can delete them manually by removing the ${VPOP_HOME} directory."
-}
-
-upgradewarning() {
- ewarn "Massive important warning if you are upgrading to 5.2.1-r8 or older"
- ewarn "The internal structure of the mail storage has changed for"
- ewarn "consistancy with the rest of Gentoo! Please review and utilize the "
- ewarn "script at /var/vpopmail/bin/vpopmail-Maildir-dotmaildir-fix.sh"
- ewarn "to upgrade your system! (It can do conversions both ways)."
- ewarn "You should be able to run it right away without any changes."
- elog
- elog "Use of vpopmail's tcp.smtp[.cdb] is also deprecated now, consider"
- elog "using net-mail/relay-ctrl instead."
-
- if use mysql; then
- elog
- elog "If you are upgrading from 5.4.17 or older, you have to fix your"
- elog "MySQL tables:"
- elog
- elog 'ALTER TABLE `dir_control` CHANGE `domain` `domain` CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `ip_alias_map` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `lastauth` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `valias` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `vlog` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `vpopmail` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `limits` CHANGE domain domain CHAR(96) NOT NULL,'
- elog ' ADD `disable_spamassassin` TINYINT(1) DEFAULT '0' NOT NULL AFTER `disable_smtp`,'
- elog ' ADD `delete_spam` TINYINT(1) DEFAULT '0' NOT NULL AFTER `disable_spamassassin`;'
- fi
-}
diff --git a/net-mail/vpopmail/vpopmail-5.4.20.ebuild b/net-mail/vpopmail/vpopmail-5.4.20.ebuild
deleted file mode 100644
index 931acdf6cec3..000000000000
--- a/net-mail/vpopmail/vpopmail-5.4.20.ebuild
+++ /dev/null
@@ -1,218 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.20.ebuild,v 1.1 2007/09/16 08:16:28 hollow Exp $
-
-inherit eutils fixheadtails autotools
-
-HOMEPAGE="http://www.inter7.com/index.php?page=vpopmail"
-DESCRIPTION="A collection of programs to manage virtual email domains and accounts on your Qmail mail servers."
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sh ~sparc ~x86"
-IUSE="clearpasswd ipalias maildrop mysql"
-
-DEPEND="virtual/qmail
- maildrop? ( mail-filter/maildrop )
- mysql? ( virtual/mysql )
-"
-
-# This makes sure the variable is set, and that it isn't null.
-VPOP_DEFAULT_HOME="/var/vpopmail"
-
-# qmail home directory
-QMAIL_HOME="/var/qmail"
-
-vpopmail_set_homedir() {
- VPOP_HOME=$(getent passwd vpopmail | cut -d: -f6)
- if [[ -z "${VPOP_HOME}" ]]; then
- ebeep
- eerror "vpopmail's home directory is null in passwd data!"
- eerror "You probably want to check that out."
- eerror "Continuing with default."
- VPOP_HOME="${VPOP_DEFAULT_HOME}"
- else
- einfo "Setting VPOP_HOME to: $VPOP_HOME"
- fi
-}
-
-pkg_setup() {
- enewgroup vpopmail 89
- enewuser vpopmail 89 -1 ${VPOP_DEFAULT_HOME} vpopmail
- upgradewarning
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-5.4.9-access.violation.patch
- epatch "${FILESDIR}"/${PN}-lazy.patch
-
- # fix maildir paths
- sed -i -e 's|Maildir|.maildir|g' \
- vchkpw.c vconvert.c vdelivermail.c \
- vpopbull.c vpopmail.c vqmaillocal.c \
- vuserinfo.c maildirquota.c || die
-
- # remove vpopmail advertisement
- sed -i -e '/printf.*vpopmail/s:vpopmail (:(:' \
- vdelivermail.c vpopbull.c vqmaillocal.c || die
-
- eautoreconf
- ht_fix_file "${S}"/cdb/Makefile || die "failed to fix file"
-}
-
-src_compile() {
- vpopmail_set_homedir
-
- if use mysql; then
- authopts=" \
- --enable-auth-module=mysql \
- --enable-libs=/usr/include/mysql \
- --enable-libdir=/usr/lib/mysql \
- --enable-sql-logging \
- --enable-valias \
- --disable-mysql-replication \
- --enable-mysql-limits"
- else
- authopts="--enable-auth-module=cdb"
- fi
-
- econf ${authopts} \
- --sysconfdir=${VPOP_HOME}/etc \
- --enable-non-root-build \
- --enable-qmaildir=${QMAIL_HOME} \
- --enable-qmail-newu=${QMAIL_HOME}/bin/qmail-newu \
- --enable-qmail-inject=${QMAIL_HOME}/bin/qmail-inject \
- --enable-qmail-newmrh=${QMAIL_HOME}/bin/qmail-newmrh \
- --enable-vpopuser=vpopmail \
- --enable-vpopgroup=vpopmail \
- --enable-many-domains \
- --enable-file-locking \
- --enable-file-sync \
- --enable-md5-passwords \
- --enable-logging \
- --enable-auth-logging \
- --enable-log-name=vpopmail \
- --enable-qmail-ext \
- --disable-tcp-rules-prog \
- --disable-tcpserver-file \
- --disable-roaming-users \
- $(use_enable ipalias ip-alias-domains) \
- $(use_enable clearpasswd clear-passwd) \
- $(use_enable maildrop) \
- || die "configure failed"
-
- emake || die "make failed"
-}
-
-src_install() {
- vpopmail_set_homedir
-
- make DESTDIR="${D}" install || die "make install failed"
- keepdir "${VPOP_HOME}"/domains
-
- # install helper script for maildir conversion
- into /var/vpopmail
- dobin "${FILESDIR}"/vpopmail-Maildir-dotmaildir-fix.sh
- into /usr
-
- # install documentation
- dodoc AUTHORS ChangeLog FAQ INSTALL README*
- dohtml doc/doc_html/* doc/man_html/*
- rm -rf "${D}"/"${VPOP_HOME}"/doc
- dosym /usr/share/doc/${PF}/ "${VPOP_HOME}"/doc
-
- # create /etc/vpopmail.conf
- if use mysql; then
- einfo "Installing vpopmail mysql configuration file"
- dodir /etc
- # config file position
- mv "${D}"/var/vpopmail/etc/vpopmail.mysql "${D}"/etc/vpopmail.conf
- dosym /etc/vpopmail.conf /var/vpopmail/etc/vpopmail.mysql
- sed -e '12d' -i "${D}"/etc/vpopmail.conf
- echo '# Read-only DB' >> "${D}"/etc/vpopmail.conf
- echo 'localhost|0|vpopmail|secret|vpopmail' >> "${D}"/etc/vpopmail.conf
- echo '# Write DB' >>${D}/etc/vpopmail.conf
- echo 'localhost|0|vpopmail|secret|vpopmail' >> "${D}"/etc/vpopmail.conf
- # lock down perms
- fperms 640 /etc/vpopmail.conf
- fowners root:vpopmail /etc/vpopmail.conf
- fi
-
- einfo "Installing env.d entry"
- dodir /etc/env.d
- doenvd "${FILESDIR}"/99vpopmail
-
- einfo "Locking down vpopmail permissions"
- fowners root:0 -R "${VPOP_HOME}"/{bin,etc,include}
- fowners root:vpopmail "${VPOP_HOME}"/bin/vchkpw
- fperms 4711 "${VPOP_HOME}"/bin/vchkpw
-}
-
-pkg_postinst() {
- einfo "Performing post-installation routines for ${P}"
-
- if use mysql ; then
- elog
- elog "You have 'mysql' turned on in your USE"
- elog "Vpopmail needs a VALID MySQL USER. Let's call it 'vpopmail'"
- elog "You MUST add it and then specify its passwd in the /etc/vpopmail.conf file"
- elog
- elog "First log into mysql as your mysql root user and pass. Then:"
- elog "> create database vpopmail;"
- elog "> use mysql;"
- elog "> grant select, insert, update, delete, create, drop on vpopmail.* to"
- elog " vpopmail@localhost identified by 'your password';"
- elog "> flush privileges;"
- elog
- elog "If you have problems with vpopmail not accepting mail properly,"
- elog "please ensure that /etc/vpopmail.conf is chmod 640 and"
- elog "owned by root:vpopmail"
- fi
-
- # do this for good measure
- if [ -e /etc/vpopmail.conf ] ; then
- chmod 640 /etc/vpopmail.conf
- chown root:vpopmail /etc/vpopmail.conf
- fi
-
- upgradewarning
-}
-
-pkg_postrm() {
- vpopmail_set_homedir
-
- elog "The vpopmail DATA will NOT be removed automatically."
- elog "You can delete them manually by removing the ${VPOP_HOME} directory."
-}
-
-upgradewarning() {
- ewarn "Massive important warning if you are upgrading to 5.2.1-r8 or older"
- ewarn "The internal structure of the mail storage has changed for"
- ewarn "consistancy with the rest of Gentoo! Please review and utilize the "
- ewarn "script at /var/vpopmail/bin/vpopmail-Maildir-dotmaildir-fix.sh"
- ewarn "to upgrade your system! (It can do conversions both ways)."
- ewarn "You should be able to run it right away without any changes."
- elog
- elog "Use of vpopmail's tcp.smtp[.cdb] is also deprecated now, consider"
- elog "using net-mail/relay-ctrl instead."
-
- if use mysql; then
- elog
- elog "If you are upgrading from 5.4.17 or older, you have to fix your"
- elog "MySQL tables:"
- elog
- elog 'ALTER TABLE `dir_control` CHANGE `domain` `domain` CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `ip_alias_map` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `lastauth` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `valias` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `vlog` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `vpopmail` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `limits` CHANGE domain domain CHAR(96) NOT NULL,'
- elog ' ADD `disable_spamassassin` TINYINT(1) DEFAULT '0' NOT NULL AFTER `disable_smtp`,'
- elog ' ADD `delete_spam` TINYINT(1) DEFAULT '0' NOT NULL AFTER `disable_spamassassin`;'
- fi
-}
diff --git a/net-mail/vpopmail/vpopmail-5.4.25.ebuild b/net-mail/vpopmail/vpopmail-5.4.25.ebuild
deleted file mode 100644
index 3c9a043ba6ab..000000000000
--- a/net-mail/vpopmail/vpopmail-5.4.25.ebuild
+++ /dev/null
@@ -1,218 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.25.ebuild,v 1.1 2008/04/06 17:37:38 hollow Exp $
-
-inherit autotools eutils fixheadtails qmail
-
-HOMEPAGE="http://www.inter7.com/index.php?page=vpopmail"
-DESCRIPTION="A collection of programs to manage virtual email domains and accounts on your Qmail mail servers."
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sh ~sparc ~x86"
-IUSE="clearpasswd ipalias maildrop mysql"
-
-DEPEND="virtual/qmail
- maildrop? ( mail-filter/maildrop )
- mysql? ( virtual/mysql )
-"
-
-# This makes sure the variable is set, and that it isn't null.
-VPOP_DEFAULT_HOME="/var/vpopmail"
-
-vpopmail_set_homedir() {
- VPOP_HOME=$(getent passwd vpopmail | cut -d: -f6)
- if [[ -z "${VPOP_HOME}" ]]; then
- ebeep
- eerror "vpopmail's home directory is null in passwd data!"
- eerror "You probably want to check that out."
- eerror "Continuing with default."
- VPOP_HOME="${VPOP_DEFAULT_HOME}"
- else
- einfo "Setting VPOP_HOME to: $VPOP_HOME"
- fi
-}
-
-pkg_setup() {
- enewgroup vpopmail 89
- enewuser vpopmail 89 -1 ${VPOP_DEFAULT_HOME} vpopmail
- upgradewarning
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-5.4.9-access.violation.patch
- epatch "${FILESDIR}"/${PN}-lazy.patch
-
- # fix maildir paths
- sed -i -e 's|Maildir|.maildir|g' \
- vchkpw.c vconvert.c vdelivermail.c \
- vpopbull.c vpopmail.c vqmaillocal.c \
- vuserinfo.c maildirquota.c || die
-
- # remove vpopmail advertisement
- sed -i -e '/printf.*vpopmail/s:vpopmail (:(:' \
- vdelivermail.c vpopbull.c vqmaillocal.c || die
-
- eautoreconf
- ht_fix_file cdb/Makefile
-}
-
-src_compile() {
- vpopmail_set_homedir
-
- if use mysql; then
- authopts=" \
- --enable-auth-module=mysql \
- --enable-libs=/usr/include/mysql \
- --enable-libdir=/usr/lib/mysql \
- --enable-sql-logging \
- --enable-valias \
- --disable-mysql-replication \
- --enable-mysql-limits"
- else
- authopts="--enable-auth-module=cdb"
- fi
-
- econf ${authopts} \
- --sysconfdir=${VPOP_HOME}/etc \
- --enable-non-root-build \
- --enable-qmaildir=${QMAIL_HOME} \
- --enable-qmail-newu=${QMAIL_HOME}/bin/qmail-newu \
- --enable-qmail-inject=${QMAIL_HOME}/bin/qmail-inject \
- --enable-qmail-newmrh=${QMAIL_HOME}/bin/qmail-newmrh \
- --enable-vpopuser=vpopmail \
- --enable-vpopgroup=vpopmail \
- --enable-many-domains \
- --enable-file-locking \
- --enable-file-sync \
- --enable-md5-passwords \
- --enable-logging \
- --enable-auth-logging \
- --enable-log-name=vpopmail \
- --enable-qmail-ext \
- --disable-tcp-rules-prog \
- --disable-tcpserver-file \
- --disable-roaming-users \
- $(use_enable ipalias ip-alias-domains) \
- $(use_enable clearpasswd clear-passwd) \
- $(use_enable maildrop) \
- || die "configure failed"
-
- emake || die "make failed"
-}
-
-src_install() {
- vpopmail_set_homedir
-
- make DESTDIR="${D}" install || die "make install failed"
- keepdir "${VPOP_HOME}"/domains
-
- # install helper script for maildir conversion
- into "${VPOP_HOME}"
- dobin "${FILESDIR}"/vpopmail-Maildir-dotmaildir-fix.sh
- into /usr
-
- dodoc AUTHORS ChangeLog FAQ INSTALL README*
- dohtml doc/doc_html/* doc/man_html/*
- rm -rf "${D}/${VPOP_HOME}"/doc
- dosym /usr/share/doc/${PF}/ "${VPOP_HOME}"/doc
-
- # create /etc/vpopmail.conf
- if use mysql; then
- dodir /etc
- mv "${D}${VPOP_HOME}"/etc/vpopmail.mysql "${D}"/etc/vpopmail.conf
- dosym /etc/vpopmail.conf "${VPOP_HOME}"/etc/vpopmail.mysql
-
- sed -e '12d' -i "${D}"/etc/vpopmail.conf
- echo '# Read-only DB' >> "${D}"/etc/vpopmail.conf
- echo 'localhost|0|vpopmail|secret|vpopmail' >> "${D}"/etc/vpopmail.conf
- echo '# Write DB' >> "${D}"/etc/vpopmail.conf
- echo 'localhost|0|vpopmail|secret|vpopmail' >> "${D}"/etc/vpopmail.conf
-
- # lock down perms
- fperms 640 /etc/vpopmail.conf
- fowners root:vpopmail /etc/vpopmail.conf
- fi
-
- einfo "Installing env.d entry"
- dodir /etc/env.d
- doenvd "${FILESDIR}"/99vpopmail
-
- einfo "Locking down vpopmail permissions"
- fowners root:0 -R "${VPOP_HOME}"/{bin,etc,include}
- fowners root:vpopmail "${VPOP_HOME}"/bin/vchkpw
- fperms 4711 "${VPOP_HOME}"/bin/vchkpw
-}
-
-pkg_postinst() {
- if use mysql ; then
- elog
- elog "You have 'mysql' turned on in your USE"
- elog "Vpopmail needs a VALID MySQL USER. Let's call it 'vpopmail'"
- elog "You MUST add it and then specify its passwd in the /etc/vpopmail.conf file"
- elog
- elog "First log into mysql as your mysql root user and pass. Then:"
- elog "> create database vpopmail;"
- elog "> use mysql;"
- elog "> grant select, insert, update, delete, create, drop on vpopmail.* to"
- elog " vpopmail@localhost identified by 'your password';"
- elog "> flush privileges;"
- elog
- elog "If you have problems with vpopmail not accepting mail properly,"
- elog "please ensure that /etc/vpopmail.conf is chmod 640 and"
- elog "owned by root:vpopmail"
- elog
- fi
-
- # do this for good measure
- if [[ -e /etc/vpopmail.conf ]]; then
- chmod 640 /etc/vpopmail.conf
- chown root:vpopmail /etc/vpopmail.conf
- fi
-
- upgradewarning
-}
-
-pkg_postrm() {
- vpopmail_set_homedir
-
- elog "The vpopmail DATA will NOT be removed automatically."
- elog "You can delete them manually by removing the ${VPOP_HOME} directory."
-}
-
-upgradewarning() {
- ewarn
- ewarn "Massive important warning if you are upgrading to 5.2.1-r8 or older"
- ewarn "The internal structure of the mail storage has changed for"
- ewarn "consistancy with the rest of Gentoo! Please review and utilize the "
- ewarn "script at ${VPOP_HOME}/bin/vpopmail-Maildir-dotmaildir-fix.sh"
- ewarn "to upgrade your system! (It can do conversions both ways)."
- ewarn "You should be able to run it right away without any changes."
- ewarn
-
- elog
- elog "Use of vpopmail's tcp.smtp[.cdb] is also deprecated now, consider"
- elog "using net-mail/relay-ctrl instead."
- elog
-
- if use mysql; then
- elog
- elog "If you are upgrading from 5.4.17 or older, you have to fix your"
- elog "MySQL tables:"
- elog
- elog 'ALTER TABLE `dir_control` CHANGE `domain` `domain` CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `ip_alias_map` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `lastauth` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `valias` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `vlog` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `vpopmail` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `limits` CHANGE domain domain CHAR(96) NOT NULL,'
- elog ' ADD `disable_spamassassin` TINYINT(1) DEFAULT '0' NOT NULL AFTER `disable_smtp`,'
- elog ' ADD `delete_spam` TINYINT(1) DEFAULT '0' NOT NULL AFTER `disable_spamassassin`;'
- elog
- fi
-}
diff --git a/net-mail/vpopmail/vpopmail-5.4.26.ebuild b/net-mail/vpopmail/vpopmail-5.4.26.ebuild
deleted file mode 100644
index 40329855018d..000000000000
--- a/net-mail/vpopmail/vpopmail-5.4.26.ebuild
+++ /dev/null
@@ -1,219 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.26.ebuild,v 1.2 2009/07/14 08:54:16 flameeyes Exp $
-
-inherit autotools eutils fixheadtails qmail
-
-HOMEPAGE="http://www.inter7.com/index.php?page=vpopmail"
-DESCRIPTION="A collection of programs to manage virtual email domains and accounts on your Qmail mail servers."
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sh ~sparc ~x86"
-IUSE="clearpasswd ipalias maildrop mysql"
-
-DEPEND="virtual/qmail
- maildrop? ( mail-filter/maildrop )
- mysql? ( virtual/mysql )
-"
-
-# This makes sure the variable is set, and that it isn't null.
-VPOP_DEFAULT_HOME="/var/vpopmail"
-
-vpopmail_set_homedir() {
- VPOP_HOME=$(getent passwd vpopmail | cut -d: -f6)
- if [[ -z "${VPOP_HOME}" ]]; then
- ebeep
- eerror "vpopmail's home directory is null in passwd data!"
- eerror "You probably want to check that out."
- eerror "Continuing with default."
- VPOP_HOME="${VPOP_DEFAULT_HOME}"
- else
- einfo "Setting VPOP_HOME to: $VPOP_HOME"
- fi
-}
-
-pkg_setup() {
- enewgroup vpopmail 89
- enewuser vpopmail 89 -1 ${VPOP_DEFAULT_HOME} vpopmail
- upgradewarning
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-5.4.9-access.violation.patch
- epatch "${FILESDIR}"/${PN}-lazy.patch
-
- # fix maildir paths
- sed -i -e 's|Maildir|.maildir|g' \
- vchkpw.c vconvert.c vdelivermail.c \
- vpopbull.c vpopmail.c vqmaillocal.c \
- vuserinfo.c maildirquota.c || die
-
- # remove vpopmail advertisement
- sed -i -e '/printf.*vpopmail/s:vpopmail (:(:' \
- vdelivermail.c vpopbull.c vqmaillocal.c || die
-
- eautoreconf
- ht_fix_file cdb/Makefile
-}
-
-src_compile() {
- vpopmail_set_homedir
-
- if use mysql; then
- authopts=" \
- --enable-auth-module=mysql \
- --enable-libs=/usr/include/mysql \
- --enable-libdir=/usr/lib/mysql \
- --enable-sql-logging \
- --enable-valias \
- --disable-mysql-replication \
- --enable-mysql-limits"
- else
- authopts="--enable-auth-module=cdb"
- fi
-
- econf ${authopts} \
- --sysconfdir=${VPOP_HOME}/etc \
- --enable-non-root-build \
- --enable-qmaildir=${QMAIL_HOME} \
- --enable-qmail-newu=${QMAIL_HOME}/bin/qmail-newu \
- --enable-qmail-inject=${QMAIL_HOME}/bin/qmail-inject \
- --enable-qmail-newmrh=${QMAIL_HOME}/bin/qmail-newmrh \
- --enable-vpopuser=vpopmail \
- --enable-vpopgroup=vpopmail \
- --enable-many-domains \
- --enable-file-locking \
- --enable-file-sync \
- --enable-md5-passwords \
- --enable-logging \
- --enable-auth-logging \
- --enable-log-name=vpopmail \
- --enable-qmail-ext \
- --disable-tcp-rules-prog \
- --disable-tcpserver-file \
- --disable-roaming-users \
- $(use_enable ipalias ip-alias-domains) \
- $(use_enable clearpasswd clear-passwd) \
- $(use_enable maildrop) \
- || die "configure failed"
-
- emake || die "make failed"
-}
-
-src_install() {
- vpopmail_set_homedir
-
- # bug #277764
- emake -j1 DESTDIR="${D}" install || die "make install failed"
- keepdir "${VPOP_HOME}"/domains
-
- # install helper script for maildir conversion
- into "${VPOP_HOME}"
- dobin "${FILESDIR}"/vpopmail-Maildir-dotmaildir-fix.sh
- into /usr
-
- dodoc AUTHORS ChangeLog FAQ INSTALL README*
- dohtml doc/doc_html/* doc/man_html/*
- rm -rf "${D}/${VPOP_HOME}"/doc
- dosym /usr/share/doc/${PF}/ "${VPOP_HOME}"/doc
-
- # create /etc/vpopmail.conf
- if use mysql; then
- dodir /etc
- mv "${D}${VPOP_HOME}"/etc/vpopmail.mysql "${D}"/etc/vpopmail.conf
- dosym /etc/vpopmail.conf "${VPOP_HOME}"/etc/vpopmail.mysql
-
- sed -e '12d' -i "${D}"/etc/vpopmail.conf
- echo '# Read-only DB' >> "${D}"/etc/vpopmail.conf
- echo 'localhost|0|vpopmail|secret|vpopmail' >> "${D}"/etc/vpopmail.conf
- echo '# Write DB' >> "${D}"/etc/vpopmail.conf
- echo 'localhost|0|vpopmail|secret|vpopmail' >> "${D}"/etc/vpopmail.conf
-
- # lock down perms
- fperms 640 /etc/vpopmail.conf
- fowners root:vpopmail /etc/vpopmail.conf
- fi
-
- einfo "Installing env.d entry"
- dodir /etc/env.d
- doenvd "${FILESDIR}"/99vpopmail
-
- einfo "Locking down vpopmail permissions"
- fowners root:0 -R "${VPOP_HOME}"/{bin,etc,include}
- fowners root:vpopmail "${VPOP_HOME}"/bin/vchkpw
- fperms 4711 "${VPOP_HOME}"/bin/vchkpw
-}
-
-pkg_postinst() {
- if use mysql ; then
- elog
- elog "You have 'mysql' turned on in your USE"
- elog "Vpopmail needs a VALID MySQL USER. Let's call it 'vpopmail'"
- elog "You MUST add it and then specify its passwd in the /etc/vpopmail.conf file"
- elog
- elog "First log into mysql as your mysql root user and pass. Then:"
- elog "> create database vpopmail;"
- elog "> use mysql;"
- elog "> grant select, insert, update, delete, create, drop on vpopmail.* to"
- elog " vpopmail@localhost identified by 'your password';"
- elog "> flush privileges;"
- elog
- elog "If you have problems with vpopmail not accepting mail properly,"
- elog "please ensure that /etc/vpopmail.conf is chmod 640 and"
- elog "owned by root:vpopmail"
- elog
- fi
-
- # do this for good measure
- if [[ -e /etc/vpopmail.conf ]]; then
- chmod 640 /etc/vpopmail.conf
- chown root:vpopmail /etc/vpopmail.conf
- fi
-
- upgradewarning
-}
-
-pkg_postrm() {
- vpopmail_set_homedir
-
- elog "The vpopmail DATA will NOT be removed automatically."
- elog "You can delete them manually by removing the ${VPOP_HOME} directory."
-}
-
-upgradewarning() {
- ewarn
- ewarn "Massive important warning if you are upgrading to 5.2.1-r8 or older"
- ewarn "The internal structure of the mail storage has changed for"
- ewarn "consistancy with the rest of Gentoo! Please review and utilize the "
- ewarn "script at ${VPOP_HOME}/bin/vpopmail-Maildir-dotmaildir-fix.sh"
- ewarn "to upgrade your system! (It can do conversions both ways)."
- ewarn "You should be able to run it right away without any changes."
- ewarn
-
- elog
- elog "Use of vpopmail's tcp.smtp[.cdb] is also deprecated now, consider"
- elog "using net-mail/relay-ctrl instead."
- elog
-
- if use mysql; then
- elog
- elog "If you are upgrading from 5.4.17 or older, you have to fix your"
- elog "MySQL tables:"
- elog
- elog 'ALTER TABLE `dir_control` CHANGE `domain` `domain` CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `ip_alias_map` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `lastauth` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `valias` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `vlog` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `vpopmail` CHANGE domain domain CHAR(96) NOT NULL;'
- elog 'ALTER TABLE `limits` CHANGE domain domain CHAR(96) NOT NULL,'
- elog ' ADD `disable_spamassassin` TINYINT(1) DEFAULT '0' NOT NULL AFTER `disable_smtp`,'
- elog ' ADD `delete_spam` TINYINT(1) DEFAULT '0' NOT NULL AFTER `disable_spamassassin`;'
- elog
- fi
-}
diff --git a/net-mail/vpopmail/vpopmail-5.4.30-r1.ebuild b/net-mail/vpopmail/vpopmail-5.4.30-r1.ebuild
index aecd02c01bfd..8e262318a21b 100644
--- a/net-mail/vpopmail/vpopmail-5.4.30-r1.ebuild
+++ b/net-mail/vpopmail/vpopmail-5.4.30-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.30-r1.ebuild,v 1.3 2010/04/05 17:40:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.30-r1.ebuild,v 1.4 2010/05/30 06:49:46 hollow Exp $
EAPI="2"
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 arm ~hppa ~ppc s390 sh sparc x86"
+KEYWORDS="amd64 arm ~hppa ~ppc s390 sh sparc x86"
IUSE="clearpasswd ipalias maildrop mysql"
DEPEND="virtual/qmail
diff --git a/net-mail/vpopmail/vpopmail-5.4.30.ebuild b/net-mail/vpopmail/vpopmail-5.4.30-r2.ebuild
index 52cf8f78bb46..2c0b9e900583 100644
--- a/net-mail/vpopmail/vpopmail-5.4.30.ebuild
+++ b/net-mail/vpopmail/vpopmail-5.4.30-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.30.ebuild,v 1.4 2010/01/26 17:34:34 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.30-r2.ebuild,v 1.1 2010/05/30 06:49:46 hollow Exp $
+
+EAPI="2"
inherit autotools eutils fixheadtails qmail
@@ -10,12 +12,13 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sh ~sparc ~x86"
-IUSE="clearpasswd ipalias maildrop mysql"
+KEYWORDS="~amd64 ~hppa ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="clearpasswd ipalias maildrop mysql spamassassin"
DEPEND="virtual/qmail
maildrop? ( mail-filter/maildrop )
- mysql? ( virtual/mysql )"
+ mysql? ( virtual/mysql )
+ spamassassin? ( mail-filter/spamassassin )"
RDEPEND="${DEPEND}"
# This makes sure the variable is set, and that it isn't null.
@@ -40,12 +43,10 @@ pkg_setup() {
upgradewarning
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${PN}-5.4.9-access.violation.patch
epatch "${FILESDIR}"/${PN}-lazy.patch
+ epatch "${FILESDIR}"/${PN}-double-free.patch
# fix maildir paths
sed -i -e 's|Maildir|.maildir|g' \
@@ -61,7 +62,7 @@ src_unpack() {
ht_fix_file cdb/Makefile
}
-src_compile() {
+src_configure() {
vpopmail_set_homedir
if use mysql; then
@@ -98,8 +99,11 @@ src_compile() {
$(use_enable ipalias ip-alias-domains) \
$(use_enable clearpasswd clear-passwd) \
$(use_enable maildrop) \
- || die "configure failed"
+ $(use_enable maildrop maildrop-prog /usr/bin/maildrop) \
+ $(use_enable spamassassin)
+}
+src_compile() {
emake || die "make failed"
}
@@ -137,6 +141,11 @@ src_install() {
fowners root:vpopmail /etc/vpopmail.conf
fi
+ insinto "${VPOP_HOME}"/etc
+ doins vusagec.conf
+ dosym "${VPOP_HOME}"/etc/vusagec.conf /etc/vusagec.conf
+ sed -i 's/Disable = False;/Disable = True;/g' "${D}${VPOP_HOME}"/etc/vusagec.conf
+
einfo "Installing env.d entry"
dodir /etc/env.d
doenvd "${FILESDIR}"/99vpopmail
@@ -214,4 +223,11 @@ upgradewarning() {
elog ' ADD `delete_spam` TINYINT(1) DEFAULT '0' NOT NULL AFTER `disable_spamassassin`;'
elog
fi
+
+ ewarn
+ ewarn "Newer versions of vpopmail contain a quota daemon called vusaged."
+ ewarn "This ebuild DOES NOT INSTALL vusaged and has therefore disabled"
+ ewarn "its usage in ${VPOP_HOME}/etc/vusagec.conf. DO NOT ENABLE!"
+ ewarn "Otherwise mail delivery WILL BREAK"
+ ewarn
}