summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2007-07-29 23:00:10 +0000
committerBenedikt Boehm <hollow@gentoo.org>2007-07-29 23:00:10 +0000
commit552d95f729780369ea804a99002bce9f69dd3226 (patch)
treebf665b88c43289cdcf8a49c7c562efa2e6c6a477 /net-mail
parentadd vpopmail maildrop use flag (diff)
downloadgentoo-2-552d95f729780369ea804a99002bce9f69dd3226.tar.gz
gentoo-2-552d95f729780369ea804a99002bce9f69dd3226.tar.bz2
gentoo-2-552d95f729780369ea804a99002bce9f69dd3226.zip
version bump. fixes #162348, #161765, #182192 and hopefully #126809, #149267 too
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/vpopmail/ChangeLog9
-rw-r--r--net-mail/vpopmail/files/99vpopmail2
-rw-r--r--net-mail/vpopmail/files/digest-vpopmail-5.4.193
-rw-r--r--net-mail/vpopmail/metadata.xml6
-rw-r--r--net-mail/vpopmail/vpopmail-5.4.19.ebuild202
5 files changed, 219 insertions, 3 deletions
diff --git a/net-mail/vpopmail/ChangeLog b/net-mail/vpopmail/ChangeLog
index fa939b7e2b52..435350b51b37 100644
--- a/net-mail/vpopmail/ChangeLog
+++ b/net-mail/vpopmail/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/vpopmail
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/ChangeLog,v 1.81 2007/07/02 14:56:57 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/ChangeLog,v 1.82 2007/07/29 23:00:10 hollow Exp $
+
+*vpopmail-5.4.19 (29 Jul 2007)
+
+ 29 Jul 2007; Benedikt Böhm <hollow@gentoo.org> files/99vpopmail,
+ metadata.xml, +vpopmail-5.4.19.ebuild:
+ version bump. fixes #162348, #161765, #182192 and hopefully #126809, #149267
+ too
02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> vpopmail-5.4.16.ebuild:
(QA) RESTRICT clean up.
diff --git a/net-mail/vpopmail/files/99vpopmail b/net-mail/vpopmail/files/99vpopmail
index f3fd7377eb90..02d0a9c4d35a 100644
--- a/net-mail/vpopmail/files/99vpopmail
+++ b/net-mail/vpopmail/files/99vpopmail
@@ -1,2 +1,2 @@
ROOTPATH="/var/vpopmail/bin"
-CONFIG_PROTECT="/var/vpopmail/domains /var/vpopmail/etc"
+CONFIG_PROTECT="/var/vpopmail/etc"
diff --git a/net-mail/vpopmail/files/digest-vpopmail-5.4.19 b/net-mail/vpopmail/files/digest-vpopmail-5.4.19
new file mode 100644
index 000000000000..af3688b2f63e
--- /dev/null
+++ b/net-mail/vpopmail/files/digest-vpopmail-5.4.19
@@ -0,0 +1,3 @@
+MD5 a00e988fa355af8c367f09ddf0d4aaea vpopmail-5.4.19a.tar.gz 489109
+RMD160 cc4c952b850bee9c6c10429dca59cce681287838 vpopmail-5.4.19a.tar.gz 489109
+SHA256 e124c596645bbdc3924b2b73339558a6d80aa61cfa4a0044939d240bae8ae66e vpopmail-5.4.19a.tar.gz 489109
diff --git a/net-mail/vpopmail/metadata.xml b/net-mail/vpopmail/metadata.xml
index 51f94e3fbe0e..ea8f365c8d69 100644
--- a/net-mail/vpopmail/metadata.xml
+++ b/net-mail/vpopmail/metadata.xml
@@ -1,5 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>net-mail</herd>
+ <herd>qmail</herd>
+ <maintainer>
+ <email>hollow@gentoo.org</email>
+ <name>Benedikt Böhm</name>
+ </maintainer>
</pkgmetadata>
diff --git a/net-mail/vpopmail/vpopmail-5.4.19.ebuild b/net-mail/vpopmail/vpopmail-5.4.19.ebuild
new file mode 100644
index 000000000000..0354edecf16c
--- /dev/null
+++ b/net-mail/vpopmail/vpopmail-5.4.19.ebuild
@@ -0,0 +1,202 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.19.ebuild,v 1.1 2007/07/29 23:00:10 hollow Exp $
+
+inherit eutils fixheadtails autotools
+
+HOMEPAGE="http://www.inter7.com/index.php?page=vpopmail"
+DESCRIPTION="A collection of programs to manage virtual email domains and accounts on your Qmail mail servers."
+SRC_URI="mirror://sourceforge/${PN}/${P}a.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="clearpasswd ipalias maildrop mysql"
+
+DEPEND="virtual/qmail
+ maildrop? ( mail-filter/maildrop )
+ mysql? ( virtual/mysql )
+"
+
+# This makes sure the variable is set, and that it isn't null.
+VPOP_DEFAULT_HOME="/var/vpopmail"
+
+# qmail home directory
+QMAIL_HOME="/var/qmail"
+
+vpopmail_set_homedir() {
+ VPOP_HOME=$(getent passwd vpopmail | cut -d: -f6)
+ if [[ -z "${VPOP_HOME}" ]]; then
+ ebeep
+ eerror "vpopmail's home directory is null in passwd data!"
+ eerror "You probably want to check that out."
+ eerror "Continuing with default."
+ VPOP_HOME="${VPOP_DEFAULT_HOME}"
+ else
+ einfo "Setting VPOP_HOME to: $VPOP_HOME"
+ fi
+}
+
+pkg_setup() {
+ enewgroup vpopmail 89
+ enewuser vpopmail 89 -1 ${VPOP_DEFAULT_HOME} vpopmail
+ upgradewarning
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-5.4.9-access.violation.patch
+ epatch "${FILESDIR}"/${PN}-lazy.patch
+
+ # fix maildir paths
+ sed -i -e 's|Maildir|.maildir|g' \
+ vchkpw.c vconvert.c vdelivermail.c \
+ vpopbull.c vpopmail.c vqmaillocal.c \
+ vuserinfo.c maildirquota.c || die
+
+ # remove vpopmail advertisement
+ sed -i -e '/printf.*vpopmail/s:vpopmail (:(:' \
+ vdelivermail.c vpopbull.c vqmaillocal.c || die
+
+ eautoreconf
+ ht_fix_file "${S}"/cdb/Makefile || die "failed to fix file"
+}
+
+src_compile() {
+ vpopmail_set_homedir
+
+ if use mysql; then
+ authopts=" \
+ --enable-auth-module=mysql \
+ --enable-libs=/usr/include/mysql \
+ --enable-libdir=/usr/lib/mysql \
+ --enable-sql-logging \
+ --enable-valias \
+ --disable-mysql-replication \
+ --enable-mysql-limits"
+ else
+ authopts="--enable-auth-module=cdb"
+ fi
+
+ econf ${authopts} \
+ --sysconfdir=${VPOP_HOME}/etc \
+ --enable-non-root-build \
+ --enable-qmaildir=${QMAIL_HOME} \
+ --enable-qmail-newu=${QMAIL_HOME}/bin/qmail-newu \
+ --enable-qmail-inject=${QMAIL_HOME}/bin/qmail-inject \
+ --enable-qmail-newmrh=${QMAIL_HOME}/bin/qmail-newmrh \
+ --enable-vpopuser=vpopmail \
+ --enable-vpopgroup=vpopmail \
+ --enable-many-domains \
+ --enable-file-locking \
+ --enable-file-sync \
+ --enable-md5-passwords \
+ --enable-logging \
+ --enable-auth-logging \
+ --enable-log-name=vpopmail \
+ --enable-qmail-ext \
+ --disable-tcp-rules-prog \
+ --disable-tcpserver-file \
+ --disable-roaming-users \
+ $(use_enable ipalias ip-alias-domains) \
+ $(use_enable clearpasswd clear-passwd) \
+ $(use_enable maildrop) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ vpopmail_set_homedir
+
+ make DESTDIR="${D}" install || die "make install failed"
+ keepdir "${VPOP_HOME}"/domains
+
+ # install helper script for maildir conversion
+ into /var/vpopmail
+ dobin "${FILESDIR}"/vpopmail-Maildir-dotmaildir-fix.sh
+ into /usr
+
+ # install documentation
+ dodoc AUTHORS ChangeLog FAQ INSTALL README*
+ dohtml doc/doc_html/* doc/man_html/*
+ rm -rf "${D}"/"${VPOP_HOME}"/doc
+ dosym /usr/share/doc/${PF}/ "${VPOP_HOME}"/doc
+
+ # create /etc/vpopmail.conf
+ if use mysql; then
+ einfo "Installing vpopmail mysql configuration file"
+ dodir /etc
+ # config file position
+ mv "${D}"/var/vpopmail/etc/vpopmail.mysql "${D}"/etc/vpopmail.conf
+ dosym /etc/vpopmail.conf /var/vpopmail/etc/vpopmail.mysql
+ sed -e '12d' -i "${D}"/etc/vpopmail.conf
+ echo '# Read-only DB' >> "${D}"/etc/vpopmail.conf
+ echo 'localhost|0|vpopmail|secret|vpopmail' >> "${D}"/etc/vpopmail.conf
+ echo '# Write DB' >>${D}/etc/vpopmail.conf
+ echo 'localhost|0|vpopmail|secret|vpopmail' >> "${D}"/etc/vpopmail.conf
+ # lock down perms
+ fperms 640 /etc/vpopmail.conf
+ fowners root:vpopmail /etc/vpopmail.conf
+ fi
+
+ einfo "Installing env.d entry"
+ dodir /etc/env.d
+ doenvd "${FILESDIR}"/99vpopmail
+
+ einfo "Locking down vpopmail permissions"
+ fowners root:0 -R "${VPOP_HOME}"/{bin,etc,include}
+ fowners root:vpopmail "${VPOP_HOME}"/bin/vchkpw
+ fperms 4711 "${VPOP_HOME}"/bin/vchkpw
+}
+
+pkg_postinst() {
+ einfo "Performing post-installation routines for ${P}"
+
+ if use mysql ; then
+ elog
+ elog "You have 'mysql' turned on in your USE"
+ elog "Vpopmail needs a VALID MySQL USER. Let's call it 'vpopmail'"
+ elog "You MUST add it and then specify its passwd in the /etc/vpopmail.conf file"
+ elog
+ elog "First log into mysql as your mysql root user and pass. Then:"
+ elog "> create database vpopmail;"
+ elog "> use mysql;"
+ elog "> grant select, insert, update, delete, create, drop on vpopmail.* to"
+ elog " vpopmail@localhost identified by 'your password';"
+ elog "> flush privileges;"
+ elog
+ elog "If you have problems with vpopmail not accepting mail properly,"
+ elog "please ensure that /etc/vpopmail.conf is chmod 640 and"
+ elog "owned by root:vpopmail"
+ fi
+
+ # do this for good measure
+ if [ -e /etc/vpopmail.conf ] ; then
+ chmod 640 /etc/vpopmail.conf
+ chown root:vpopmail /etc/vpopmail.conf
+ fi
+
+ upgradewarning
+}
+
+pkg_postrm() {
+ vpopmail_set_homedir
+
+ elog "The vpopmail DATA will NOT be removed automatically."
+ elog "You can delete them manually by removing the ${VPOP_HOME} directory."
+}
+
+upgradewarning() {
+ ewarn "Massive important warning if you are upgrading to 5.2.1-r8 or older"
+ ewarn "The internal structure of the mail storage has changed for"
+ ewarn "consistancy with the rest of Gentoo! Please review and utilize the "
+ ewarn "script at /var/vpopmail/bin/vpopmail-Maildir-dotmaildir-fix.sh"
+ ewarn "to upgrade your system! (It can do conversions both ways)."
+ ewarn "You should be able to run it right away without any changes."
+ elog
+ elog "Use of vpopmail's tcp.smtp[.cdb] is also deprecated now, consider"
+ elog "using net-mail/relay-ctrl instead."
+}