summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-01-26 22:16:33 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-01-26 22:16:33 +0000
commit3916b8dae1d3c687322e4e78a5a3b6ad56df4cb4 (patch)
tree85175381eaf5f85d690f666d7aac42f28fe9aad6 /net-mail
parentAdded ~mips; bug #161039 (diff)
downloadgentoo-2-3916b8dae1d3c687322e4e78a5a3b6ad56df4cb4.tar.gz
gentoo-2-3916b8dae1d3c687322e4e78a5a3b6ad56df4cb4.tar.bz2
gentoo-2-3916b8dae1d3c687322e4e78a5a3b6ad56df4cb4.zip
Version bump.
(Portage version: 2.1.2-r4)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/getmail/ChangeLog7
-rw-r--r--net-mail/getmail/files/digest-getmail-4.7.03
-rw-r--r--net-mail/getmail/getmail-4.7.0.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/net-mail/getmail/ChangeLog b/net-mail/getmail/ChangeLog
index b9bca6927b54..ceae7cb2da3f 100644
--- a/net-mail/getmail/ChangeLog
+++ b/net-mail/getmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/getmail
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.137 2007/01/06 00:58:42 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.138 2007/01/26 22:16:32 ticho Exp $
+
+*getmail-4.7.0 (26 Jan 2007)
+
+ 26 Jan 2007; Andrej Kacian <ticho@gentoo.org> +getmail-4.7.0.ebuild:
+ Version bump.
06 Jan 2007; Fernando J. Pereda <ferdy@gentoo.org> -getmail-4.6.3.ebuild,
-getmail-4.6.4.ebuild, -getmail-4.6.5.ebuild, -getmail-4.6.6.ebuild:
diff --git a/net-mail/getmail/files/digest-getmail-4.7.0 b/net-mail/getmail/files/digest-getmail-4.7.0
new file mode 100644
index 000000000000..bd77c3ede0d3
--- /dev/null
+++ b/net-mail/getmail/files/digest-getmail-4.7.0
@@ -0,0 +1,3 @@
+MD5 9f0339b2208b729024bc1e633dd3ca04 getmail-4.7.0.tar.gz 146261
+RMD160 0cf39d73afcf01af4c5b4d6bb21512ceb73f2847 getmail-4.7.0.tar.gz 146261
+SHA256 15776ad603803c032616f5a2f32cc0de59ddd0e8aed5b7d076cde148ba1cb7e1 getmail-4.7.0.tar.gz 146261
diff --git a/net-mail/getmail/getmail-4.7.0.ebuild b/net-mail/getmail/getmail-4.7.0.ebuild
new file mode 100644
index 000000000000..2fc69561cfe6
--- /dev/null
+++ b/net-mail/getmail/getmail-4.7.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.7.0.ebuild,v 1.1 2007/01/26 22:16:32 ticho Exp $
+
+inherit distutils
+
+IUSE=""
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/python-2.3.3"
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ if has_version "=net-mail/getmail-3*" ; then
+ mv ${D}/usr/bin/getmail ${D}/usr/bin/getmail4
+ mv ${D}/usr/bin/getmail_maildir ${D}/usr/bin/getmail_maildir4
+ mv ${D}/usr/bin/getmail_mbox ${D}/usr/bin/getmail_mbox4
+ fi
+
+ # handle docs the gentoo way
+ if [ ${P} != ${PF} ]; then
+ mv ${D}/usr/share/doc/${P} ${D}/usr/share/doc/${PF}
+ fi
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/${PF}/*.html ${D}/usr/share/doc/${PF}/*.css ${D}/usr/share/doc/${PF}/html
+ gzip --silent ${D}/usr/share/doc/${PF}/*
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/getmailcore
+
+ if has_version "=net-mail/getmail-3*" ; then
+ echo
+ ewarn "An already installed instance of getmail v3 was detected. In order to"
+ ewarn "co-exist with it the three main scripts of getmail v4 were renamed to"
+ ewarn "getmail4, getmail_maildir4, getmail_mbox4."
+ echo
+ fi
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}