summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-08-19 22:51:29 +0000
committerAron Griffis <agriffis@gentoo.org>2003-08-19 22:51:29 +0000
commit2c9bb961cf0155d73bba4301aae32e30095b12ea (patch)
tree3bb5f902e1a854b72b76c4dc2e6c3bed63db7d03 /net-mail
parentadd some alpha fixes (diff)
downloadgentoo-2-2c9bb961cf0155d73bba4301aae32e30095b12ea.tar.gz
gentoo-2-2c9bb961cf0155d73bba4301aae32e30095b12ea.tar.bz2
gentoo-2-2c9bb961cf0155d73bba4301aae32e30095b12ea.zip
add some alpha fixes
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/evolution/ChangeLog6
-rw-r--r--net-mail/evolution/Manifest4
-rw-r--r--net-mail/evolution/evolution-1.4.4.ebuild9
-rw-r--r--net-mail/evolution/files/evolution-1.4.4-alpha.patch71
4 files changed, 85 insertions, 5 deletions
diff --git a/net-mail/evolution/ChangeLog b/net-mail/evolution/ChangeLog
index c4cf3611658f..a8f709d8b625 100644
--- a/net-mail/evolution/ChangeLog
+++ b/net-mail/evolution/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/evolution
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.73 2003/08/14 13:25:04 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.74 2003/08/19 22:51:25 agriffis Exp $
+
+ 19 Aug 2003; Aron Griffis <agriffis@gentoo.org> evolution-1.4.4.ebuild,
+ files/evolution-1.4.4-alpha.patch:
+ Add some alpha fixes --- not complete yet
14 Aug 2003; Aron Griffis <agriffis@gentoo.org> evolution-1.4.4.ebuild:
Add ~alpha to KEYWORDS
diff --git a/net-mail/evolution/Manifest b/net-mail/evolution/Manifest
index 9e58a34637a9..776b804ad6cf 100644
--- a/net-mail/evolution/Manifest
+++ b/net-mail/evolution/Manifest
@@ -1,5 +1,5 @@
-MD5 c2bac4e37fd4f54869ea5c67cacb50e7 ChangeLog 11902
-MD5 61a4d468d31662580eff696952b05744 evolution-1.4.4.ebuild 5004
+MD5 7b3d71d90e654326fb1c74ebcff85839 ChangeLog 12058
+MD5 ef516dabe643e34873c035e729e892ed evolution-1.4.4.ebuild 5004
MD5 8fefce38e3ac94cc548fc2a0929241b0 evolution-1.2.4.ebuild 6364
MD5 04e14969d84f200f5d3cc4ec9f09a08a evolution-1.4.0.ebuild 4941
MD5 80850151bae2bd61c4ac796f83656ef6 metadata.xml 217
diff --git a/net-mail/evolution/evolution-1.4.4.ebuild b/net-mail/evolution/evolution-1.4.4.ebuild
index 54b0d4ce3318..651d249fd5ee 100644
--- a/net-mail/evolution/evolution-1.4.4.ebuild
+++ b/net-mail/evolution/evolution-1.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.4.4.ebuild,v 1.2 2003/08/14 13:25:04 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.4.4.ebuild,v 1.3 2003/08/19 22:51:25 agriffis Exp $
IUSE="ssl mozilla ldap doc spell pda ipv6 kerberos kde"
@@ -15,7 +15,7 @@ HOMEPAGE="http://www.ximian.com"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~hppa ~alpha"
+KEYWORDS="~x86 ~ppc ~sparc ~hppa"
# Top stanza are ximian deps
RDEPEND=">=gnome-extra/libgtkhtml-3.0.8
@@ -74,6 +74,11 @@ src_unpack() {
# We need the omf fix, or else we get access violation
# errors related to sandbox
gnome2_omf_fix ${S}/help/C/Makefile.in
+
+ # Patches for 64-bit
+ if use alpha; then
+ epatch ${FILESDIR}/evolution-1.4.4-alpha.patch || die "epatch failed"
+ fi
}
##### Compile evolution specific db3 for static linking #####
diff --git a/net-mail/evolution/files/evolution-1.4.4-alpha.patch b/net-mail/evolution/files/evolution-1.4.4-alpha.patch
new file mode 100644
index 000000000000..7e60e2e902f1
--- /dev/null
+++ b/net-mail/evolution/files/evolution-1.4.4-alpha.patch
@@ -0,0 +1,71 @@
+--- evolution-1.4.4/shell/e-config-upgrade.c 2003-06-25 13:08:01.000000000 -0400
++++ ../../evo-avg/shell/e-config-upgrade.c 2003-08-18 14:54:57.000000000 -0400
+@@ -734,7 +734,7 @@
+ struct _map_table {
+ char *from;
+ char *to;
+- int type;
++ GType type;
+ struct _map_table *child;
+ };
+
+@@ -1097,7 +1097,7 @@
+ struct _gconf_map {
+ char *from;
+ char *to;
+- int type;
++ GType type;
+ };
+
+ /* ********************************************************************** */
+--- evolution-1.4.4/filter/rule-context.c 2003-06-12 13:04:20.000000000 -0400
++++ ../../evo-avg/filter/rule-context.c 2003-08-18 14:29:14.000000000 -0400
+@@ -209,7 +209,7 @@
+ }
+
+ void
+-rule_context_add_part_set(RuleContext *rc, const char *setname, int part_type, RCPartFunc append, RCNextPartFunc next)
++rule_context_add_part_set(RuleContext *rc, const char *setname, GType part_type, RCPartFunc append, RCNextPartFunc next)
+ {
+ struct _part_set_map *map;
+
+@@ -226,7 +226,7 @@
+ }
+
+ void
+-rule_context_add_rule_set(RuleContext *rc, const char *setname, int rule_type, RCRuleFunc append, RCNextRuleFunc next)
++rule_context_add_rule_set(RuleContext *rc, const char *setname, GType rule_type, RCRuleFunc append, RCNextRuleFunc next)
+ {
+ struct _rule_set_map *map;
+
+--- evolution-1.4.4/filter/rule-context.h 2003-04-29 14:14:08.000000000 -0400
++++ ../../evo-avg/filter/rule-context.h 2003-08-18 14:28:04.000000000 -0400
+@@ -85,14 +85,14 @@
+
+ struct _part_set_map {
+ char *name;
+- int type;
++ GType type;
+ RCPartFunc append;
+ RCNextPartFunc next;
+ };
+
+ struct _rule_set_map {
+ char *name;
+- int type;
++ GType type;
+ RCRuleFunc append;
+ RCNextRuleFunc next;
+ };
+@@ -122,9 +122,9 @@
+ int rule_context_get_rank_rule (RuleContext *rc, FilterRule *rule, const char *source);
+
+ /* setup type for set parts */
+-void rule_context_add_part_set (RuleContext *rc, const char *setname, int part_type,
++void rule_context_add_part_set (RuleContext *rc, const char *setname, GType part_type,
+ RCPartFunc append, RCNextPartFunc next);
+-void rule_context_add_rule_set (RuleContext *rc, const char *setname, int rule_type,
++void rule_context_add_rule_set (RuleContext *rc, const char *setname, GType rule_type,
+ RCRuleFunc append, RCNextRuleFunc next);
+
+ /* uri's disappear/renamed externally */