summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2005-02-23 12:19:03 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2005-02-23 12:19:03 +0000
commitcaff2c2430f70e15f95cb397fdda9155e1ad2308 (patch)
tree67ec02339fc9a84fa3575ba8206c9f86165aae92 /net-mail/vm-pop3d/vm-pop3d-1.1.6-r1.ebuild
parentVersion bump for bug 82792; removed old patches that I forgot to remove last ... (diff)
downloadgentoo-2-caff2c2430f70e15f95cb397fdda9155e1ad2308.tar.gz
gentoo-2-caff2c2430f70e15f95cb397fdda9155e1ad2308.tar.bz2
gentoo-2-caff2c2430f70e15f95cb397fdda9155e1ad2308.zip
Bump to make it conform bug #79240.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'net-mail/vm-pop3d/vm-pop3d-1.1.6-r1.ebuild')
-rw-r--r--net-mail/vm-pop3d/vm-pop3d-1.1.6-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/net-mail/vm-pop3d/vm-pop3d-1.1.6-r1.ebuild b/net-mail/vm-pop3d/vm-pop3d-1.1.6-r1.ebuild
new file mode 100644
index 000000000000..5a5e9132530e
--- /dev/null
+++ b/net-mail/vm-pop3d/vm-pop3d-1.1.6-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vm-pop3d/vm-pop3d-1.1.6-r1.ebuild,v 1.1 2005/02/23 12:19:03 ferdy Exp $
+
+inherit eutils
+
+DESCRIPTION="POP3 server"
+HOMEPAGE="http://www.reedmedia.net/software/virtualmail-pop3d/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/system/mail/pop/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE="pam debug"
+
+DEPEND="virtual/libc
+ pam? (
+ sys-libs/pam
+ >=net-mail/mailbase-0.00-r8
+ )"
+
+pkg_setup() {
+ if use pam && ! built_with_use net-mail/mailbase pam;
+ then
+ echo
+ ewarn "${PN} needs net-mail/mailbase to be built with USE flag pam"
+ ewarn " activated. Please rebuild net-mail/mailbase with pam"
+ echo
+ die "mailbase has to be built with pam flag"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/makefile.in.diff
+}
+
+src_compile() {
+ econf \
+ $(use_enable pam) \
+ $(use_enable debug) \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ dodoc AUTHORS CHANGES COPYING FAQ INSTALL README TODO
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/vm-pop3d.rc3 vm-pop3d
+ insinto /etc/conf.d
+ newins ${FILESDIR}/vm-pop3d.confd vm-pop3d
+}
+
+pkg_postinst() {
+ if use pam;
+ then
+ ln -s /etc/pam.d/pop /etc/pam.d/vm-pop3d
+ fi
+}