summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-08-18 00:22:47 +0000
committerNick Hadaway <raker@gentoo.org>2002-08-18 00:22:47 +0000
commitd77e5bd1b6e79c9c0df5efd8814327c7773283b1 (patch)
tree06930b559c56d6cb8a95faf285b63ccbbb3751ec /net-mail/uw-imap
parentUpdated ChangeLog. (diff)
downloadgentoo-2-d77e5bd1b6e79c9c0df5efd8814327c7773283b1.tar.gz
gentoo-2-d77e5bd1b6e79c9c0df5efd8814327c7773283b1.tar.bz2
gentoo-2-d77e5bd1b6e79c9c0df5efd8814327c7773283b1.zip
Reverted mailsubdir change as it may break many client installs.
Changed login timeout from 3 minutes to 1 minute. Updated SSL configuration options. Disabled reverse dns lookups.
Diffstat (limited to 'net-mail/uw-imap')
-rw-r--r--net-mail/uw-imap/ChangeLog7
-rw-r--r--net-mail/uw-imap/files/gentoo.diff38
-rw-r--r--net-mail/uw-imap/uw-imap-2001a-r2.ebuild12
3 files changed, 50 insertions, 7 deletions
diff --git a/net-mail/uw-imap/ChangeLog b/net-mail/uw-imap/ChangeLog
index 9ce6b0f31719..e7c3dc560a2f 100644
--- a/net-mail/uw-imap/ChangeLog
+++ b/net-mail/uw-imap/ChangeLog
@@ -1,8 +1,13 @@
# ChangeLog for net-mail/uw-imap
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/ChangeLog,v 1.4 2002/08/17 02:34:05 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/ChangeLog,v 1.5 2002/08/18 00:22:47 raker Exp $
*uw-imap-2001a-r2 (6 Jun 2002)
+
+ 17 Aug 2002; Nick Hadaway <raker@gentoo.org> uw-imap-2001a-r2.ebuild :
+ Reverted mailsubdir option change as it may break many client installs.
+ Disabled reverse DNS lookups. Updated SSL configuration options.
+ Changed imap login timeout from 3 minutes to 1 minute.
16 Aug 2002; Nick Hadaway <raker@gentoo.org> uw-imap-2001a-r2.ebuild :
Added support for the default mailsubdir to be ~/mail. Almost
diff --git a/net-mail/uw-imap/files/gentoo.diff b/net-mail/uw-imap/files/gentoo.diff
new file mode 100644
index 000000000000..ae8f9a660cb6
--- /dev/null
+++ b/net-mail/uw-imap/files/gentoo.diff
@@ -0,0 +1,38 @@
+diff -urN imap-2001a/Makefile imap-2001a-modified/Makefile
+--- imap-2001a/Makefile Mon Oct 22 23:46:33 2001
++++ imap-2001a-modified/Makefile Sat Aug 17 19:01:19 2002
+@@ -212,7 +212,7 @@
+ # gradually-increasing intervals, starting at 2800-2900, and becoming
+ # permanent at 48,300.
+
+-EXTRACFLAGS=
++EXTRACFLAGS=-DDISABLE_REVERSE_DNS_LOOKUP
+
+
+ # Extra linker flags (additional/alternative libraries, etc.)
+diff -urN imap-2001a/src/imapd/imapd.c imap-2001a-modified/src/imapd/imapd.c
+--- imap-2001a/src/imapd/imapd.c Wed Nov 14 17:26:07 2001
++++ imap-2001a-modified/src/imapd/imapd.c Sat Aug 17 18:55:51 2002
+@@ -37,7 +37,7 @@
+
+ #define MINUTES *60
+
+-#define LOGINTIMEOUT 3 MINUTES /* not logged in autologout timer */
++#define LOGINTIMEOUT 1 MINUTES /* not logged in autologout timer */
+ #define TIMEOUT 30 MINUTES /* RFC 2060 minimum autologout timer */
+ #define ALERTTIMER 1 MINUTES /* alert check timer */
+ #define SHUTDOWNTIMER 1 MINUTES /* shutdown dally timer */
+diff -urN imap-2001a/src/osdep/unix/Makefile imap-2001a-modified/src/osdep/unix/Makefile
+--- imap-2001a/src/osdep/unix/Makefile Tue Nov 6 18:16:43 2001
++++ imap-2001a-modified/src/osdep/unix/Makefile Sat Aug 17 19:14:37 2002
+@@ -28,8 +28,8 @@
+
+ # Extended flags needed for SSL. You may need to modify.
+
+-SSLDIR=/usr/local/ssl
+-SSLCERTS=$(SSLDIR)/certs
++SSLDIR=/usr
++SSLCERTS=$(SSLDIR)/lib/ssl/certs
+ SSLINCLUDE=$(SSLDIR)/include
+ SSLLIB=$(SSLDIR)/lib
+
diff --git a/net-mail/uw-imap/uw-imap-2001a-r2.ebuild b/net-mail/uw-imap/uw-imap-2001a-r2.ebuild
index eb09ec482744..630e1394021c 100644
--- a/net-mail/uw-imap/uw-imap-2001a-r2.ebuild
+++ b/net-mail/uw-imap/uw-imap-2001a-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/uw-imap-2001a-r2.ebuild,v 1.4 2002/08/17 02:34:05 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/uw-imap-2001a-r2.ebuild,v 1.5 2002/08/18 00:22:47 raker Exp $
PN0=imap
S=${WORKDIR}/${PN0}-${PV}
@@ -20,14 +20,14 @@ src_unpack() {
cd ${S}/src/osdep/unix/
sed "s:-g -fno-omit-frame-pointer -O6:${CFLAGS}:" Makefile > Makefile.bak
mv Makefile.bak Makefile
+ cd ${S}
+ patch -p1 < ${FILESDIR}/gentoo.diff || die
}
src_compile() {
if use ssl; then
- make lnp SPECIALAUTHENTICATORS=ssl \
- SSLTYPE=unix SSLDIR=/usr/ssl \
- SSLINCLUDE=/usr/include/openssl \
- EXTRACFLAGS=-DMAILSUBDIR="mail" || die
+ cd ${S}
+ make lnp SPECIALAUTHENTICATORS=ssl SSLTYPE=unix || die
# I was SO tempted to add -DY4KBUGFIX to the EXTRACFLAGS...
# but I didn't. S0meday s00n.
@@ -54,7 +54,7 @@ EOF
umask 022
done
else
- make lnp || die
+ make lnp EXTRACFLAGS=-DMAILSUBDIR=\"mail\" || die
fi
}