summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2002-04-15 20:13:40 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2002-04-15 20:13:40 +0000
commit3189565370000fe9f6c67e3bf61a26524168dd08 (patch)
treeec8bf79675f71cbbfed768514443a03c51217c3c /net-mail/uw-imap
parentFixed bug #1401(javac path problem) & bug #1254(imap with ssl) (diff)
downloadgentoo-2-3189565370000fe9f6c67e3bf61a26524168dd08.tar.gz
gentoo-2-3189565370000fe9f6c67e3bf61a26524168dd08.tar.bz2
gentoo-2-3189565370000fe9f6c67e3bf61a26524168dd08.zip
Fixed bug #1759 (uw-imap didn't provide enough headers for proper php
imap compile) Remove PROVIDE of virtual/imapUW
Diffstat (limited to 'net-mail/uw-imap')
-rw-r--r--net-mail/uw-imap/ChangeLog12
-rw-r--r--net-mail/uw-imap/files/digest-uw-imap-2001a-r11
-rw-r--r--net-mail/uw-imap/uw-imap-2001a-r1.ebuild90
3 files changed, 102 insertions, 1 deletions
diff --git a/net-mail/uw-imap/ChangeLog b/net-mail/uw-imap/ChangeLog
index 1635d705741a..d3a775de9438 100644
--- a/net-mail/uw-imap/ChangeLog
+++ b/net-mail/uw-imap/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/ChangeLog,v 1.1 2002/02/23 18:06:44 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/ChangeLog,v 1.2 2002/04/15 20:13:40 jhhudso Exp $
+
+*uw-imap-2001a-r1 (15 Apr 2002)
+
+ 15 Apr 2002; Jared H. Hudson <jhhudso@gentoo.org> :
+
+ Made uw-imap install more headers, so that php with imap
+ support will properly compile. Bug #1759
+ Removed virtual/imapUW PROVIDE because php will only DEPEND on
+ uw-imap specifically. pine will also no longer PROVIDE virtual/imapUW
+ now.
*uw-imap-2001a (23 Feb. 2002)
diff --git a/net-mail/uw-imap/files/digest-uw-imap-2001a-r1 b/net-mail/uw-imap/files/digest-uw-imap-2001a-r1
new file mode 100644
index 000000000000..b752e9d05f97
--- /dev/null
+++ b/net-mail/uw-imap/files/digest-uw-imap-2001a-r1
@@ -0,0 +1 @@
+MD5 42c5c8d049c209b15513a4f6ebba34d2 imap-2001a.tar.Z 1959777
diff --git a/net-mail/uw-imap/uw-imap-2001a-r1.ebuild b/net-mail/uw-imap/uw-imap-2001a-r1.ebuild
new file mode 100644
index 000000000000..1e8ed81a0aad
--- /dev/null
+++ b/net-mail/uw-imap/uw-imap-2001a-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Cristian Martinez <cfuga@itam.mx>
+# Updated by Todd Wright <wylie@geekasylum.org> -r1
+# /space/gentoo/cvsroot/gentoo-x86/net-mail/uw-imap/uw-imap-2001a.ebuild,v 1.3 2002/02/23 21:08:38 g2boojum Exp
+
+PN0=imap
+S=${WORKDIR}/${PN0}-${PV}
+DESCRIPTION="UW server daemons for IMAP and POP network mail protocols."
+SRC_URI="ftp://ftp.cac.washington.edu/${PN0}/${PN0}-${PV}.tar.Z"
+HOMEPAGE="http://www.washington.edu/imap/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/pam-0.72
+ ssl? ( dev-libs/openssl )"
+
+PROVIDE="virtual/imapd"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src/osdep/unix/
+ sed "s:-g -fno-omit-frame-pointer -O6:${CFLAGS}:" Makefile > Makefile.bak
+ mv Makefile.bak Makefile
+}
+
+src_compile() {
+ if use ssl; then
+ make lnp SPECIALAUTHENTICATORS=ssl SSLTYPE=unix SSLDIR=/usr/ssl \
+ SSLINCLUDE=/usr/include/openssl || die
+ local i
+ for i in imapd ipop3d; do
+ umask 077
+ PEM1=`/bin/mktemp ${T}/openssl.XXXXXX`
+ PEM2=`/bin/mktemp ${T}/openssl.XXXXXX`
+ /usr/bin/openssl req -newkey rsa:1024 -keyout $$PEM1 \
+ -nodes -x509 -days 365 -out $$PEM2 << EOF
+--
+SomeState
+SomeCity
+SomeOrganization
+SomeOrganizationalUnit
+localhost.localdomain
+root@localhost.localdomain
+EOF
+
+ cat $$PEM1 > ${i}.pem
+ echo "" >> ${i}.pem
+ cat $$PEM2 >> ${i}.pem
+ rm $$PEM1 $$PEM2
+ umask 022
+ done
+ else
+ make lnp || die
+ fi
+}
+
+src_install() {
+ into /usr
+ dosbin imapd/imapd ipopd/ipop?d
+
+ if use ssl; then
+ mkdir -p ${D}/usr/ssl/certs
+ mv imapd.pem ${D}/usr/ssl/certs
+ mv ipop3d.pem ${D}/usr/ssl/certs
+ fi
+
+ insinto /usr/include/imap
+ doins c-client/{c-client,mail,imap4r1,rfc822,linkage,misc,smtp,nntp}.h
+ doins c-client/{osdep,env_unix,env,fs,ftl,nl,tcp}.h
+ dolib.a c-client/c-client.a
+ dosym /usr/lib/c-client.a /usr/lib/libc-client.a
+
+ doman src/ipopd/ipopd.8c src/imapd/imapd.8c
+
+ dodoc CPYRIGHT README docs/*.txt docs/CONFIG docs/FAQ docs/RELNOTES
+
+ docinto rfc
+ dodoc docs/rfc/*.txt
+
+ # gentoo config stuff
+ insinto /etc/pam.d
+ newins ${FILESDIR}/uw-imap.pam imap
+ newins ${FILESDIR}/uw-imap.pam pop
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/uw-imap.xinetd imap
+ newins ${FILESDIR}/uw-ipop2.xinetd ipop2
+ newins ${FILESDIR}/uw-ipop3.xinetd ipop3
+ newins ${FILESDIR}/uw-imaps.xinetd imaps
+
+}