summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-06-29 09:42:57 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-06-29 09:42:57 +0000
commit0db73a76bdeda0e9aab37a41b4e2c82ecd172573 (patch)
treebb820b7ef68848fb829ae7e62915eaf55b190467 /net-mail/sylpheed-claws
parentadded virtual/sylpheed (diff)
downloadgentoo-2-0db73a76bdeda0e9aab37a41b4e2c82ecd172573.tar.gz
gentoo-2-0db73a76bdeda0e9aab37a41b4e2c82ecd172573.tar.bz2
gentoo-2-0db73a76bdeda0e9aab37a41b4e2c82ecd172573.zip
provides virtual/sylpheed
Diffstat (limited to 'net-mail/sylpheed-claws')
-rw-r--r--net-mail/sylpheed-claws/ChangeLog9
-rw-r--r--net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.7.8-r11
-rw-r--r--net-mail/sylpheed-claws/sylpheed-claws-0.7.8-r1.ebuild84
3 files changed, 93 insertions, 1 deletions
diff --git a/net-mail/sylpheed-claws/ChangeLog b/net-mail/sylpheed-claws/ChangeLog
index 03036e76eeda..c2851eaec6fb 100644
--- a/net-mail/sylpheed-claws/ChangeLog
+++ b/net-mail/sylpheed-claws/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/sylpheed-claws
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/ChangeLog,v 1.9 2002/06/17 05:25:33 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/ChangeLog,v 1.10 2002/06/29 09:42:36 seemant Exp $
+
+*sylpheed-claws-0.7.8-r1 (29 Jun 2002)
+
+ 29 Jun 2002; Seemant Kulleen <seemant@gentoo.org> sylpheed-claws-0.7.8-r1
+ files/digest-sylpheed-claws-0.7.8-r1 :
+
+ PROVIDEs virtual/sylpheed
*sylpheed-claws-0.7.8 (16 Jun 2002)
diff --git a/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.7.8-r1 b/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.7.8-r1
new file mode 100644
index 000000000000..f6f898eb6524
--- /dev/null
+++ b/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.7.8-r1
@@ -0,0 +1 @@
+MD5 94724f28b92a20297783aa29625b558c sylpheed-0.7.8claws.tar.bz2 1711787
diff --git a/net-mail/sylpheed-claws/sylpheed-claws-0.7.8-r1.ebuild b/net-mail/sylpheed-claws/sylpheed-claws-0.7.8-r1.ebuild
new file mode 100644
index 000000000000..3f51137a2676
--- /dev/null
+++ b/net-mail/sylpheed-claws/sylpheed-claws-0.7.8-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/sylpheed-claws-0.7.8-r1.ebuild,v 1.1 2002/06/29 09:42:36 seemant Exp $
+
+
+MY_P="sylpheed-${PV}claws"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Bleeding edge version of Sylpheed"
+SRC_URI="mirror://sourceforge/sylpheed-claws/${MY_P}.tar.bz2"
+HOMEPAGE="http://sylpheed-claws.sf.net"
+
+SLOT=""
+LICENSE="GPL-2"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ crypt? ( >=app-crypt/gpgme-0.2.3 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.16 )
+ imlib? ( >=media-libs/imlib-1.9.10 )
+ spell? ( >=app-text/pspell-0.12.2 )
+ xface? ( >=media-libs/compface-1.4 )
+ pda? ( >=app-misc/jpilot-0.99 )"
+
+RDEPEND="$DEPEND
+ nls? ( sys-devel/gettext )"
+
+PROVIDE="virtual/sylpheed"
+
+src_compile() {
+ local myconf
+
+ use ssl && myconf="${myconf} --enable-ssl"
+
+ use crypt && myconf="${myconf} --enable-gpgme"
+
+ use gnome && \
+ myconf="${myconf} --enable-gdk-pixbuf" || \
+ myconf="${myconf} --disable-gdk-pixbuf"
+
+ use imlib && \
+ myconf="${myconf} --enable-imlib" || \
+ myconf="${myconf} --disable-imlib"
+
+ use ldap && myconf="${myconf} --enable-ldap"
+
+ use spell && myconf="${myconf} --enable-pspell"
+
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ use pda && myconf="${myconf} --enable-jpilot"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --program-suffix=-claws \
+ ${myconf} || die "./configure failed"
+
+ for i in `find . -name Makefile` ; do
+ cp $i ${i}.orig
+ sed "s/PACKAGE = sylpheed/PACKAGE = sylpheed-claws/" \
+ < ${i}.orig \
+ > ${i}
+ done
+ cp sylpheed.desktop sylpheed.desktop.orig
+ sed "s/sylpheed.png/sylpheed-claws.png/" \
+ < sylpheed.desktop.orig
+ > sylpheed.desktop
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ use gnome || rm -rf ${D}/usr/share/gnome
+
+ mv ${D}/usr/share/pixmaps/sylpheed.png \
+ ${D}/usr/share/pixmaps/sylpheed-claws.png
+}