summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-06-29 08:37:05 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-06-29 08:37:05 +0000
commit390b3fd0c28e3a347ce86379b619fe906ed206d6 (patch)
tree456a1ed889c482562e648284e8483e473c713ec0 /net-mail/sylpheed-claws-nc
parentdependency rework (diff)
downloadgentoo-2-390b3fd0c28e3a347ce86379b619fe906ed206d6.tar.gz
gentoo-2-390b3fd0c28e3a347ce86379b619fe906ed206d6.tar.bz2
gentoo-2-390b3fd0c28e3a347ce86379b619fe906ed206d6.zip
new package
Diffstat (limited to 'net-mail/sylpheed-claws-nc')
-rw-r--r--net-mail/sylpheed-claws-nc/ChangeLog10
-rw-r--r--net-mail/sylpheed-claws-nc/files/digest-sylpheed-claws-nc-0.7.81
-rw-r--r--net-mail/sylpheed-claws-nc/sylpheed-claws-nc-0.7.8.ebuild82
3 files changed, 93 insertions, 0 deletions
diff --git a/net-mail/sylpheed-claws-nc/ChangeLog b/net-mail/sylpheed-claws-nc/ChangeLog
new file mode 100644
index 000000000000..5368ac1fbc3c
--- /dev/null
+++ b/net-mail/sylpheed-claws-nc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-mail/sylpheed-claws-nc
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws-nc/ChangeLog,v 1.1 2002/06/29 08:37:05 seemant Exp $
+
+*sylpheed-claws-nc-0.7.8 (28 Jun 2002)
+
+ 28 Jun 2002; Seemant Kulleen <seemant@gentoo.org>
+ sylpheed-claws-nc-0.7.8.ebuild files/digest-sylpheed-claws-nc-0.7.8 :
+
+ New package. Thanks to Rachel Holmes for informing me of it.
diff --git a/net-mail/sylpheed-claws-nc/files/digest-sylpheed-claws-nc-0.7.8 b/net-mail/sylpheed-claws-nc/files/digest-sylpheed-claws-nc-0.7.8
new file mode 100644
index 000000000000..53a47454f1b3
--- /dev/null
+++ b/net-mail/sylpheed-claws-nc/files/digest-sylpheed-claws-nc-0.7.8
@@ -0,0 +1 @@
+MD5 a927cf3dc11845cd635e952804023bd5 sylpheed-0.7.8claws-nc.tar.bz2 1988720
diff --git a/net-mail/sylpheed-claws-nc/sylpheed-claws-nc-0.7.8.ebuild b/net-mail/sylpheed-claws-nc/sylpheed-claws-nc-0.7.8.ebuild
new file mode 100644
index 000000000000..3a149c8aa2f3
--- /dev/null
+++ b/net-mail/sylpheed-claws-nc/sylpheed-claws-nc-0.7.8.ebuild
@@ -0,0 +1,82 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws-nc/sylpheed-claws-nc-0.7.8.ebuild,v 1.1 2002/06/29 08:37:05 seemant Exp $
+
+
+MY_P="sylpheed-${PV}claws-nc"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Bleeding edge version of Sylpheed-Claws -- New Cache implementation."
+SRC_URI="mirror://sourceforge/sylpheed-claws/${MY_P}.tar.bz2"
+HOMEPAGE="http://sylpheed-claws.sf.net"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ crypt? ( >=app-crypt/gpgme-0.2.3 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.16 )
+ imlib? ( >=media-libs/imlib-1.9.10 )
+ spell? ( >=app-text/pspell-0.12.2 )
+ xface? ( >=media-libs/compface-1.4 )
+ pda? ( >=app-misc/jpilot-0.99 )"
+
+RDEPEND="$DEPEND
+ nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2"
+
+src_compile() {
+ local myconf
+
+ use ssl && myconf="${myconf} --enable-ssl"
+
+ use crypt && myconf="${myconf} --enable-gpgme"
+
+ use gnome && \
+ myconf="${myconf} --enable-gdk-pixbuf" || \
+ myconf="${myconf} --disable-gdk-pixbuf"
+
+ use imlib && \
+ myconf="${myconf} --enable-imlib" || \
+ myconf="${myconf} --disable-imlib"
+
+ use ldap && myconf="${myconf} --enable-ldap"
+
+ use spell && myconf="${myconf} --enable-pspell"
+
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ use pda && myconf="${myconf} --enable-jpilot"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --program-suffix=-claws-nc \
+ ${myconf} || die "./configure failed"
+
+ for i in `find . -name Makefile` ; do
+ cp $i ${i}.orig
+ sed "s/PACKAGE = sylpheed/PACKAGE = sylpheed-claws/" \
+ < ${i}.orig \
+ > ${i}
+ done
+ cp sylpheed.desktop sylpheed.desktop.orig
+ sed "s/sylpheed.png/sylpheed-claws.png/" \
+ < sylpheed.desktop.orig
+ > sylpheed.desktop
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ use gnome || rm -rf ${D}/usr/share/gnome
+
+ mv ${D}/usr/share/pixmaps/sylpheed.png \
+ ${D}/usr/share/pixmaps/sylpheed-claws.png
+}