summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-03-07 16:55:04 +0000
committerMike Frysinger <vapier@gentoo.org>2003-03-07 16:55:04 +0000
commit93ff04ce5d0b5f2a757aa1333d472f9410345b8f (patch)
tree4e5724485c94c71696f949cf0e199b7f7f4faa75 /net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild
parenterrno fix #17012 (diff)
downloadgentoo-2-93ff04ce5d0b5f2a757aa1333d472f9410345b8f.tar.gz
gentoo-2-93ff04ce5d0b5f2a757aa1333d472f9410345b8f.tar.bz2
gentoo-2-93ff04ce5d0b5f2a757aa1333d472f9410345b8f.zip
glibc fix #17013
Diffstat (limited to 'net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild')
-rw-r--r--net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild b/net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild
new file mode 100644
index 000000000000..1dc893efac21
--- /dev/null
+++ b/net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild,v 1.1 2003/03/07 16:55:04 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="collection of tools to help you analyze qmail's activity record"
+SRC_URI="http://cr.yp.to/software/${P}.tar.gz"
+HOMEPAGE="http://cr.yp.to/qmailanalog.html"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 sparc"
+
+DEPEND="sys-apps/groff"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-errno.patch
+}
+
+src_compile() {
+ echo "/var/qmail" > conf-home
+ echo "gcc ${CFLAGS}" > conf-cc
+ echo "gcc" > conf-ld
+
+ emake || die
+ gcc ${CFLAGS} ${FILESDIR}/tai64nfrac.c -o tai64nfrac || die
+}
+
+src_install() {
+ doman matchup.1 xqp.1 xsender.1 xrecipient.1 columnt.1
+ dodoc MATCHUP ACCOUNTING BLURB
+
+ insopts -o root -g qmail -m 755
+ insinto /var/qmail/bin
+ into /var/qmail
+ dobin columnt ddist deferrals failures matchup recipients rhosts
+ dobin rxdelay senders successes suids xqp xrecipient xsender
+ dobin zddist zdeferrals zfailures zoverall zrecipients zrhosts
+ dobin zrxdelay zsenders zsendmail zsuccesses zsuids tai64nfrac
+}