summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-09-03 15:08:59 +0000
committerIan Delaney <idella4@gentoo.org>2013-09-03 15:08:59 +0000
commita3700b803b46fe6465fc372a85abc7d16a25acea (patch)
tree5c23af3a2e527cc14758faf5364aef03831f731e /net-mail/mhonarc
parentVersion bump. (diff)
downloadgentoo-2-a3700b803b46fe6465fc372a85abc7d16a25acea.tar.gz
gentoo-2-a3700b803b46fe6465fc372a85abc7d16a25acea.tar.bz2
gentoo-2-a3700b803b46fe6465fc372a85abc7d16a25acea.zip
revbump -> EAPI 5, add IUSE examples, fix src_install
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'net-mail/mhonarc')
-rw-r--r--net-mail/mhonarc/ChangeLog9
-rw-r--r--net-mail/mhonarc/mhonarc-2.6.18-r2.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/net-mail/mhonarc/ChangeLog b/net-mail/mhonarc/ChangeLog
index 100bed82e2c2..ffcea426e9e6 100644
--- a/net-mail/mhonarc/ChangeLog
+++ b/net-mail/mhonarc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/mhonarc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mhonarc/ChangeLog,v 1.31 2012/12/27 11:48:33 kensington Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mhonarc/ChangeLog,v 1.32 2013/09/03 15:08:59 idella4 Exp $
+
+*mhonarc-2.6.18-r2 (03 Sep 2013)
+
+ 03 Sep 2013; Ian Delaney <idella4@gentoo.org> +mhonarc-2.6.18-r2.ebuild:
+ revbump -> EAPI 5, add IUSE examples, fix src_install
27 Dec 2012; Michael Palimaka <kensington@gentoo.org> -mhonarc-2.6.18.ebuild:
Remove old.
diff --git a/net-mail/mhonarc/mhonarc-2.6.18-r2.ebuild b/net-mail/mhonarc/mhonarc-2.6.18-r2.ebuild
new file mode 100644
index 000000000000..5425c99a85df
--- /dev/null
+++ b/net-mail/mhonarc/mhonarc-2.6.18-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mhonarc/mhonarc-2.6.18-r2.ebuild,v 1.1 2013/09/03 15:08:59 idella4 Exp $
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="Perl Mail-to-HTML Converter"
+HOMEPAGE="http://www.mhonarc.org/"
+SRC_URI="http://www.mhonarc.org/release/MHonArc/tar/MHonArc-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+# Warrants IUSE examples, and here it is + ? IUSE doc; see also extras folder with html docs
+IUSE="examples"
+
+RESTRICT="mirror"
+
+S="${WORKDIR}/${P/mhonarc/MHonArc}"
+mydoc="README.txt"
+
+src_install() {
+ sed -e "s|-prefix |-docpath '${D}/usr/share/doc/${PF}/html' -prefix '${D}'|g" -i Makefile || die 'sed on Makefile failed'
+ sed -e "s|installsitelib|installvendorlib|g" -i install.me || die 'sed on install.me failed'
+ perl-module_src_install
+ if use examples; then
+ docompress -x usr/share/doc/${PF}/examples
+ insinto usr/share/doc/${PF}/
+ doins -r examples/
+ fi
+}