summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-02-21 01:22:21 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-02-21 01:22:21 +0000
commitf40bb51a9804fccd2022d1fc0e2517e65a14260c (patch)
tree3786332ebcfeaa45cc8142b79d9b9379b6ba1551 /net-mail/getmail
parentGet rid of C++ symbol in Xrandr.h. (Bug #167714; Ginsu for the report, Doug (diff)
downloadgentoo-2-f40bb51a9804fccd2022d1fc0e2517e65a14260c.tar.gz
gentoo-2-f40bb51a9804fccd2022d1fc0e2517e65a14260c.tar.bz2
gentoo-2-f40bb51a9804fccd2022d1fc0e2517e65a14260c.zip
Version bump.
(Portage version: 2.1.2-r6)
Diffstat (limited to 'net-mail/getmail')
-rw-r--r--net-mail/getmail/ChangeLog7
-rw-r--r--net-mail/getmail/files/digest-getmail-4.7.23
-rw-r--r--net-mail/getmail/getmail-4.7.2.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/net-mail/getmail/ChangeLog b/net-mail/getmail/ChangeLog
index 87006a707060..cd39c5c809b1 100644
--- a/net-mail/getmail/ChangeLog
+++ b/net-mail/getmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/getmail
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.140 2007/02/02 18:07:33 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.141 2007/02/21 01:22:20 ticho Exp $
+
+*getmail-4.7.2 (21 Feb 2007)
+
+ 21 Feb 2007; Andrej Kacian <ticho@gentoo.org> +getmail-4.7.2.ebuild:
+ Version bump.
*getmail-4.7.1 (02 Feb 2007)
diff --git a/net-mail/getmail/files/digest-getmail-4.7.2 b/net-mail/getmail/files/digest-getmail-4.7.2
new file mode 100644
index 000000000000..6532a2190a30
--- /dev/null
+++ b/net-mail/getmail/files/digest-getmail-4.7.2
@@ -0,0 +1,3 @@
+MD5 17eda7b41ef9bf3eccccd907ecec5f3d getmail-4.7.2.tar.gz 147606
+RMD160 1f885e641994de03243245bd2fbb33c9032aa86a getmail-4.7.2.tar.gz 147606
+SHA256 4e1e955a30bc5d0867c67bef65fd21b50b942c616878a0f1959cc98bede4049b getmail-4.7.2.tar.gz 147606
diff --git a/net-mail/getmail/getmail-4.7.2.ebuild b/net-mail/getmail/getmail-4.7.2.ebuild
new file mode 100644
index 000000000000..7f6fe05700e1
--- /dev/null
+++ b/net-mail/getmail/getmail-4.7.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.7.2.ebuild,v 1.1 2007/02/21 01:22:20 ticho Exp $
+
+inherit distutils
+
+IUSE=""
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/python-2.3.3"
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ if has_version "=net-mail/getmail-3*" ; then
+ mv ${D}/usr/bin/getmail ${D}/usr/bin/getmail4
+ mv ${D}/usr/bin/getmail_maildir ${D}/usr/bin/getmail_maildir4
+ mv ${D}/usr/bin/getmail_mbox ${D}/usr/bin/getmail_mbox4
+ fi
+
+ # handle docs the gentoo way
+ if [ ${P} != ${PF} ]; then
+ mv ${D}/usr/share/doc/${P} ${D}/usr/share/doc/${PF}
+ fi
+
+ rm ${D}/usr/share/doc/COPYING
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/${PF}/*.html ${D}/usr/share/doc/${PF}/*.css ${D}/usr/share/doc/${PF}/html
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/getmailcore
+
+ if has_version "=net-mail/getmail-3*" ; then
+ echo
+ ewarn "An already installed instance of getmail v3 was detected. In order to"
+ ewarn "co-exist with it the three main scripts of getmail v4 were renamed to"
+ ewarn "getmail4, getmail_maildir4, getmail_mbox4."
+ echo
+ fi
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}