summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-01-26 09:28:11 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-01-26 09:28:11 +0000
commitd52b2dd65e15bedaeab9dbceb1a2a7b88b71fdfe (patch)
treeea8e8c4ab965092b8d3af083bcaf39ccc8e23385 /net-mail/ezmlm-idx
parentAdd umask support to cronolog. Patch by Mike Doty <kingtaco@gentoo.org>, conf... (diff)
downloadgentoo-2-d52b2dd65e15bedaeab9dbceb1a2a7b88b71fdfe.tar.gz
gentoo-2-d52b2dd65e15bedaeab9dbceb1a2a7b88b71fdfe.tar.bz2
gentoo-2-d52b2dd65e15bedaeab9dbceb1a2a7b88b71fdfe.zip
Multilib fix w/ revbump because it installed as broken.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/ezmlm-idx')
-rw-r--r--net-mail/ezmlm-idx/ChangeLog10
-rw-r--r--net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r1.ebuild62
2 files changed, 70 insertions, 2 deletions
diff --git a/net-mail/ezmlm-idx/ChangeLog b/net-mail/ezmlm-idx/ChangeLog
index 66f78f6124c5..7947e83649a4 100644
--- a/net-mail/ezmlm-idx/ChangeLog
+++ b/net-mail/ezmlm-idx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/ezmlm-idx
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx/ChangeLog,v 1.28 2009/09/18 20:27:24 hollow Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx/ChangeLog,v 1.29 2010/01/26 09:28:11 robbat2 Exp $
+
+*ezmlm-idx-7.0.0-r1 (26 Jan 2010)
+
+ 26 Jan 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +ezmlm-idx-7.0.0-r1.ebuild:
+ Multilib fix w/ revbump because it installed as broken.
18 Sep 2009; Benedikt Böhm <hollow@gentoo.org> ezmlm-idx-6.0.0.ebuild:
stable on amd64 wrt #265121
diff --git a/net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r1.ebuild b/net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r1.ebuild
new file mode 100644
index 000000000000..017f8ce151e8
--- /dev/null
+++ b/net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r1.ebuild,v 1.1 2010/01/26 09:28:11 robbat2 Exp $
+
+inherit qmail multilib
+
+DESCRIPTION="Simple yet powerful mailing list manager for qmail"
+HOMEPAGE="http://www.ezmlm.org"
+SRC_URI="http://www.ezmlm.org/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="mysql postgres"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-base )"
+RDEPEND="${DEPEND}
+ virtual/qmail"
+
+pkg_setup() {
+ if use mysql && use postgres; then
+ die "cannot build mysql and pgsql support at the same time"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die
+
+ echo /usr/bin > conf-bin
+ echo /usr/$(get_libdir)/ezmlm > conf-lib
+ echo /etc/ezmlm > conf-etc
+ echo /usr/share/man > conf-man
+ echo ${QMAIL_HOME} > conf-qmail
+
+ echo $(tc-getCC) ${CFLAGS} -I/usr/include/{my,postgre}sql > conf-cc
+ echo $(tc-getCC) ${CFLAGS} -Wl,-E > conf-ld
+
+ # fix DESTDIR and skip cat man-pages
+ sed -e "s:\(/install\) \(\"\`head\):\1 ${D}\2:" \
+ -e "s:\(./install.*\) < MAN$:grep -v \:/cat MAN | \1:" \
+ -e "s:\(\"\`head -n 1 conf-etc\`\"/default\):${D}\1:" \
+ -i Makefile
+}
+
+src_compile() {
+ emake it man || die "make failed"
+
+ if use mysql; then
+ emake mysql || die "make mysql failed"
+ elif use postgres; then
+ emake pgsql || die "make pgsql failed"
+ fi
+}
+
+src_install () {
+ dodir /usr/bin /usr/$(get_libdir)/ezmlm /etc/ezmlm /usr/share/man
+ dobin ezmlm-{cgi,checksub}
+
+ make DESTDIR="${D}" setup || die "make setup failed"
+}