summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-10-14 07:24:53 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-10-14 07:24:53 +0000
commit054b3b22a49766795a332b1fcc0fa3de54637a51 (patch)
tree97bd6c8d04c5153d1e762fa876c8f294eecb1402 /net-mail/checkpassword
parentBug #236138, allow building with non-modular kernels. (diff)
downloadgentoo-2-054b3b22a49766795a332b1fcc0fa3de54637a51.tar.gz
gentoo-2-054b3b22a49766795a332b1fcc0fa3de54637a51.tar.bz2
gentoo-2-054b3b22a49766795a332b1fcc0fa3de54637a51.zip
Fix bug #241040.
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-rc1-10246-gca5de40 x86_64)
Diffstat (limited to 'net-mail/checkpassword')
-rw-r--r--net-mail/checkpassword/ChangeLog6
-rw-r--r--net-mail/checkpassword/checkpassword-0.90-r2.ebuild8
-rw-r--r--net-mail/checkpassword/checkpassword-0.90-r3.ebuild4
3 files changed, 11 insertions, 7 deletions
diff --git a/net-mail/checkpassword/ChangeLog b/net-mail/checkpassword/ChangeLog
index a1120cd9ede8..343d6b80830a 100644
--- a/net-mail/checkpassword/ChangeLog
+++ b/net-mail/checkpassword/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/checkpassword
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/ChangeLog,v 1.22 2008/04/06 17:13:28 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/ChangeLog,v 1.23 2008/10/14 07:24:53 robbat2 Exp $
+
+ 14 Oct 2008; Robin H. Johnson <robbat2@gentoo.org>
+ checkpassword-0.90-r2.ebuild, checkpassword-0.90-r3.ebuild:
+ Fix bug #241040.
*checkpassword-0.90-r3 (06 Apr 2008)
diff --git a/net-mail/checkpassword/checkpassword-0.90-r2.ebuild b/net-mail/checkpassword/checkpassword-0.90-r2.ebuild
index 37d840d5b220..1c62cfc51b5b 100644
--- a/net-mail/checkpassword/checkpassword-0.90-r2.ebuild
+++ b/net-mail/checkpassword/checkpassword-0.90-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/checkpassword-0.90-r2.ebuild,v 1.4 2006/10/21 19:45:18 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/checkpassword-0.90-r2.ebuild,v 1.5 2008/10/14 07:24:53 robbat2 Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -20,11 +20,11 @@ src_unpack() {
epatch "${FILESDIR}"/${PV}-head-1.patch
use static && append-ldflags -static
- echo "$(tc-getCC) ${CFLAGS}" > conf-cc
- echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
}
src_compile() {
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
make || die "Error in make"
}
diff --git a/net-mail/checkpassword/checkpassword-0.90-r3.ebuild b/net-mail/checkpassword/checkpassword-0.90-r3.ebuild
index 1ac822a60f79..8a8be615edc2 100644
--- a/net-mail/checkpassword/checkpassword-0.90-r3.ebuild
+++ b/net-mail/checkpassword/checkpassword-0.90-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/checkpassword-0.90-r3.ebuild,v 1.1 2008/04/06 17:13:28 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/checkpassword-0.90-r3.ebuild,v 1.2 2008/10/14 07:24:53 robbat2 Exp $
inherit eutils fixheadtails flag-o-matic qmail
@@ -23,10 +23,10 @@ src_unpack() {
ht_fix_file Makefile print-cc.sh
use static && append-ldflags -static
- qmail_set_cc
}
src_compile() {
+ qmail_set_cc
make || die
}