summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-03-08 18:43:29 +0000
committerMarinus Schraal <foser@gentoo.org>2003-03-08 18:43:29 +0000
commit93fa0f6fba5734325df90498246bc3eda1412164 (patch)
tree344a6d15786d3df792186f4256e22f1c4ce84d37 /net-mail/balsa
parentnew patch, should fix persistent locale bug (diff)
downloadgentoo-2-93fa0f6fba5734325df90498246bc3eda1412164.tar.gz
gentoo-2-93fa0f6fba5734325df90498246bc3eda1412164.tar.bz2
gentoo-2-93fa0f6fba5734325df90498246bc3eda1412164.zip
minor fixes, mark stable x86
Diffstat (limited to 'net-mail/balsa')
-rw-r--r--net-mail/balsa/ChangeLog7
-rw-r--r--net-mail/balsa/balsa-2.0.9-r1.ebuild73
-rw-r--r--net-mail/balsa/files/digest-balsa-2.0.9-r11
3 files changed, 80 insertions, 1 deletions
diff --git a/net-mail/balsa/ChangeLog b/net-mail/balsa/ChangeLog
index c1db22f515ce..2cb8ba9ca095 100644
--- a/net-mail/balsa/ChangeLog
+++ b/net-mail/balsa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/balsa
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/ChangeLog,v 1.31 2003/03/03 20:23:21 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/ChangeLog,v 1.32 2003/03/08 18:43:29 foser Exp $
+
+*balsa-2.0.9-r1 (08 Mar 2003)
+
+ 08 Mar 2003; foser <foser@gentoo.org> balsa-2.0.9-r1.ebuild :
+ disabled threads because of bug #17079
*balsa-2.0.9 (03 Mar 2003)
diff --git a/net-mail/balsa/balsa-2.0.9-r1.ebuild b/net-mail/balsa/balsa-2.0.9-r1.ebuild
new file mode 100644
index 000000000000..42a4a357eea5
--- /dev/null
+++ b/net-mail/balsa/balsa-2.0.9-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-2.0.9-r1.ebuild,v 1.1 2003/03/08 18:43:29 foser Exp $
+
+inherit gnome2 eutils
+
+IUSE="ssl gtkhtml perl ldap"
+DESCRIPTION="Email client for GNOME"
+SRC_URI="http://balsa.gnome.org/${P}.tar.bz2"
+HOMEPAGE="http://balsa.gnome.org"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~sparc"
+
+RDEPEND="net-mail/mailbase
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ >=net-libs/libesmtp-0.8.11
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/libgnomeprint-2.1.4
+ >=gnome-base/libgnomeprintui-2.1.4
+ >=app-text/aspell-0.50
+ ssl? ( dev-libs/openssl )
+ perl? ( >=dev-libs/libpcre-3.4 )
+ gtkhtml? ( >=gnome-extra/libgtkhtml-2 )
+ ldap? ( net-nds/openldap )"
+
+DEPEND="dev-util/pkgconfig
+ sys-devel/gettext
+ >=app-text/scrollkeeper-0.1.4
+ ${RDEPEND}"
+
+src_compile() {
+ local myconf
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+ use gtkhtml \
+ && myconf="${myconf} --with-gtkhtml" \
+ || myconf="${myconf} --without-gtkhtml"
+ use perl \
+ && myconf="${myconf} --enable-pcre" \
+ || myconf="${myconf} --disable-pcre"
+ use ldap \
+ && myconf="${myconf} --enable-ldap" \
+ || myconf="${myconf} --disable-ldap"
+
+ libmutt/configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --with-mailpath=/var/mail || die "configure libmutt failed"
+
+ # threads diabled because of 17079
+ #myconf="${myconf} --enable-threads"
+ myconf="${myconf} --disable-threads"
+
+ econf ${myconf} || die "configure balsa failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ local myinst
+ myinst="gnomeconfdir=${D}/etc \
+ gnomedatadir=${D}/usr/share"
+
+ einstall ${myinst} || die "make install failed"
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO
+ docinto docs
+ dodoc docs/*
+}
diff --git a/net-mail/balsa/files/digest-balsa-2.0.9-r1 b/net-mail/balsa/files/digest-balsa-2.0.9-r1
new file mode 100644
index 000000000000..c6d44a72ef3b
--- /dev/null
+++ b/net-mail/balsa/files/digest-balsa-2.0.9-r1
@@ -0,0 +1 @@
+MD5 f8fc07818ee1d854d77b806d315ba0e2 balsa-2.0.9.tar.bz2 2466308