summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2007-08-07 02:13:17 +0000
committerOlivier Crête <tester@gentoo.org>2007-08-07 02:13:17 +0000
commitb1a0bc806c6a6a5504d7d34f6536f51de45730ed (patch)
tree58ce03c06bfb11dce5ded16aabd3527380bb8c84 /net-libs
parentAdd support for @RETURN values. (diff)
downloadgentoo-2-b1a0bc806c6a6a5504d7d34f6536f51de45730ed.tar.gz
gentoo-2-b1a0bc806c6a6a5504d7d34f6536f51de45730ed.tar.bz2
gentoo-2-b1a0bc806c6a6a5504d7d34f6536f51de45730ed.zip
Version bump, bug #187573
(Portage version: 2.1.2.11)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libotr/ChangeLog7
-rw-r--r--net-libs/libotr/files/digest-libotr-3.1.03
-rw-r--r--net-libs/libotr/libotr-3.1.0.ebuild30
3 files changed, 39 insertions, 1 deletions
diff --git a/net-libs/libotr/ChangeLog b/net-libs/libotr/ChangeLog
index 098c40384c38..2da3107e3c1d 100644
--- a/net-libs/libotr/ChangeLog
+++ b/net-libs/libotr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libotr
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libotr/ChangeLog,v 1.15 2007/05/04 23:21:44 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libotr/ChangeLog,v 1.16 2007/08/07 02:13:17 tester Exp $
+
+*libotr-3.1.0 (07 Aug 2007)
+
+ 07 Aug 2007; Olivier Crête <tester@gentoo.org> +libotr-3.1.0.ebuild:
+ Version bump, bug #187573
04 May 2007; Jeroen Roovers <jer@gentoo.org> libotr-3.0.0.ebuild:
Marked ~hppa (bug #176926).
diff --git a/net-libs/libotr/files/digest-libotr-3.1.0 b/net-libs/libotr/files/digest-libotr-3.1.0
new file mode 100644
index 000000000000..8b727cf5ce65
--- /dev/null
+++ b/net-libs/libotr/files/digest-libotr-3.1.0
@@ -0,0 +1,3 @@
+MD5 6266a2966cc9e00822add3175b0b77cf libotr-3.1.0.tar.gz 428444
+RMD160 8a0e1a4f84aa2b50773eddaf6b7461536842682a libotr-3.1.0.tar.gz 428444
+SHA256 721560bba21ec7e54c75925de26fe7b59ecdaf9c9b81613a052a3d86b72d7ef4 libotr-3.1.0.tar.gz 428444
diff --git a/net-libs/libotr/libotr-3.1.0.ebuild b/net-libs/libotr/libotr-3.1.0.ebuild
new file mode 100644
index 000000000000..63928b864a2c
--- /dev/null
+++ b/net-libs/libotr/libotr-3.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libotr/libotr-3.1.0.ebuild,v 1.1 2007/08/07 02:13:17 tester Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="(OTR) Messaging allows you to have private conversations over instant messaging"
+HOMEPAGE="http://www.cypherpunks.ca/otr/"
+SRC_URI="http://www.cypherpunks.ca/otr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libgpg-error
+ >=dev-libs/libgcrypt-1.2.0"
+
+src_compile() {
+ strip-flags
+ replace-flags -O? -O2
+
+ econf || die "econf failed"
+ emake -j1 || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "Install failed"
+ dodoc COPYING ChangeLog README
+}