summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-07-08 13:29:06 +0000
committerPeter Volkov <pva@gentoo.org>2009-07-08 13:29:06 +0000
commit89cc1938826255c4ab4ae4ecf2cc8fadc006a752 (patch)
tree122294b588a09b302cfaf87a2ebae73e761ca8ae /net-libs
parentAdd ~mips keywords to KDE 3.5.10 (diff)
downloadgentoo-2-89cc1938826255c4ab4ae4ecf2cc8fadc006a752.tar.gz
gentoo-2-89cc1938826255c4ab4ae4ecf2cc8fadc006a752.tar.bz2
gentoo-2-89cc1938826255c4ab4ae4ecf2cc8fadc006a752.zip
Version bump, fixes 100% cpu usage, bug #275257, thank Michael O'Brien for report. Remove affected version.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libpcap/ChangeLog10
-rw-r--r--net-libs/libpcap/files/libpcap-1.0.1_pre20090708-libnl-automagic.patch36
-rw-r--r--net-libs/libpcap/libpcap-1.0.1_pre20090708.ebuild (renamed from net-libs/libpcap/libpcap-1.0.1_pre20090616.ebuild)11
-rw-r--r--net-libs/libpcap/metadata.xml4
4 files changed, 56 insertions, 5 deletions
diff --git a/net-libs/libpcap/ChangeLog b/net-libs/libpcap/ChangeLog
index d98216862aa0..819a333ef807 100644
--- a/net-libs/libpcap/ChangeLog
+++ b/net-libs/libpcap/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/libpcap
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.120 2009/06/17 07:14:24 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.121 2009/07/08 13:29:06 pva Exp $
+
+*libpcap-1.0.1_pre20090708 (08 Jul 2009)
+
+ 08 Jul 2009; Peter Volkov <pva@gentoo.org>
+ -libpcap-1.0.1_pre20090616.ebuild, +libpcap-1.0.1_pre20090708.ebuild,
+ +files/libpcap-1.0.1_pre20090708-libnl-automagic.patch, metadata.xml:
+ Version bump, fixes 100% cpu usage, bug #275257, thank Michael O'Brien for
+ report. Remove affected version.
*libpcap-1.0.1_pre20090616 (17 Jun 2009)
diff --git a/net-libs/libpcap/files/libpcap-1.0.1_pre20090708-libnl-automagic.patch b/net-libs/libpcap/files/libpcap-1.0.1_pre20090708-libnl-automagic.patch
new file mode 100644
index 000000000000..1895dbe576ad
--- /dev/null
+++ b/net-libs/libpcap/files/libpcap-1.0.1_pre20090708-libnl-automagic.patch
@@ -0,0 +1,36 @@
+commit e61f27f56bef0f229f0bf02911f76cfcfa12f083
+Author: Peter Volkov <pva@gentoo.org>
+Date: Wed Jul 8 16:06:18 2009 +0400
+
+ Add --without-libnl configure switch
+
+ Allow build libpcap with libnl disabled even in case libnl is installed
+ at system.
+
+diff --git a/configure.in b/configure.in
+index 88a71ef..397a9c7 100644
+--- a/configure.in
++++ b/configure.in
+@@ -437,9 +437,19 @@ linux)
+ #
+ # Do we have libnl?
+ #
+- AC_CHECK_LIB(nl, nl_handle_alloc,
+- LIBS="-lnl $LIBS"
+- AC_DEFINE(HAVE_LIBNL,1,[if libnl exists]),)
++ AC_ARG_WITH(libnl,
++ AC_HELP_STRING([--without-libnl],[disable libnl support @<:@default=yes, on Linux, if present@:>@]),
++ with_libnl=$withval,,)
++
++ if test x$with_libnl != xno ; then
++ AC_CHECK_LIB(nl, nl_handle_alloc,
++ LIBS="-lnl $LIBS"
++ AC_DEFINE(HAVE_LIBNL,1,[if libnl exists]),
++ if test x$with_libnl = xyes ; then
++ AC_MSG_ERROR([libnl support requested but libnl not found])
++ fi
++ )
++ fi
+
+ AC_LBL_TPACKET_STATS
+ AC_LBL_LINUX_TPACKET_AUXDATA_TP_VLAN_TCI
diff --git a/net-libs/libpcap/libpcap-1.0.1_pre20090616.ebuild b/net-libs/libpcap/libpcap-1.0.1_pre20090708.ebuild
index 1c051a34d2fc..05ad3c7cda21 100644
--- a/net-libs/libpcap/libpcap-1.0.1_pre20090616.ebuild
+++ b/net-libs/libpcap/libpcap-1.0.1_pre20090708.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.0.1_pre20090616.ebuild,v 1.1 2009/06/17 07:14:24 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.0.1_pre20090708.ebuild,v 1.1 2009/07/08 13:29:06 pva Exp $
EAPI=2
inherit autotools eutils multilib toolchain-funcs
@@ -15,23 +15,26 @@ S=${WORKDIR}/${MY_P}
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="ipv6 bluetooth"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="bluetooth ipv6 libnl"
RDEPEND="!virtual/libpcap
- bluetooth? ( || ( net-wireless/bluez net-wireless/bluez-libs ) )"
+ bluetooth? ( || ( net-wireless/bluez net-wireless/bluez-libs ) )
+ libnl? ( dev-libs/libnl )"
DEPEND="${RDEPEND}
sys-devel/flex"
PROVIDE="virtual/libpcap"
src_prepare() {
epatch "${FILESDIR}/${PN}-1.0.0-cross-linux.patch"
+ epatch "${FILESDIR}/libpcap-1.0.1_pre20090708-libnl-automagic.patch"
echo ${PV} > VERSION # Avoid CVS in version
eautoreconf
}
src_configure() {
econf $(use_enable ipv6) \
+ $(use_with libnl) \
$(use_enable bluetooth)
}
diff --git a/net-libs/libpcap/metadata.xml b/net-libs/libpcap/metadata.xml
index 40885d6db36b..3c55993ffb88 100644
--- a/net-libs/libpcap/metadata.xml
+++ b/net-libs/libpcap/metadata.xml
@@ -3,4 +3,8 @@
<pkgmetadata>
<herd>netmon</herd>
<longdescription>A system-independent library for user-level network packet capture</longdescription>
+<use>
+ <flag name='libnl'>link with <pkg>dev-libs/libnl</pkg> (used to put wireless
+ interfaces in monitore mode)</flag>
+</use>
</pkgmetadata>