summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-05-18 21:00:08 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-05-18 21:00:08 +0000
commit637945ac0c7f7fb6d113074daf6a3b8cb9810104 (patch)
tree8cbafe23cd4fee382f4b10fe03c349ca1b8e9f31 /net-libs
parentBump to 0.97. Bug fixes, user GtkPrint for printing, and more, bug #270306. (diff)
downloadgentoo-2-637945ac0c7f7fb6d113074daf6a3b8cb9810104.tar.gz
gentoo-2-637945ac0c7f7fb6d113074daf6a3b8cb9810104.tar.bz2
gentoo-2-637945ac0c7f7fb6d113074daf6a3b8cb9810104.zip
Bump to 2.26.2. Disable TLS1.1 support for now, DNS resolution should be slightly faster, and more.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libsoup/ChangeLog9
-rw-r--r--net-libs/libsoup/libsoup-2.26.2.ebuild48
2 files changed, 56 insertions, 1 deletions
diff --git a/net-libs/libsoup/ChangeLog b/net-libs/libsoup/ChangeLog
index efe9dccd0e89..954e335af852 100644
--- a/net-libs/libsoup/ChangeLog
+++ b/net-libs/libsoup/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libsoup
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.185 2009/05/17 11:16:05 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.186 2009/05/18 21:00:08 eva Exp $
+
+*libsoup-2.26.2 (18 May 2009)
+
+ 18 May 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +libsoup-2.26.2.ebuild:
+ Bump to 2.26.2. Disable TLS1.1 support for now, DNS resolution should be
+ slightly faster, and more.
17 May 2009; Raúl Porcel <armin76@gentoo.org> libsoup-2.26.1.ebuild:
Add ~arm/~ia64/~sh wrt #268529
diff --git a/net-libs/libsoup/libsoup-2.26.2.ebuild b/net-libs/libsoup/libsoup-2.26.2.ebuild
new file mode 100644
index 000000000000..ba9efb743fdd
--- /dev/null
+++ b/net-libs/libsoup/libsoup-2.26.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.26.2.ebuild,v 1.1 2009/05/18 21:00:08 eva Exp $
+
+EAPI="2"
+
+inherit gnome2
+
+DESCRIPTION="An HTTP library implementation in C"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="2.4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~sh ~sparc ~x86 ~x86-fbsd"
+# Do NOT build with --disable-debug/--enable-debug=no - gnome2.eclass takes care of that
+IUSE="debug doc gnome ssl"
+
+RDEPEND=">=dev-libs/glib-2.15.3
+ >=dev-libs/libxml2-2
+ gnome? (
+ net-libs/libproxy
+ >=gnome-base/gconf-2
+ dev-db/sqlite:3 )
+ ssl? ( >=net-libs/gnutls-1 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+# test? (
+# www-servers/apache
+# dev-lang/php
+# net-misc/curl )
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_with gnome)
+ $(use_enable ssl)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix test to follow POSIX (for x86-fbsd)
+ # No patch to prevent having to eautoreconf
+ sed -e 's/\(test.*\)==/\1=/g' -i configure.in configure || die "sed failed"
+}