summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-09-10 17:40:35 +0000
committerMichał Górny <mgorny@gentoo.org>2011-09-10 17:40:35 +0000
commit2e924c1de367d31eba124e51f385fd1193065bb0 (patch)
tree560a2e17a6f48147425376263f2579fd0ba75854 /net-libs
parentMarked ~hppa (bug #381709). (diff)
downloadgentoo-2-2e924c1de367d31eba124e51f385fd1193065bb0.tar.gz
gentoo-2-2e924c1de367d31eba124e51f385fd1193065bb0.tar.bz2
gentoo-2-2e924c1de367d31eba124e51f385fd1193065bb0.zip
Version bump per bug #366623. Bump EAPI, migrate to autotools-utils, add USE=static-libs and dependencies for tests.
(Portage version: 2.2.0_alpha55_p1/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtorrent/ChangeLog8
-rw-r--r--net-libs/libtorrent/libtorrent-0.12.9.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index 277039983a87..f05d2624375a 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.158 2011/06/09 20:31:45 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.159 2011/09/10 17:40:35 mgorny Exp $
+
+*libtorrent-0.12.9 (10 Sep 2011)
+
+ 10 Sep 2011; Michał Górny <mgorny@gentoo.org> +libtorrent-0.12.9.ebuild:
+ Version bump per bug #366623. Bump EAPI, migrate to autotools-utils, add
+ USE=static-libs and dependencies for tests.
*libtorrent-0.12.7-r1 (09 Jun 2011)
diff --git a/net-libs/libtorrent/libtorrent-0.12.9.ebuild b/net-libs/libtorrent/libtorrent-0.12.9.ebuild
new file mode 100644
index 000000000000..f34442a69c43
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.12.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.9.ebuild,v 1.1 2011/09/10 17:40:35 mgorny Exp $
+
+EAPI=4
+inherit autotools-utils libtool
+
+DESCRIPTION="BitTorrent library written in C++ for *nix"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug ipv6 ssl static-libs test"
+
+RDEPEND=">=dev-libs/libsigc++-2.2.2:2
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ test? ( dev-util/cppunit )"
+
+# http://libtorrent.rakshasa.no/ticket/2617
+RESTRICT=test
+
+DOCS=( AUTHORS NEWS README )
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-0.12.6-gcc44.patch
+ "${FILESDIR}"/${PN}-0.12.7-test.patch
+ "${FILESDIR}"/download_constructor.diff
+ )
+ autotools-utils_src_prepare
+ elibtoolize
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-aligned
+ --with-posix-fallocate # configure will check for availability
+ $(use_enable ipv6)
+ $(use_enable ssl openssl)
+ )
+
+ autotools-utils_src_configure
+}