summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-06 09:15:10 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-06 09:15:10 +0000
commit2996c6550911bff95e53f211d4ba7ca98659e831 (patch)
treed2b37fd6166ac0b913bd608a7e8605688d26eff2 /net-libs
parentmask emesene:0 for removal (diff)
downloadgentoo-2-2996c6550911bff95e53f211d4ba7ca98659e831.tar.gz
gentoo-2-2996c6550911bff95e53f211d4ba7ca98659e831.tar.bz2
gentoo-2-2996c6550911bff95e53f211d4ba7ca98659e831.zip
Version bump; Facebook and Windows Live authentication is now enabled since it no longer requires distributing secret application keys.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gnome-online-accounts/ChangeLog11
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.4.1-r1.ebuild54
2 files changed, 63 insertions, 2 deletions
diff --git a/net-libs/gnome-online-accounts/ChangeLog b/net-libs/gnome-online-accounts/ChangeLog
index 96b516e61e03..eeb6540cd743 100644
--- a/net-libs/gnome-online-accounts/ChangeLog
+++ b/net-libs/gnome-online-accounts/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/gnome-online-accounts
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/ChangeLog,v 1.1 2011/10/29 05:57:03 tetromino Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/ChangeLog,v 1.2 2012/05/06 09:15:10 tetromino Exp $
+
+*gnome-online-accounts-3.4.1-r1 (06 May 2012)
+
+ 06 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +gnome-online-accounts-3.4.1-r1.ebuild:
+ Version bump; Facebook and Windows Live authentication is now enabled since
+ it no longer requires distributing secret application keys.
*gnome-online-accounts-3.2.1 (29 Oct 2011)
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.4.1-r1.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.4.1-r1.ebuild
new file mode 100644
index 000000000000..34a174d755b2
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.4.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/gnome-online-accounts-3.4.1-r1.ebuild,v 1.1 2012/05/06 09:15:10 tetromino Exp $
+
+EAPI="4"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc gnome +introspection"
+KEYWORDS="~amd64 ~x86"
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# Require {glib,gdbus-codegen}-2.30.0 due to GDBus API changes between 2.29.92
+# and 2.30.0
+RDEPEND="
+ >=dev-libs/glib-2.30.0:2
+ dev-libs/json-glib
+ gnome-base/libgnome-keyring
+ net-libs/libsoup:2.4
+ >=net-libs/libsoup-gnome-2.26:2.4
+ net-libs/rest:0.7
+ net-libs/webkit-gtk:3
+ >=x11-libs/gtk+-3.0.0:3
+ >=x11-libs/libnotify-0.7
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2 )"
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2 )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.30.0
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ doc? ( >=dev-util/gtk-doc-1.3 )"
+
+pkg_setup() {
+ # TODO: Give users a way to set the G/Y!/FB/Twitter/Windows Live secrets
+ G2CONF="${G2CONF}
+ --disable-static
+ --enable-documentation
+ --enable-facebook
+ --enable-windows-live"
+ DOCS="NEWS" # README is empty
+}